summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--perl-Test-Warnings.spec78
1 files changed, 38 insertions, 40 deletions
diff --git a/perl-Test-Warnings.spec b/perl-Test-Warnings.spec
index f2efa26..1d7cc2c 100644
--- a/perl-Test-Warnings.spec
+++ b/perl-Test-Warnings.spec
@@ -6,71 +6,69 @@
%define pnam Warnings
%include /usr/lib/rpm/macros.perl
Summary: Test::Warnings - Test for warnings and the lack of them
-#Summary(pl.UTF-8):
+Summary(pl.UTF-8): Test::Warnings - testowanie pod kątem ostrzeżeń i ich braku
Name: perl-Test-Warnings
-Version: 0.013
+Version: 0.020
Release: 1
-# same as perl
+# same as perl 5
License: GPL v1+ or Artistic
Group: Development/Languages/Perl
Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 417033144b2fc373830a3547e9f96fab
+# Source0-md5: c5d923fd727fea3f4b3aa91bad5ccf47
URL: http://search.cpan.org/dist/Test-Warnings/
-BuildRequires: perl-Module-Build-Tiny
BuildRequires: perl-devel >= 1:5.8.0
BuildRequires: rpm-perlprov >= 4.1-13
%if %{with tests}
-BuildRequires: perl-Test-Tester >= 0.108
BuildRequires: perl-Test-Deep
+BuildRequires: perl-Test-Simple >= 0.94
+BuildRequires: perl-Test-Tester >= 0.108
%endif
BuildArch: noarch
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
-If you've ever tried to use Test::NoWarnings to confirm there are no warnings
-generated by your tests, combined with the convenience of done_testing to
-not have to declare a
-test count,
-you'll have discovered that these two features do not play well together,
-as the test count will be calculated before the warnings test is run,
-resulting in a TAP error. (See examples/test_nowarnings.pl in this
-distribution for a demonstration.)
+If you've ever tried to use Test::NoWarnings to confirm there are no
+warnings generated by your tests, combined with the convenience of
+done_testing to not have to declare a test count, you'll have
+discovered that these two features do not play well together, as the
+test count will be calculated before the warnings test is run,
+resulting in a TAP error.
This module is intended to be used as a drop-in replacement for
-Test::NoWarnings: it also adds an extra test, but runs this test before
-done_testing calculates the test count, rather than after. It does this by
-hooking into done_testing as well as via an END block. You can declare
-a plan, or not, and things will still Just Work.
-
-It is actually equivalent to:
-
- use Test::NoWarnings 1.04 ':early';
-
-as warnings are still printed normally as they occur. You are safe, and
-enthusiastically encouraged, to perform a global search-replace of the above
-with use Test::Warnings; whether or not your tests have a plan.
-
-
-
-# %description -l pl.UTF-8
-# TODO
+Test::NoWarnings: it also adds an extra test, but runs this test
+before done_testing calculates the test count, rather than after. It
+does this by hooking into done_testing as well as via an END block.
+You can declare a plan, or not, and things will still Just Work.
+
+%description -l pl.UTF-8
+Przy próbie użycia Test::NoWarnings w celu upewnienia się, że testy
+nie generują ostrzeżeń w połączeniu z wygodą done_testing, aby nie
+trzeba było deklarować liczby testów, okazuje się, że udogodnienia te
+nie współpracują dobrze ze sobą - liczba testów jest obliczana przed
+uruchomieniem testu ostrzeżeń, czego wynikiem jest błąd TAP.
+
+Ten moduł jest pomyślany jako zamiennik Test::Nowarnings - także
+dodaje dodatkowy test, ale uruchamia go zanim done_testing obliczy
+liczbę testów, a nie po tym. Robi to przez wstawienie w done_testing,
+a także poprzez blok END. Można zadeklarować plan lub nie, a wszystko
+będzie po prostu działać.
%prep
%setup -q -n %{pdir}-%{pnam}-%{version}
%build
-%{__perl} Build.PL \
- --installdirs=vendor
-./Build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+
+%{__make}
-%{?with_tests:./Build test}
+%{?with_tests:%{__make} test}
%install
rm -rf $RPM_BUILD_ROOT
-./Build install \
- --destdir=$RPM_BUILD_ROOT \
- --create_packlist=0
+%{__make} pure_install \
+ DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -80,7 +78,7 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc Changes INSTALL README
+%doc CONTRIBUTING Changes README
%{perl_vendorlib}/Test/Warnings.pm
-%{_mandir}/man3/*
+%{_mandir}/man3/Test::Warnings.3pm*
%{_examplesdir}/%{name}-%{version}