summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cxx.patch107
-rw-r--r--format-security.patch22
-rw-r--r--openldev.spec10
3 files changed, 137 insertions, 2 deletions
diff --git a/cxx.patch b/cxx.patch
new file mode 100644
index 0000000..97793c2
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,107 @@
+--- openldev/openldev/openldev-settings/openldev-makefile-parser.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-settings/openldev-makefile-parser.cc 2014-01-28 01:25:12.200110697 +0100
+@@ -18,6 +18,7 @@
+ ***************************************************************************/
+
+ #include "openldev-makefile-parser.h"
++#include <algorithm>
+
+ bool openldev_makefile_buffer_new_variable (MakefileBuffer*, string&);
+ void openldev_makefile_buffer_new_script (MakefileBuffer*, string&);
+--- openldev/openldev/openldev-settings/openldev-project.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-settings/openldev-project.cc 2014-01-28 01:26:11.046776937 +0100
+@@ -16,7 +16,7 @@
+ * Free Software Foundation, Inc., *
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+-
++#include <cstring>
+ #include "openldev-project.h"
+
+ static void openldev_project_settings_get_makefiles (vector<string>&, string);
+--- openldev/openldev/openldev-dialogs/openldev-import-project.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-dialogs/openldev-import-project.cc 2014-01-28 01:26:43.320110038 +0100
+@@ -16,7 +16,7 @@
+ * Free Software Foundation, Inc., *
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+-
++#include <cstring>
+ #include "openldev-import-project.h"
+
+ gchar*
+--- openldev/openldev/openldev-dialogs/openldev-new-project.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-dialogs/openldev-new-project.cc 2014-01-28 01:27:03.946776555 +0100
+@@ -17,6 +17,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstring>
+ #include "openldev-new-project.h"
+
+ static void openldev_new_project_dialog_populate_combobox (NewProjectDialog*);
+--- openldev/openldev/openldev-widgets/openldev-file-browser.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-widgets/openldev-file-browser.cc 2014-01-28 01:27:27.226776385 +0100
+@@ -17,6 +17,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cstring>
+ #include "openldev-file-browser.h"
+
+ vector<string> read_directory (const char*, gboolean);
+--- openldev/openldev/openldev-widgets/openldev-status-bar.h~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-widgets/openldev-status-bar.h 2014-01-28 01:28:54.740109086 +0100
+@@ -58,17 +58,17 @@
+ \param bar A StatusBar object.
+ \param message The message to show on the status bar.
+ */
+-void openldev_status_bar_set_message (StatusBar *bar, gint bar, gchar *message);
++void openldev_status_bar_set_message (StatusBar *statusbar, gint bar, gchar *message);
+
+ /*! Set the current message on the status bar. This message is locked, so other parts of the application cannot edit it. Make sure to unlock the message when you are done! This will append a message on the stack, so when you unlock the message, it will revert to the prior.
+ \param bar A StatusBar object.
+ \param message The message to show on the status bar.
+ */
+-void openldev_status_bar_lock_message (StatusBar *bar, gint bar, gchar *message);
++void openldev_status_bar_lock_message (StatusBar *statusbar, gint bar, gchar *message);
+
+ /*! Unlock the status bar message and revert to the prior message. Make sure you do this when locking is no longer necessary!
+ \param bar A StatusBar object.
+ */
+-void openldev_status_bar_unlock_message (StatusBar *bar, gint bar);
++void openldev_status_bar_unlock_message (StatusBar *statusbar, gint bar);
+
+ #endif
+--- openldev/openldev/main.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/main.cc 2014-01-28 01:29:29.063442171 +0100
+@@ -20,6 +20,7 @@
+ #include "openldev.h"
+ #include <glade/glade.h>
+ #include <cstring>
++#include <cstdio>
+
+ static void on_destroy (GtkWidget*, gpointer);
+ static void on_find_activate (GtkEntry*, OpenLDev*);
+--- openldev/openldev/launcher/main.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/launcher/main.cc 2014-01-28 01:30:16.046775164 +0100
+@@ -20,7 +20,8 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <glib.h>
+-#include <stdlib.h>
++#include <cstdlib>
++#include <cstdio>
+ #include <iostream>
+ #include <string>
+ using namespace std;
+--- openldev/openldev/openldev-utils.cc~ 2007-03-28 17:27:58.000000000 +0200
++++ openldev/openldev/openldev-utils.cc 2014-01-28 01:30:54.303441554 +0100
+@@ -19,6 +19,7 @@
+
+ #include "openldev-utils.h"
+ #include <glade/glade.h>
++#include <cstdlib>
+
+ gchar*
+ openldev_add_prefix (gchar *text)
diff --git a/format-security.patch b/format-security.patch
new file mode 100644
index 0000000..a8a720e
--- /dev/null
+++ b/format-security.patch
@@ -0,0 +1,22 @@
+--- openldev/openldev/openldev-utils.cc~ 2014-01-28 01:33:29.000000000 +0100
++++ openldev/openldev/openldev-utils.cc 2014-01-28 01:34:43.156773230 +0100
+@@ -36,8 +36,8 @@
+ GtkWidget *dialog;
+
+ dialog = gtk_message_dialog_new (NULL, GTK_DIALOG_MODAL, type,
+- GTK_BUTTONS_CLOSE, title);
+- gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog), message);
++ GTK_BUTTONS_CLOSE, "%s", title);
++ gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog), "%s", message);
+
+ gtk_dialog_run (GTK_DIALOG (dialog));
+ gtk_widget_destroy (dialog);
+@@ -52,7 +52,7 @@
+ GtkWidget *dialog;
+
+ dialog = gtk_message_dialog_new (NULL, GTK_DIALOG_MODAL, GTK_MESSAGE_QUESTION,
+- GTK_BUTTONS_YES_NO, question);
++ GTK_BUTTONS_YES_NO, "%s", question);
+
+ if (gtk_dialog_run (GTK_DIALOG (dialog)) == GTK_RESPONSE_YES)
+ {
diff --git a/openldev.spec b/openldev.spec
index 8ffa34d..a901a15 100644
--- a/openldev.spec
+++ b/openldev.spec
@@ -2,22 +2,26 @@ Summary: Graphical front-end to gcc/g++
Summary(pl.UTF-8): Graficzna nakładka na gcc/g++
Name: openldev
Version: 1.0
-Release: 2
+Release: 3
License: GPL v2
Group: X11/Applications
Source0: http://dl.sourceforge.net/openldev/%{name}-%{version}.tar.bz2
# Source0-md5: e5345d18b6f7cafcac85e3ce66b33217
Patch0: %{name}-desktop.patch
Patch1: %{name}-makefile.patch
+Patch2: cxx.patch
+Patch3: format-security.patch
URL: http://www.openldev.org/
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gnome-vfs2-devel
BuildRequires: gtk+2-devel >= 2.6.0
BuildRequires: gtksourceview-devel >= 1.2.0
+BuildRequires: libgnomeprintui-devel
+BuildRequires: libgnomeui-devel
BuildRequires: libtool
BuildRequires: pkgconfig
-BuildRequires: vte-devel
+BuildRequires: vte0-devel
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
@@ -34,6 +38,8 @@ porzebne dla programisty C/C++.
%setup -qn %{name}
%patch0 -p1
%patch1 -p1
+%patch2 -p1
+%patch3 -p1
# workaround for hardcoded paths
sed -i -e 's|/lib/openldev|/%{_lib}/openldev|' openldev/openldev-plugin-engine.cc