summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LFS.patch23
-rw-r--r--ninja.spec2
2 files changed, 25 insertions, 0 deletions
diff --git a/LFS.patch b/LFS.patch
new file mode 100644
index 0000000..5500bc4
--- /dev/null
+++ b/LFS.patch
@@ -0,0 +1,23 @@
+Largefile patch
+https://github.com/martine/ninja/issues/829
+
+--- ninja-1.5.1/bootstrap.py~ 2014-06-28 02:37:05.000000000 +0300
++++ ninja-1.5.1/bootstrap.py 2014-10-26 22:44:01.480757832 +0200
+@@ -106,6 +106,7 @@
+ args = shlex.split(os.environ.get('CXX', 'g++'))
+ cflags.extend(['-Wno-deprecated',
+ '-DNINJA_PYTHON="' + sys.executable + '"',
++ '-D_LARGEFILE_SOURCE', '-D_FILE_OFFSET_BITS=64'
+ '-DNINJA_BOOTSTRAP'])
+ if platform.is_windows():
+ cflags.append('-D_WIN32_WINNT=0x0501')
+--- ninja-1.5.1/configure.py~ 2014-10-26 22:45:18.000000000 +0200
++++ ninja-1.5.1/configure.py 2014-10-26 22:45:26.284641172 +0200
+@@ -142,6 +142,7 @@
+ '-fno-exceptions',
+ '-fvisibility=hidden', '-pipe',
+ '-Wno-missing-field-initializers',
++ '-D_LARGEFILE_SOURCE', '-D_FILE_OFFSET_BITS=64',
+ '-DNINJA_PYTHON="%s"' % options.with_python]
+ if options.debug:
+ cflags += ['-D_GLIBCXX_DEBUG', '-D_GLIBCXX_DEBUG_PEDANTIC']
diff --git a/ninja.spec b/ninja.spec
index abc59e8..bded730 100644
--- a/ninja.spec
+++ b/ninja.spec
@@ -14,6 +14,7 @@ License: Apache v2.0
Group: Development/Tools
Source0: https://github.com/martine/ninja/archive/v%{version}/%{name}-%{version}.tar.gz
# Source0-md5: 59f4f1cf5d9bb0d7877a6d5a5afd770a
+Patch0: LFS.patch
URL: http://martine.github.com/ninja/
%{?with_doc:BuildRequires: asciidoc}
BuildRequires: libstdc++-devel
@@ -65,6 +66,7 @@ Dokumentacja do %{name}.
%prep
%setup -q
+%patch0 -p1
%build
export CXX="%{__cxx}"