summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mpd_sima.spec10
-rw-r--r--vardir.patch25
2 files changed, 5 insertions, 30 deletions
diff --git a/mpd_sima.spec b/mpd_sima.spec
index 76c6530..9414881 100644
--- a/mpd_sima.spec
+++ b/mpd_sima.spec
@@ -1,16 +1,17 @@
Summary: Automagically add titles to mpd playlist
Name: mpd_sima
-Version: 0.8.0
+Version: 0.9.0
Release: 1
License: GPL v3+
Group: Applications
-Source0: http://codingteam.net/project/sima/download/file/%{name}_%{version}.tgz
-# Source0-md5: 5c6e5790ce87c034ef4c437c214bad1d
+Source0: http://codingteam.net/project/sima/download/file/%{name}_%{version}.tar.xz
+# Source0-md5: 3c64d480ecbeec7e9b3e83a153f7ba90
Source1: %{name}.service
-Patch0: vardir.patch
URL: http://codingteam.net/project/sima
BuildRequires: rpm-pythonprov
BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
Requires: python-mpd
Requires: systemd-units >= 37-0.10
Provides: group(mpd_sima)
@@ -27,7 +28,6 @@ playlist queue is getting short.
%prep
%setup -q -n %{name}_%{version}
-%patch0 -p1
for f in src/mpd_sima src/simadb_cli; do
sed -i -e 's=#!/usr/bin/env python=#!/usr/bin/python=' $f
done
diff --git a/vardir.patch b/vardir.patch
deleted file mode 100644
index 532c95e..0000000
--- a/vardir.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- mpd_sima_0.8.0/src/utils/startopt.py.wiget 2012-02-03 14:09:03.722512780 +0100
-+++ mpd_sima_0.8.0/src/utils/startopt.py 2012-02-03 14:10:09.119982354 +0100
-@@ -52,6 +52,13 @@ def is_file_exist(option, opt_str, value
- raise OptionValueError('no access to "%s"' % value)
- setattr(parser.values, option.dest, value)
-
-+def is_directory_rwable(option, opt_str, value, parser):
-+ value = normalize_path(value)
-+ # Check either file is write-able or not
-+ if not access(value, W_OK):
-+ raise OptionValueError('no write access to "%s"' % value)
-+ setattr(parser.values, option.dest, value)
-+
- def obsolete_option(option, opt_str, value, parser):
- raise parser.error('"%s" now obsolete' % option)#}}}
-
-@@ -129,7 +136,7 @@ OPTS = list([
- 'type': 'string',
- 'dest': 'var_dir',
- 'action': 'callback',
-- 'callback': is_file_rwable,
-+ 'callback': is_directory_rwable,
- 'help': 'Directory to store var content (ie. database)'},
- {
- 'sw': ['--new-version'],