summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2013-02-18 11:17:48 (GMT)
committerElan Ruusamäe2013-02-18 11:17:48 (GMT)
commit8eca91295c35d039c63c4290152a8fde067ac2b4 (patch)
tree8b96d20a502510d16d6fe24e81d7ec444175ccb4
parent4eff655eb4863e91eb92195cade76a3815bc1280 (diff)
downloadmate-power-manager-8eca91295c35d039c63c4290152a8fde067ac2b4.zip
mate-power-manager-8eca91295c35d039c63c4290152a8fde067ac2b4.tar.gz
use libnotify, not libmatenotify forkauto/th/mate-power-manager-1.5.1-4
-rw-r--r--mate-power-manager.spec6
-rw-r--r--use-libnotify.patch65
2 files changed, 61 insertions, 10 deletions
diff --git a/mate-power-manager.spec b/mate-power-manager.spec
index d739c4e..ec08abe 100644
--- a/mate-power-manager.spec
+++ b/mate-power-manager.spec
@@ -7,13 +7,14 @@
Summary: MATE power management service
Name: mate-power-manager
Version: 1.5.1
-Release: 3
+Release: 4
License: GPL v2+
Group: X11/Applications
Source0: http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
# Source0-md5: 8ef2d2e6552461f88ac233377a5f5760
Patch0: bashism.patch
Patch1: use-gnome-keyring.patch
+Patch2: use-libnotify.patch
URL: http://wiki.mate-desktop.org/mate-power-manager
BuildRequires: cairo-devel >= 1.0.0
BuildRequires: dbus-glib-devel
@@ -25,7 +26,7 @@ BuildRequires: gtk+2-devel >= 2:2.17.7
BuildRequires: libcanberra-devel
BuildRequires: libcanberra-gtk-devel
BuildRequires: libgnome-keyring-devel >= 0.6.0
-BuildRequires: libmatenotify-devel
+BuildRequires: libnotify-devel >= 0.7.5
BuildRequires: libunique-devel
BuildRequires: mate-common
BuildRequires: mate-doc-utils
@@ -52,6 +53,7 @@ MATE session.
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1
%build
NOCONFIGURE=1 ./autogen.sh
diff --git a/use-libnotify.patch b/use-libnotify.patch
index 727e2cd..f0ac6e0 100644
--- a/use-libnotify.patch
+++ b/use-libnotify.patch
@@ -1,25 +1,23 @@
-diff -up mate-power-manager-1.5.0/configure.ac.libnotify mate-power-manager-1.5.0/configure.ac
---- mate-power-manager-1.5.0/configure.ac.libnotify 2013-02-17 03:41:22.511890196 +0100
-+++ mate-power-manager-1.5.0/configure.ac 2013-02-17 03:41:22.536889962 +0100
-@@ -106,7 +106,7 @@ GDK_REQUIRED=2.11.0
+--- mate-power-manager-1.5.1/./configure.ac 2013-02-18 13:10:23.719300158 +0200
++++ mate-power-manager-1.5.1/./configure.ac 2013-02-18 13:12:23.171483682 +0200
+@@ -106,7 +106,7 @@
GNOME_KEYRING_REQUIRED=0.6.0
DBUS_REQUIRED=1.0
DBUS_GLIB_REQUIRED=0.70
-LIBMATENOTIFY_REQUIRED=1.1.0
-+LIBMATENOTIFY_REQUIRED=0.7.5
++LIBNOTIFY_REQUIRED=0.7.5
CAIRO_REQUIRED=1.0.0
UNIQUE_REQUIRED=0.9.4
LIBPANEL_REQUIRED=1.5.0
-@@ -168,7 +168,7 @@ PKG_CHECK_EXISTS(
+@@ -168,7 +168,7 @@
[xrandr >= 1.3],
[AC_DEFINE(HAVE_XRANDR_13, 1, [xrandr 1.3 available])])
-PKG_CHECK_MODULES(LIBMATENOTIFY, libmatenotify >= $LIBMATENOTIFY_REQUIRED)
-+PKG_CHECK_MODULES(LIBMATENOTIFY, libnotify >= $LIBMATENOTIFY_REQUIRED)
++PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED)
dnl ----------------------------------------------------------------------------
dnl - Unique
-diff -up mate-power-manager-1.5.0/src/gpm-manager.c.libnotify mate-power-manager-1.5.0/src/gpm-manager.c
--- mate-power-manager-1.5.0/src/gpm-manager.c.libnotify 2012-11-08 00:42:58.000000000 +0100
+++ mate-power-manager-1.5.0/src/gpm-manager.c 2013-02-17 03:43:58.448430837 +0100
@@ -40,7 +40,7 @@
@@ -43,3 +41,54 @@ diff -up mate-power-manager-1.5.0/src/gpm-manager.c.libnotify mate-power-manager
notify_notification_set_timeout (notification, timeout);
notify_notification_set_urgency (notification, urgency);
g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);
+--- mate-power-manager-1.5.1/./applets/inhibit/Makefile.am~ 2012-11-23 04:26:11.000000000 +0200
++++ mate-power-manager-1.5.1/./applets/inhibit/Makefile.am 2013-02-18 13:11:55.123521630 +0200
+@@ -4,7 +4,7 @@
+ $(DBUS_CFLAGS) \
+ $(MATE_CFLAGS) \
+ $(PANEL_CFLAGS) \
+- $(LIBMATENOTIFY_CFLAGS) \
++ $(LIBNOTIFY_CFLAGS) \
+ $(GTKUNIQUE_CFLAGS) \
+ -DBINDIR=\"$(bindir)\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+--- mate-power-manager-1.5.1/./applets/brightness/Makefile.am~ 2012-11-23 04:26:11.000000000 +0200
++++ mate-power-manager-1.5.1/./applets/brightness/Makefile.am 2013-02-18 13:12:02.690537777 +0200
+@@ -4,7 +4,7 @@
+ $(DBUS_CFLAGS) \
+ $(MATE_CFLAGS) \
+ $(PANEL_CFLAGS) \
+- $(LIBMATENOTIFY_CFLAGS) \
++ $(LIBNOTIFY_CFLAGS) \
+ $(GTKUNIQUE_CFLAGS) \
+ -DBINDIR=\"$(bindir)\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+--- mate-power-manager-1.5.1/./src/Makefile.am 2013-02-18 13:12:11.624283712 +0200
++++ mate-power-manager-1.5.1/./src/Makefile.am 2013-02-18 13:15:12.969325736 +0200
+@@ -15,7 +15,7 @@
+ $(MATE_CFLAGS) \
+ $(UNIQUE_CFLAGS) \
+ $(X11_CFLAGS) \
+- $(LIBMATENOTIFY_CFLAGS) \
++ $(LIBNOTIFY_CFLAGS) \
+ $(CANBERRA_CFLAGS) \
+ $(GSTREAMER_CFLAGS) \
+ -DI_KNOW_THE_DEVICEKIT_POWER_API_IS_SUBJECT_TO_CHANGE \
+@@ -187,7 +187,7 @@
+ $(DBUS_LIBS) \
+ $(X11_LIBS) \
+ $(CANBERRA_LIBS) \
+- $(LIBMATENOTIFY_LIBS) \
++ $(LIBNOTIFY_LIBS) \
+ $(GPM_EXTRA_LIBS) \
+ $(UPOWER_LIBS) \
+ -lm
+@@ -254,7 +254,7 @@
+ $(UPOWER_LIBS) \
+ $(DBUS_LIBS) \
+ $(X11_LIBS) \
+- $(LIBMATENOTIFY_LIBS) \
++ $(LIBNOTIFY_LIBS) \
+ $(GPM_EXTRA_LIBS) \
+ -lm
+