summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-04-05 16:05:32 (GMT)
committerElan Ruusamäe2015-04-05 16:05:32 (GMT)
commitcfecb6568684ba255c1f949b2528924ced50e02b (patch)
tree8b0a4a283aefa3852d96205ab365c5183dfe65f7
parent35cb0f9d337a75e51b34be0dbb6b69a56ddff73e (diff)
downloadhhvm-cfecb6568684ba255c1f949b2528924ced50e02b.zip
hhvm-cfecb6568684ba255c1f949b2528924ced50e02b.tar.gz
disable fastcgi (heimdal compile failures within fbthrift)
-rw-r--r--hhvm.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/hhvm.spec b/hhvm.spec
index f9f1ce9..ac3c98b 100644
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -2,10 +2,11 @@
# Conditional build:
%bcond_without system_dconv # system double-conversion
%bcond_without system_sqlite # system sqlite3
-%bcond_without system_lz4 # system lz4
+%bcond_without system_lz4 # system lz4
%bcond_without system_fastlz # system fastlz
%bcond_with system_libafdt # system libafdt
%bcond_without system_libzip # system libzip
+%bcond_with fastcgi # enable FastCGI protocol
# cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
%bcond_with cotire # cotire (compile time reducer): Speed up the build by precompiling headers
@@ -325,6 +326,7 @@ fi
-DUSE_JEMALLOC=OFF \
-DUSE_TCMALLOC=OFF \
-DTEST_BIN=OFF \
+ -DENABLE_FASTCGI=%{!?with_fastcgi:OFF}%{?with_fastcgi:ON} \
-DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
.