summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-01-01 19:49:47 (GMT)
committerElan Ruusamäe2015-01-01 19:49:47 (GMT)
commita46def0c05393496b29c860b7806b1dbf835cdf7 (patch)
tree49f87e6c4afc8d901a2fa1e298919047d8ee7130
parent8041f44b0bec4b68a6c83b268ed987dd4f9f222b (diff)
downloadhhvm-a46def0c05393496b29c860b7806b1dbf835cdf7.zip
hhvm-a46def0c05393496b29c860b7806b1dbf835cdf7.tar.gz
revert 5b8c73a to fix $<TARGET_FILE> error with cmake 3.0
-rw-r--r--cmake.patch46
-rw-r--r--hhvm.spec2
2 files changed, 48 insertions, 0 deletions
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 0000000..c52bda1
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,46 @@
+https://github.com/facebook/hhvm/issues/4103
+
+From 5ede5bb6d8b5bb8ba094d874771c64b0480e7b7a Mon Sep 17 00:00:00 2001
+From: Sara Golemon <sgolemon@fb.com>
+Date: Fri, 31 Oct 2014 16:07:05 -0700
+Subject: [PATCH] Revert "Silence warning from CMake Policy CMP0026"
+
+Summary: This reverts commit https://github.com/facebook/hhvm/commit/5b8c73ab2bfb31d29d52c7bdba28bc58ba1dd066
+
+Reviewed By: @ptarjan
+
+Differential Revision: D1650299
+
+Signature: t1:1650299:1414713932:a1335e585ff36e5686b9b18f6513e5f4995094ba
+---
+ CMake/HPHPFunctions.cmake | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/CMake/HPHPFunctions.cmake b/CMake/HPHPFunctions.cmake
+index e65de8e..957b2a3 100644
+--- a/CMake/HPHPFunctions.cmake
++++ b/CMake/HPHPFunctions.cmake
+@@ -153,19 +153,20 @@ endfunction(embed_all_systemlibs)
+ # Custom install function that doesn't relink, instead it uses chrpath to change it, if
+ # it's available, otherwise, it leaves the chrpath alone
+ function(HHVM_INSTALL TARGET DEST)
++ get_target_property(LOC ${TARGET} LOCATION)
+ get_target_property(TY ${TARGET} TYPE)
+ if (FOUND_CHRPATH)
+ get_target_property(RPATH ${TARGET} INSTALL_RPATH)
+ if (NOT RPATH STREQUAL "RPATH-NOTFOUND")
+ if (RPATH STREQUAL "")
+- install(CODE "execute_process(COMMAND \"${CHRPATH}\" \"-d\" \"$<TARGET_FILE>\" ERROR_QUIET)")
++ install(CODE "execute_process(COMMAND \"${CHRPATH}\" \"-d\" \"${LOC}\" ERROR_QUIET)")
+ else()
+- install(CODE "execute_process(COMMAND \"${CHRPATH}\" \"-r\" \"${RPATH}\" \"$<TARGET_FILE>\" ERROR_QUIET)")
++ install(CODE "execute_process(COMMAND \"${CHRPATH}\" \"-r\" \"${RPATH}\" \"${LOC}\" ERROR_QUIET)")
+ endif()
+ endif()
+ endif()
+ string(TOUPPER ${DEST} DEST_UPPER)
+- install(CODE "FILE(INSTALL DESTINATION \"\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_${DEST_UPPER}DIR}\" TYPE ${TY} FILES \"$<TARGET_FILE>\")")
++ install(CODE "FILE(INSTALL DESTINATION \"\${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_${DEST_UPPER}DIR}\" TYPE ${TY} FILES \"${LOC}\")")
+ endfunction(HHVM_INSTALL)
+
+ function(HHVM_PUBLIC_HEADERS TARGET)
diff --git a/hhvm.spec b/hhvm.spec
index 7784287..8857d45 100644
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -49,6 +49,7 @@ Patch1: no-debug.patch
Patch2: hphpize.patch
Patch3: MAX.patch
Patch4: system-thirdparty.patch
+Patch5: cmake.patch
URL: https://github.com/facebook/hhvm/wiki
BuildRequires: ImageMagick-devel
BuildRequires: a52dec-libs-devel
@@ -254,6 +255,7 @@ mv folly-* third-party/folly/src
%patch2 -p1
%patch3 -p1
%patch4 -p1
+%patch5 -p1
# prefer ones from system
rm CMake/FindBISON.cmake