summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-07-29 19:26:59 (GMT)
committerElan Ruusamäe2015-07-29 19:26:59 (GMT)
commit9f5cfd3388ca05c17223e4730467af86a457ef85 (patch)
treeb358f28f37b0ccbfe7478da5bb0aec73ab44e3c3
parentcb8654b2225dfe6e2dc1ff8ae27e49c2b5f69e57 (diff)
downloadhhvm-9f5cfd3388ca05c17223e4730467af86a457ef85.zip
hhvm-9f5cfd3388ca05c17223e4730467af86a457ef85.tar.gz
up to 3.6.5, builds without mcrouter
-rw-r--r--hhvm.spec16
-rw-r--r--libvpx-1.4.0.patch50
-rw-r--r--mcrouter-chrono.patch61
3 files changed, 58 insertions, 69 deletions
diff --git a/hhvm.spec b/hhvm.spec
index a595de8..d54347a 100644
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -28,12 +28,12 @@
# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
%define php_version 5.6.0
-# git show HHVM-3.6.1
-%define githash c051feff88ba8050f33f10f7b1fb07f8d3415f9e
+# git show HHVM-3.6.5
+%define githash 20a30678cd67fad96602ffd93e69780d001ce57f
# these hashes are git submodules (be sure to check them on proper branch)
# GIT_DIR=third-party/.git git log -1
+# note update to '054a1e7' includes only timezonedb update
%define thirdparty 3bf14f9
-# 6e46d468cf2876dd59c7a4dddcb4e37abf070b7a
# GIT_DIR=third-party/folly/src/.git git log -1
%define folly 0.26.0
%define fbthrift d30280a
@@ -44,14 +44,14 @@
Summary: Virtual Machine, Runtime, and JIT for PHP
Name: hhvm
# we prefer LTS versions, see
-# http://hhvm.com/blog/6083/hhvm-long-term-support
+# https://github.com/facebook/hhvm/wiki/Long-term-support-(LTS)
# http://hhvm.com/blog/8849/hhvm-3-6-0
-Version: 3.6.1
+Version: 3.6.5
Release: 0.1
License: PHP 3.01 and BSD
Group: Development/Languages
Source0: https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
-# Source0-md5: 42dd1d75b4dd0785d3284e7809600c9e
+# Source0-md5: 8d3a94cbfe879127ed5c16f72a940560
Source2: https://github.com/facebook/folly/archive/v%{folly}/folly-%{folly}.tar.gz
# Source2-md5: c76a3fd2e86215d523a9fe18ba9087a1
Source3: https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
@@ -75,8 +75,8 @@ Patch5: cmake.patch
Patch6: webscalesql-5.6-build.patch
Patch7: disable-fastcgi.patch
Patch8: folly-malloc_usable_size.patch
-Patch9: mcrouter-chrono.patch
Patch10: system-webscalesqlclient.patch
+Patch11: libvpx-1.4.0.patch
URL: https://github.com/facebook/hhvm/wiki
BuildRequires: ImageMagick-devel
BuildRequires: a52dec-libs-devel
@@ -317,8 +317,8 @@ mv mcrouter-* third-party/mcrouter/src
%patch6 -p1 -d third-party/webscalesqlclient/webscalesql-5.6
%patch7 -p1
%patch8 -p1 -d third-party
-%patch9 -p1
%patch10 -p1
+%patch11 -p1
# prefer ones from system
rm CMake/FindBISON.cmake
diff --git a/libvpx-1.4.0.patch b/libvpx-1.4.0.patch
new file mode 100644
index 0000000..747d361
--- /dev/null
+++ b/libvpx-1.4.0.patch
@@ -0,0 +1,50 @@
+https://github.com/facebook/hhvm/pull/5191
+
+From a8cc58ea31e753663a59796ee973de0decbcd4b2 Mon Sep 17 00:00:00 2001
+From: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+Date: Mon, 4 May 2015 10:02:32 -0700
+Subject: [PATCH] Fix building gd extension with libvpx 1.4.0
+
+Summary: In libvpx 1.4.0 the compatibility layer for some of the older constants have been removed [1].
+The use of this constants was deprecated since 2010 in favor of the newer VPX_ prefixed names.
+The same issue as been reported in the php bugtracker [2].
+
+Thanks!
+
+[1] https://gerrit.chromium.org/gerrit/#/c/70164/3/vpx/vpx_image.h,unified
+[2] https://bugs.php.net/patch-display.php?bug_id=69479&patch=php-gd-newvpx.diff&revision=latest
+Closes https://github.com/facebook/hhvm/pull/5191
+
+Reviewed By: @fredemmott
+
+Differential Revision: D2005702
+---
+ hphp/runtime/ext/gd/libgd/webpimg.cpp | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/hphp/runtime/ext/gd/libgd/webpimg.cpp b/hphp/runtime/ext/gd/libgd/webpimg.cpp
+index 29dd633..0c1c3ba 100644
+--- a/hphp/runtime/ext/gd/libgd/webpimg.cpp
++++ b/hphp/runtime/ext/gd/libgd/webpimg.cpp
+@@ -705,14 +705,14 @@ static WebPResult VPXEncode(const uint8* Y,
+ codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
+ codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
+
+- vpx_img_wrap(&img, IMG_FMT_I420,
++ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
+ y_width, y_height, 16, (uint8*)(Y));
+- img.planes[PLANE_Y] = (uint8*)(Y);
+- img.planes[PLANE_U] = (uint8*)(U);
+- img.planes[PLANE_V] = (uint8*)(V);
+- img.stride[PLANE_Y] = y_stride;
+- img.stride[PLANE_U] = uv_stride;
+- img.stride[PLANE_V] = uv_stride;
++ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
++ img.planes[VPX_PLANE_U] = (uint8*)(U);
++ img.planes[VPX_PLANE_V] = (uint8*)(V);
++ img.stride[VPX_PLANE_Y] = y_stride;
++ img.stride[VPX_PLANE_U] = uv_stride;
++ img.stride[VPX_PLANE_V] = uv_stride;
+
+ res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
+
diff --git a/mcrouter-chrono.patch b/mcrouter-chrono.patch
deleted file mode 100644
index 18c92ca..0000000
--- a/mcrouter-chrono.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-applied for 3.6 branch:
-https://github.com/facebook/hhvm/pull/5135
-
-https://github.com/facebook/hhvm/pull/4877
-https://github.com/facebook/hhvm/commit/dae5b4c24c47abf6499e9adf8cb6dda1fd1f8df7
-
-From dae5b4c24c47abf6499e9adf8cb6dda1fd1f8df7 Mon Sep 17 00:00:00 2001
-From: Yaacov Akiba Slama <ya@slamail.org>
-Date: Mon, 23 Feb 2015 11:36:24 -0800
-Subject: [PATCH] Add mcrouter include directory after mbfl one to fix
- compilation error
-
-Summary: Fix the following error:
-```
-Building C object third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/mbfilter.c.o
-In file included from hhvm/third-party/mcrouter/config.h:11:0,
- from hhvm/third-party/libmbfl/mbfl/mbfilter.c:85:
-hhvm/third-party/mcrouter/mcrouter/mcrouter_config.h:21:18: fatal error: chrono: No such file or directory
- #include <chrono>
- ^
-compilation terminated.
-third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/build.make:54: recipe for target 'third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/mbfilter.c.o' failed
-make[2]: *** [third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/mbfilter.c.o] Error 1
-CMakeFiles/Makefile2:450: recipe for target 'third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/all' failed
-make[1]: *** [third-party/libmbfl/mbfl/CMakeFiles/mbfl.dir/all] Error 2
-Makefile:117: recipe for target 'all' failed
-make: *** [all] Error 2
-```
-Closes https://github.com/facebook/hhvm/pull/4877
-
-Reviewed By: @sgolemon
-
-Differential Revision: D1864311
----
- CMake/HPHPSetup.cmake | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/CMake/HPHPSetup.cmake b/CMake/HPHPSetup.cmake
-index 64468ce..7bcd752 100644
---- a/CMake/HPHPSetup.cmake
-+++ b/CMake/HPHPSetup.cmake
-@@ -242,15 +242,15 @@ if (NOT FASTLZ_LIBRARY)
- include_directories("${TP_DIR}/fastlz")
- endif()
-
--if (ENABLE_MCROUTER)
-- include_directories("${TP_DIR}/mcrouter")
--endif()
--
- include_directories("${TP_DIR}/timelib")
- include_directories("${TP_DIR}/libafdt/src")
- include_directories("${TP_DIR}/libmbfl")
- include_directories("${TP_DIR}/libmbfl/mbfl")
- include_directories("${TP_DIR}/libmbfl/filter")
-+if (ENABLE_MCROUTER)
-+ include_directories("${TP_DIR}/mcrouter")
-+endif()
-+
- add_definitions(-DNO_LIB_GFLAGS)
- include_directories("${TP_DIR}/folly")
- include_directories("${TP_DIR}/thrift")