summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2015-04-05 15:56:32 (GMT)
committerElan Ruusamäe2015-04-05 15:57:46 (GMT)
commit35cb0f9d337a75e51b34be0dbb6b69a56ddff73e (patch)
treed017a028571f29d2d746bb34d41476e5cd64b707
parent9f0422d0c936dac94ab178a1ac9268e011d81147 (diff)
downloadhhvm-35cb0f9d337a75e51b34be0dbb6b69a56ddff73e.zip
hhvm-35cb0f9d337a75e51b34be0dbb6b69a56ddff73e.tar.gz
update patches
-rw-r--r--MAX.patch69
-rw-r--r--hhvm.spec6
-rw-r--r--no-debug.patch17
-rw-r--r--system-thirdparty.patch24
4 files changed, 0 insertions, 116 deletions
diff --git a/MAX.patch b/MAX.patch
deleted file mode 100644
index 3e5f891..0000000
--- a/MAX.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-
-https://github.com/facebook/hhvm/commit/8207a31c26cc42fee79363a14c4a8f4fcbfffe63
-
-From 8207a31c26cc42fee79363a14c4a8f4fcbfffe63 Mon Sep 17 00:00:00 2001
-From: Jordan DeLong <jdelong@fb.com>
-Date: Mon, 6 Oct 2014 18:30:28 -0700
-Subject: [PATCH] Remove some MIN/MAX macro uses in the emitter
-
-Summary: <algorithm> has preferable type-safe versions that don't double-eval
-their args.
-
-Reviewed By: @paulbiss
-
-Differential Revision: D1599803
----
- hphp/compiler/analysis/emitter.cpp | 6 +++---
- hphp/util/compatibility.h | 4 ----
- 2 files changed, 3 insertions(+), 7 deletions(-)
-
-diff --git a/hphp/compiler/analysis/emitter.cpp b/hphp/compiler/analysis/emitter.cpp
-index 321e637..b1d3f2d 100644
---- a/hphp/compiler/analysis/emitter.cpp
-+++ b/hphp/compiler/analysis/emitter.cpp
-@@ -799,8 +799,8 @@ void SymbolicStack::push(char sym) {
- if (sym != StackSym::W && sym != StackSym::K && sym != StackSym::L &&
- sym != StackSym::T && sym != StackSym::I && sym != StackSym::H) {
- m_actualStack.push_back(m_symStack.size());
-- *m_actualStackHighWaterPtr = MAX(*m_actualStackHighWaterPtr,
-- (int)m_actualStack.size());
-+ *m_actualStackHighWaterPtr = std::max(*m_actualStackHighWaterPtr,
-+ (int)m_actualStack.size());
- }
- m_symStack.push_back(SymEntry(sym));
- }
-@@ -1010,7 +1010,7 @@ int SymbolicStack::sizeActual() const {
-
- void SymbolicStack::pushFDesc() {
- m_fdescCount += kNumActRecCells;
-- *m_fdescHighWaterPtr = MAX(*m_fdescHighWaterPtr, m_fdescCount);
-+ *m_fdescHighWaterPtr = std::max(*m_fdescHighWaterPtr, m_fdescCount);
- }
-
- void SymbolicStack::popFDesc() {
-diff --git a/hphp/util/compatibility.h b/hphp/util/compatibility.h
-index 723f6c8..43f1bc8 100644
---- a/hphp/util/compatibility.h
-+++ b/hphp/util/compatibility.h
-@@ -58,10 +58,6 @@ typedef struct {
- int dladdr(const void *addr, Dl_info *info);
- int backtrace (void **buffer, int size);
-
--// From sys/param.h
--#define MIN(a,b) (((a)<(b))?(a):(b))
--#define MAX(a,b) (((a)>(b))?(a):(b))
--
- #endif
-
- //////////////////////////////////////////////////////////////////////
---- hhvm-HHVM-3.3.2/hphp/runtime/base/zend-pack.cpp~ 2014-12-20 02:39:46.000000000 +0200
-+++ hhvm-HHVM-3.3.2/hphp/runtime/base/zend-pack.cpp 2014-12-29 13:01:04.142356895 +0200
-@@ -294,7 +294,7 @@
- case 'a':
- case 'A':
- case 'Z': {
-- int arg_cp = (code != 'Z') ? arg : MAX(0, arg - 1);
-+ int arg_cp = (code != 'Z') ? arg : std::max(0, arg - 1);
- memset(&output[outputpos], (code != 'A') ? '\0' : ' ', arg);
- val = argv[currentarg++].toString();
- s = val.c_str();
diff --git a/hhvm.spec b/hhvm.spec
index 021e3d7..f9f1ce9 100644
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -61,10 +61,7 @@ Source10: %{name}-fcgi.init
Source11: %{name}-fcgi.sysconfig
Source12: php.ini
Source100: get-source.sh
-Patch1: no-debug.patch
Patch2: hphpize.patch
-Patch3: MAX.patch
-Patch4: system-thirdparty.patch
Patch5: cmake.patch
URL: https://github.com/facebook/hhvm/wiki
BuildRequires: ImageMagick-devel
@@ -275,10 +272,7 @@ mv squangle-* third-party/squangle/squangle
rmdir third-party/proxygen/src
mv proxygen-* third-party/proxygen/src
-%patch1 -p1
%patch2 -p1
-%patch3 -p1
-%patch4 -p1
#%patch5 -p1
# prefer ones from system
diff --git a/no-debug.patch b/no-debug.patch
deleted file mode 100644
index 6e325ee..0000000
--- a/no-debug.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-as pld sets CMAKE_BUILD_TYPE to PLD, conditions like this fail:
-
-if (${CMAKE_BUILD_TYPE} MATCHES "Release")
-
-mabe PLDRelease would do better?
-
---- hhvm-HHVM-3.2.0/CMake/HPHPSetup.cmake~ 2014-07-18 03:12:10.000000000 +0300
-+++ hhvm-HHVM-3.2.0/CMake/HPHPSetup.cmake 2014-08-06 11:57:50.109380674 +0300
-@@ -81,7 +81,7 @@
- add_definitions(-D_GNU_SOURCE)
- endif()
-
--if(${CMAKE_BUILD_TYPE} MATCHES "Release")
-+if(NOT ${CMAKE_BUILD_TYPE} MATCHES "Debug")
- add_definitions(-DRELEASE=1)
- add_definitions(-DNDEBUG)
- message("Generating Release build")
diff --git a/system-thirdparty.patch b/system-thirdparty.patch
deleted file mode 100644
index bbfee4a..0000000
--- a/system-thirdparty.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-upstream fix: https://github.com/hhvm/hhvm-third-party/pull/55
-
---- hhvm-HHVM-3.3.3/third-party/CMakeLists.txt~ 2015-01-09 23:57:55.000000000 +0200
-+++ hhvm-HHVM-3.3.3/third-party/CMakeLists.txt 2015-02-05 19:11:24.761557999 +0200
-@@ -24,7 +24,6 @@
- set(THIRD_PARTY_HEADERS)
-
- list(APPEND THIRD_PARTY_MODULES
-- libafdt
- libmbfl
- timelib
- folly)
-@@ -33,6 +32,11 @@
- list(APPEND THIRD_PARTY_MODULES thrift)
- endif()
-
-+# Add bundled libafdt if the system one will not be used
-+if(NOT LIBAFDT_LIBRARY)
-+ list(APPEND THIRD_PARTY_MODULES libafdt)
-+endif()
-+
- # Add bundled fastlz if the system one will not be used
- if(NOT FASTLZ_LIBRARY)
- list(APPEND THIRD_PARTY_MODULES fastlz)