summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2005-08-28 20:24:17 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit75a762f72aee8dea20f8e03f1a5e3bc1f20bd09e (patch)
treed5ca4a7da315a8e003f61526865605c7a02c0a0c
parentf0854606a3ab806c7a4a687034b8544508c5c5ad (diff)
downloadfonts-TTF-microsoft-75a762f72aee8dea20f8e03f1a5e3bc1f20bd09e.zip
fonts-TTF-microsoft-75a762f72aee8dea20f8e03f1a5e3bc1f20bd09e.tar.gz
- fix for installing from local src.rpm
Changed files: license-installer.sh -> 1.6
-rw-r--r--license-installer.sh8
1 files changed, 5 insertions, 3 deletions
diff --git a/license-installer.sh b/license-installer.sh
index 0d3933c..4a0378b 100644
--- a/license-installer.sh
+++ b/license-installer.sh
@@ -21,16 +21,18 @@ if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
done
fi
if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
- ( cd $SRPMDIR
+ (
if echo "$3" | grep '://' >/dev/null; then
+ cd $SRPMDIR
wget --passive-ftp -t0 "$3"
else
- cp -f "$3" .
+ cp -f "$3" $SRPMDIR
+ cd $SRPMDIR
fi
rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i @BASE_NAME@.spec )
if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
for i in @COPYSOURCES@; do
- rpm2cpio $i | ( cd $TMPDIR; cpio -i $i )
+ rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i $i )
done
fi
)