summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--enchant.spec4
-rw-r--r--hunspell-1.4.patch21
2 files changed, 24 insertions, 1 deletions
diff --git a/enchant.spec b/enchant.spec
index 44b57e8..96a3dff 100644
--- a/enchant.spec
+++ b/enchant.spec
@@ -6,11 +6,12 @@ Summary: libenchant - generic spell checking library
Summary(pl.UTF-8): libenchant - ogólna biblioteka sprawdzania pisowni
Name: enchant
Version: 1.6.0
-Release: 4
+Release: 5
License: LGPL v2
Group: Libraries
Source0: http://www.abisource.com/downloads/enchant/%{version}/%{name}-%{version}.tar.gz
# Source0-md5: de11011aff801dc61042828041fb59c7
+Patch0: hunspell-1.4.patch
URL: http://www.abisource.com/enchant/
BuildRequires: aspell-devel >= 2:0.50.0
BuildRequires: autoconf
@@ -188,6 +189,7 @@ Moduł obsługujący backend zemberek (turecki) dla Enchanta.
%prep
%setup -q
+%patch0 -p1
%build
%{__libtoolize}
diff --git a/hunspell-1.4.patch b/hunspell-1.4.patch
new file mode 100644
index 0000000..601df54
--- /dev/null
+++ b/hunspell-1.4.patch
@@ -0,0 +1,21 @@
+Description: fix build with hunspell 1.4
+ hunspell 1.4.0 doesn't expose MAXWORDLEN anymore.
+Author: Caolan McNamara <caolanm@redhat.com>
+Origin: upstream bug
+Bug: http://bugzilla.abisource.com/show_bug.cgi?id=13772
+Bug-Debian: https://bugs.debian.org/821464
+
+diff -ru enchant-1.6.0-orig/src/myspell/myspell_checker.cpp enchant-1.6.0/src/myspell/myspell_checker.cpp
+--- enchant-1.6.0-orig/src/myspell/myspell_checker.cpp 2016-04-18 12:25:00.094614256 +0100
++++ enchant-1.6.0/src/myspell/myspell_checker.cpp 2016-04-18 12:26:09.108569576 +0100
+@@ -148,6 +148,10 @@ MySpellChecker::~MySpellChecker()
+ g_iconv_close(m_translate_out);
+ }
+
++#ifndef MAXWORDLEN
++# define MAXWORDLEN 100
++#endif
++
+ bool
+ MySpellChecker::checkWord(const char *utf8Word, size_t len)
+ {