summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2021-03-23 21:34:35 (GMT)
committerJan Palus2021-03-23 21:34:35 (GMT)
commit06caaf2f42deed8ccb9570d999ab87d93583bfaa (patch)
treee3c92fd8dad6fa82a2a4b3efb947bed10f1f5eec
parentc56481ad1a6757f6ebc2d672bda86eab5ca37a82 (diff)
downloaddocker-compose-auto/th/docker-compose-1.28.6-1.zip
docker-compose-auto/th/docker-compose-1.28.6-1.tar.gz
-rw-r--r--docker-compose.spec6
-rw-r--r--remove-requires-upper-bound.patch12
2 files changed, 9 insertions, 9 deletions
diff --git a/docker-compose.spec b/docker-compose.spec
index cb55f25..87ec4cc 100644
--- a/docker-compose.spec
+++ b/docker-compose.spec
@@ -7,13 +7,13 @@
%define pypi_name docker-compose
Summary: Multi-container orchestration for Docker
Name: docker-compose
-Version: 1.28.5
-Release: 2
+Version: 1.28.6
+Release: 1
License: Apache v2.0
Group: Applications/System
# https://github.com/docker/compose/releases
Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: a13bbf434827a963493932858aa2d052
+# Source0-md5: 8a41f1ccb9870f9b4f3b5b0dbda870a7
Patch0: remove-requires-upper-bound.patch
URL: https://docs.docker.com/compose/
%if %{with tests}
diff --git a/remove-requires-upper-bound.patch b/remove-requires-upper-bound.patch
index a4e9b1a..f629b3f 100644
--- a/remove-requires-upper-bound.patch
+++ b/remove-requires-upper-bound.patch
@@ -2,7 +2,7 @@
+++ docker-compose-1.27.0/requirements.txt 2020-09-07 22:17:28.372476931 +0200
@@ -1,22 +1,22 @@
-backports.shutil_get_terminal_size==1.0.0
--cached-property==1.5.1
+-cached-property==1.5.1; python_version < '3.8'
-certifi==2020.6.20
-chardet==3.0.4
-colorama==0.4.3; sys_platform == 'win32'
@@ -24,7 +24,7 @@
-urllib3==1.25.10; python_version == '3.3'
-websocket-client==0.57.0
+backports.shutil_get_terminal_size
-+cached-property
++cached-property; python_version < '3.8'
+certifi
+chardet
+colorama; sys_platform == 'win32'
@@ -47,11 +47,10 @@
+websocket-client
--- docker-compose-1.27.0/setup.py.orig 2020-09-07 22:15:24.818988058 +0200
+++ docker-compose-1.27.0/setup.py 2020-09-07 22:19:17.642592487 +0200
-@@ -25,17 +25,17 @@
+@@ -25,16 +25,16 @@
install_requires = [
-- 'cached-property >= 1.2.0, < 2',
- 'docopt >= 0.6.1, < 1',
- 'PyYAML >= 3.10, < 6',
- 'requests >= 2.20.0, < 3',
@@ -62,7 +61,6 @@
- 'dockerpty >= 0.4.1, < 1',
- 'jsonschema >= 2.5.1, < 4',
- 'python-dotenv >= 0.13.0, < 1',
-+ 'cached-property >= 1.2.0',
+ 'docopt >= 0.6.1',
+ 'PyYAML >= 3.10',
+ 'requests >= 2.20.0',
@@ -76,14 +74,16 @@
]
-@@ -49,9 +49,9 @@
+@@ -49,10 +49,10 @@
tests_require.append('mock >= 1.0.1, < 4')
extras_require = {
- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
+- ':python_version < "3.8"': ['cached-property >= 1.2.0, < 2'],
- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
++ ':python_version < "3.8"': ['cached-property >= 1.2.0'],
+ ':sys_platform == "win32"': ['colorama >= 0.4'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
'tests': tests_require,