summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2020-09-07 20:36:50 (GMT)
committerJan Palus2020-09-07 20:36:50 (GMT)
commit0d46711e0556cedb30d02701f4e4f29ef3959aee (patch)
tree52f8ecf0f627a8b5d30ec098b899ad80459b177e
parent4d286ef8423b7dac146d4c6a6d95c0602e69a4c3 (diff)
downloaddocker-compose-auto/th/docker-compose-1.27.0-1.zip
docker-compose-auto/th/docker-compose-1.27.0-1.tar.gz
- switched to python3
-rw-r--r--docker-compose.spec35
-rw-r--r--remove-requires-upper-bound.patch56
2 files changed, 34 insertions, 57 deletions
diff --git a/docker-compose.spec b/docker-compose.spec
index 790342a..127c477 100644
--- a/docker-compose.spec
+++ b/docker-compose.spec
@@ -7,31 +7,31 @@
%define pypi_name docker-compose
Summary: Multi-container orchestration for Docker
Name: docker-compose
-Version: 1.26.2
+Version: 1.27.0
Release: 1
License: Apache v2.0
Group: Applications/System
# https://github.com/docker/compose/releases
Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 74fb79ebcb35619c2a87efd4e119dfd0
+# Source0-md5: 93dac92e2415ddb1bbd58d4a4cf8d828
Patch0: remove-requires-upper-bound.patch
URL: https://docs.docker.com/compose/
%if %{with tests}
-BuildRequires: python-PyYAML
-BuildRequires: python-docker
-BuildRequires: python-docopt
-BuildRequires: python-paramiko
-BuildRequires: python-requests
-BuildRequires: python-setuptools
-BuildRequires: python-texttable
-BuildRequires: python-websocket-client
+BuildRequires: python3-PyYAML
+BuildRequires: python3-docker
+BuildRequires: python3-docopt
+BuildRequires: python3-paramiko
+BuildRequires: python3-requests
+BuildRequires: python3-setuptools
+BuildRequires: python3-texttable
+BuildRequires: python3-websocket-client
%endif
BuildRequires: rpm-pythonprov
BuildRequires: rpmbuild(macros) >= 1.714
Requires: docker(engine) >= 1.10.0
-Requires: python-docker >= 4.2.2
-Requires: python-paramiko >= 2.4.2
-Requires: python-setuptools
+Requires: python3-docker >= 4.3.1
+Requires: python3-paramiko >= 2.4.2
+Requires: python3-setuptools
BuildArch: noarch
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -53,12 +53,11 @@ Docker-compose allows you to:
rm -r docker_compose.egg-info
%build
-%py_build
+%py3_build
%install
rm -rf $RPM_BUILD_ROOT
-%py_install
-%py_postclean
+%py3_install
%clean
rm -rf $RPM_BUILD_ROOT
@@ -67,5 +66,5 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%doc CHANGELOG.md CONTRIBUTING.md README.md SWARM.md LICENSE
%attr(755,root,root) %{_bindir}/%{name}
-%{py_sitescriptdir}/%{module}
-%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
diff --git a/remove-requires-upper-bound.patch b/remove-requires-upper-bound.patch
index 93053c5..2c5b1be 100644
--- a/remove-requires-upper-bound.patch
+++ b/remove-requires-upper-bound.patch
@@ -1,37 +1,30 @@
---- docker-compose-1.26.0/requirements.txt.orig 2020-06-03 17:13:24.695266751 +0200
-+++ docker-compose-1.26.0/requirements.txt 2020-06-03 17:15:46.190749529 +0200
-@@ -1,29 +1,28 @@
+--- docker-compose-1.27.0/requirements.txt.orig 2020-09-07 22:15:24.818988058 +0200
++++ docker-compose-1.27.0/requirements.txt 2020-09-07 22:17:28.372476931 +0200
+@@ -1,23 +1,22 @@
-backports.shutil_get_terminal_size==1.0.0
--backports.ssl-match-hostname==3.5.0.1; python_version < '3'
-cached-property==1.5.1
--certifi==2020.4.5.1
+-certifi==2020.6.20
-chardet==3.0.4
-colorama==0.4.3; sys_platform == 'win32'
-distro==1.5.0
--docker==4.2.2
+-docker==4.3.1
-docker-pycreds==0.4.0
-dockerpty==0.4.1
-docopt==0.6.2
--enum34==1.1.6; python_version < '3.4'
--functools32==3.2.3.post2; python_version < '3.2'
--idna==2.8
+-idna==2.10
-ipaddress==1.0.23
-jsonschema==3.2.0
-paramiko==2.7.1
-pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
-pypiwin32==223; sys_platform == 'win32' and python_version >= '3.6'
-PySocks==1.7.1
--python-dotenv==0.13.0
--PyYAML==5.3
--requests==2.22.0
--six==1.12.0
--subprocess32==3.5.4; python_version < '3.2'
+-python-dotenv==0.14.0
+-PyYAML==5.3.1
+-requests==2.24.0
-texttable==1.6.2
--urllib3==1.25.7; python_version == '3.3'
--wcwidth==0.1.9
+-urllib3==1.25.10; python_version == '3.3'
-websocket-client==0.57.0
+backports.shutil_get_terminal_size
-+backports.ssl-match-hostname; python_version < '3'
+cached-property
+certifi
+chardet
@@ -41,26 +34,21 @@
+docker-pycreds
+dockerpty
+docopt
-+enum34; python_version < '3.4'
-+functools32; python_version < '3.2'
+idna
+ipaddress
+jsonschema
+paramiko
-+pypiwin32; sys_platform == 'win32'
++pypiwin3; sys_platform == 'win32'
+PySocks
+python-dotenv
+PyYAML
+requests
-+six
-+subprocess32; python_version < '3.2'
+texttable
+urllib3; python_version == '3.3'
-+wcwidth
+websocket-client
---- docker-compose-1.26.0/setup.py.orig 2020-06-03 17:13:24.695266751 +0200
-+++ docker-compose-1.26.0/setup.py 2020-06-03 17:17:48.769056566 +0200
-@@ -30,18 +30,18 @@
+--- docker-compose-1.27.0/setup.py.orig 2020-09-07 22:15:24.818988058 +0200
++++ docker-compose-1.27.0/setup.py 2020-09-07 22:19:17.642592487 +0200
+@@ -25,17 +25,17 @@
install_requires = [
@@ -71,9 +59,8 @@
- 'texttable >= 0.9.0, < 2',
- 'websocket-client >= 0.32.0, < 1',
- 'distro >= 1.5.0, < 2',
-- 'docker[ssh] >= 4.2.2, < 5',
+- 'docker[ssh] >= 4.3.1, < 5',
- 'dockerpty >= 0.4.1, < 1',
-- 'six >= 1.3.0, < 2',
- 'jsonschema >= 2.5.1, < 4',
- 'python-dotenv >= 0.13.0, < 1',
+ 'cached-property >= 1.2.0',
@@ -83,30 +70,21 @@
+ 'texttable >= 0.9.0',
+ 'websocket-client >= 0.32.0',
+ 'distro >= 1.5.0',
-+ 'docker[ssh] >= 4.2.2',
++ 'docker[ssh] >= 4.3.1',
+ 'dockerpty >= 0.4.1',
-+ 'six >= 1.3.0',
+ 'jsonschema >= 2.5.1',
+ 'python-dotenv >= 0.13.0',
]
-@@ -55,13 +55,13 @@
+@@ -49,9 +49,9 @@
tests_require.append('mock >= 1.0.1, < 4')
extras_require = {
-- ':python_version < "3.2"': ['subprocess32 >= 3.5.4, < 4'],
-- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
-- ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
-- 'ipaddress >= 1.0.16, < 2'],
- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
-+ ':python_version < "3.2"': ['subprocess32 >= 3.5.4'],
-+ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
-+ ':python_version < "3.3"': ['backports.shutil_get_terminal_size >= 1.0.0',
-+ 'ipaddress >= 1.0.16'],
+ ':sys_platform == "win32"': ['colorama >= 0.4'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
'tests': tests_require,