summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--zlib-asmopt.patch20
1 files changed, 9 insertions, 11 deletions
diff --git a/zlib-asmopt.patch b/zlib-asmopt.patch
index 681580a..81eba56 100644
--- a/zlib-asmopt.patch
+++ b/zlib-asmopt.patch
@@ -1,24 +1,22 @@
-diff -urN zlib-1.1.3/Makefile zlib-1.1.3.new/Makefile
-diff -urN zlib-1.1.3/Makefile.in zlib-1.1.3.new/Makefile.in
---- zlib-1.1.3/Makefile.in Thu Jul 9 18:07:18 1998
-+++ zlib-1.1.3.new/Makefile.in Thu Sep 13 09:02:28 2001
-@@ -41,7 +41,7 @@
+--- zlib-1.2.1/Makefile.in.orig 2003-11-09 03:29:23.000000000 +0100
++++ zlib-1.2.1/Makefile.in 2003-11-25 23:58:48.202584104 +0100
+@@ -49,7 +49,7 @@
OBJS = adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o \
- zutil.o inflate.o infblock.o inftrees.o infcodes.o infutil.o inffast.o
+ zutil.o inflate.o infback.o inftrees.o inffast.o
-OBJA =
+OBJA = match.o
# to use the asm code: make OBJA=match.o
TEST_OBJS = example.o minigzip.o
-@@ -79,8 +79,8 @@
+@@ -77,8 +77,8 @@
mv _match.o match.o
rm -f _match.s
--$(SHAREDLIB).$(VER): $(OBJS)
+-$(SHAREDLIBV): $(OBJS)
- $(LDSHARED) -o $@ $(OBJS)
-+$(SHAREDLIB).$(VER): $(OBJS) $(OBJA)
++$(SHAREDLIBV): $(OBJS) $(OBJA)
+ $(LDSHARED) -o $@ $(OBJS) $(OBJA)
- rm -f $(SHAREDLIB) $(SHAREDLIB).1
+ rm -f $(SHAREDLIB) $(SHAREDLIBM)
ln -s $@ $(SHAREDLIB)
- ln -s $@ $(SHAREDLIB).1
+ ln -s $@ $(SHAREDLIBM)