summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2006-01-05 17:00:01 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit9882a03122a1e50ce72464e8e4d4d64fb520515a (patch)
tree77f7507fb328e5cdf98f09345d32146b657b9137
parentca188ff5059ee8d7d8e5ec491932f68240b08b2a (diff)
downloadapache1-mod_rpaf-9882a03122a1e50ce72464e8e4d4d64fb520515a.zip
apache1-mod_rpaf-9882a03122a1e50ce72464e8e4d4d64fb520515a.tar.gz
- add ipv6 patch; rel 1
Changed files: apache1-mod_rpaf.spec -> 1.13
-rw-r--r--apache1-mod_rpaf.spec22
1 files changed, 10 insertions, 12 deletions
diff --git a/apache1-mod_rpaf.spec b/apache1-mod_rpaf.spec
index f387507..125dc96 100644
--- a/apache1-mod_rpaf.spec
+++ b/apache1-mod_rpaf.spec
@@ -1,7 +1,6 @@
-# TODO
-# - need ipv6 support
#
-%bcond_with ipv6 # disable IPv6 support
+# Conditional build:
+%bcond_without ipv6 # disable IPv6 support
#
%define mod_name rpaf
%define apxs %{_sbindir}/apxs1
@@ -9,17 +8,19 @@ Summary: Reverse proxy add forward module for Apache
Summary(pl): Moduł Apache'a dodający przekazywanie dla odwrotnych proxy
Name: apache1-mod_%{mod_name}
Version: 0.5
-Release: 0.15
+Release: 1
License: Apache
Group: Networking/Daemons
Source0: http://stderr.net/apache/rpaf/download/mod_%{mod_name}-%{version}.tar.gz
# Source0-md5: 471fb059d6223a394f319b7c8ab45c4d
Source1: %{name}.conf
+Patch0: %{name}-ipv6.patch
URL: http://stderr.net/apache/rpaf/
+%{?with_ipv6:BuildRequires: apache1(ipv6)-devel}
BuildRequires: apache1-devel >= 1.3.33-2
-%{!?with_ipv6:BuildConflicts: apache1(ipv6)-devel}
-%{!?with_ipv6:Conflicts: apache1(ipv6)}
+BuildRequires: rpmbuild(macros) >= 1.268
Requires: apache1 >= 1.3.33-2
+%{!?with_ipv6:Conflicts: apache1(ipv6)}
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
@@ -46,6 +47,7 @@ od wersji 1.3.25.
%prep
%setup -q -n mod_%{mod_name}-%{version}
+%{?with_ipv6:%patch0 -p1}
%build
%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
@@ -61,15 +63,11 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/99_mod_%{mod_name}.conf
rm -rf $RPM_BUILD_ROOT
%post
-if [ -f /var/lock/subsys/apache ]; then
- /etc/rc.d/init.d/apache restart 1>&2
-fi
+%service -q apache restart
%postun
if [ "$1" = "0" ]; then
- if [ -f /var/lock/subsys/apache ]; then
- /etc/rc.d/init.d/apache restart 1>&2
- fi
+ %service -q apache restart
fi
%files