]> git.pld-linux.org Git - packages/zimg.git/blob - zimg.spec
up to 3.0.5
[packages/zimg.git] / zimg.spec
1 # NOTE: for http://zimg.buaa.us/ see zimg-storage.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Z img - resizing, colorspace and bit depth conversion library
7 Summary(pl.UTF-8):      Z img - biblioteka do zmiany rozmiaru oraz przekształceń przestrzeni i głębi barw
8 Name:           zimg
9 Version:        3.0.5
10 Release:        1
11 License:        WTFPL v2 (library), LGPL v2.1+ (vszimg plugin)
12 Group:          Libraries
13 #Source0Download: https://github.com/sekrit-twc/zimg/releases
14 Source0:        https://github.com/sekrit-twc/zimg/archive/release-%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  af2c08cc0e695f4c0c225feed14e9f20
16 URL:            https://github.com/sekrit-twc/zimg
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  libtool >= 2:2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The "z" library implements the commonly required image processing
25 basics of scaling, colorspace conversion, and depth conversion. A
26 simple API enables conversion between any supported formats to operate
27 with minimal knowledge from the programmer. All library routines were
28 designed from the ground-up with flexibility, thread-safety, and
29 correctness as first priorities. Allocation, buffering, and I/O are
30 cleanly separated from processing, allowing the programmer to adapt
31 "z" to many scenarios.
32
33 %description -l pl.UTF-8
34 Biblioteka "z" implementuje często wymagane podstawowe operacje
35 przetwarzania obrazu, takie jak skalowanie oraz przekształcenia
36 przestrzeni i głębi barw. Proste API pozwala na konwersję między
37 dowolnymi obsługiwanymi formatami, wymagając od programisty minimum
38 wiedzy. Wszystkie funkcje biblioteki zostały zaprojektowane z myślą o
39 elastyczności, bezpiecznym użyciu współbieżnym oraz poprawnością.
40 Przydzielanie pamięci, buforowanie oraz operacje we/wy są odizolowane
41 od przetwarzania, co pozwala programiście adaptować bibliotekę "z" do
42 wielu scenariuszy.
43
44 %package devel
45 Summary:        Header files for Z img library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Z img
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libstdc++-devel >= 6:4.7
50
51 %description devel
52 Header files for Z img library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki Z img.
56
57 %package static
58 Summary:        Static Z img library
59 Summary(pl.UTF-8):      Statyczna biblioteka Z img
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static Z img library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka Z img.
68
69 %prep
70 %setup -q -n zimg-release-%{version}
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__automake}
77 %configure \
78         --disable-silent-rules \
79         %{!?with_static_libs:--disable-static} \
80 %ifarch %{ix86} %{x8664} x32
81         --enable-x86simd
82 %endif
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzimg.la
94
95 install -d $RPM_BUILD_ROOT%{_examplesdir}
96 %{__mv} $RPM_BUILD_ROOT%{_docdir}/zimg/example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/zimg
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc COPYING ChangeLog README.md
108 %attr(755,root,root) %{_libdir}/libzimg.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libzimg.so.2
110 %if 0
111 # vapoursynth plugin (no vapoursynth in PLD yet)
112 %dir %{_libdir}/zimg
113 %attr(755,root,root) %{_libdir}/zimg/vszimg.so
114 %endif
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libzimg.so
119 %{_includedir}/zimg.h
120 %{_includedir}/zimg++.hpp
121 %{_pkgconfigdir}/zimg.pc
122 %{_examplesdir}/%{name}-%{version}
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libzimg.a
128 %endif
This page took 0.075329 seconds and 4 git commands to generate.