]> git.pld-linux.org Git - packages/zeromq.git/blob - zeromq.spec
- updated to 4.3.5 (relicensed to MPL v2.0 now)
[packages/zeromq.git] / zeromq.spec
1 #
2 # Conditional build:
3 %bcond_without  gnutls          # TLS transport (GnuTLS based)
4 %bcond_with     kerberos5       # GSSAPI client support [expects MIT Kerberos]
5 %bcond_with     norm            # NORM extension
6 %bcond_without  pgm             # PGM extension (using OpenPGM library)
7 %bcond_without  tests           # build without tests
8
9 Summary:        0MQ - Zero Message Queue
10 Summary(en.UTF-8):      ØMQ - Zero Message Queue
11 Summary(pl.UTF-8):      ØMQ (Zero Message Queue) - kolejka komunikatów
12 Name:           zeromq
13 Version:        4.3.5
14 Release:        1
15 License:        MPL v2.0
16 Group:          Libraries
17 #Source0Download: https://github.com/zeromq/libzmq/releases/
18 Source0:        https://github.com/zeromq/libzmq/releases/download/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  ae933b1e98411fd7cb8309f9502d2737
20 URL:            http://www.zeromq.org/
21 BuildRequires:  asciidoc
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake
24 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.1.4}
25 %{?with_krb5:BuildRequires:     krb5-devel}
26 BuildRequires:  libbsd-devel
27 # 5.1, 5.2, 5.3 are supported
28 %{?with_pgm:BuildRequires:      libpgm-devel >= 5.1}
29 %{?with_pgm:BuildRequires:      libpgm-devel < 5.4}
30 BuildRequires:  libsodium-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libunwind-devel
34 BuildRequires:  libuuid-devel
35 %{?with_norm:BuildRequires:     norm-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  xmlto
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 The 0MQ lightweight messaging kernel is a library which extends the
43 standard socket interfaces with features traditionally provided by
44 specialised messaging middleware products. 0MQ sockets provide an
45 abstraction of asynchronous message queues, multiple messaging
46 patterns, message filtering (subscriptions), seamless access to
47 multiple transport protocols and more.
48
49 %description -l en.UTF-8
50 The ØMQ lightweight messaging kernel is a library which extends the
51 standard socket interfaces with features traditionally provided by
52 specialised messaging middleware products. ØMQ sockets provide an
53 abstraction of asynchronous message queues, multiple messaging
54 patterns, message filtering (subscriptions), seamless access to
55 multiple transport protocols and more.
56
57 %description -l pl.UTF-8
58 Lekkie jądro przekazywania komunikatów ØMQ to biblioteka rozszerzająca
59 standardowe interfejsy gniazd o możliwości zwykle udostępniane przez
60 specjalizowane produkty warstwy pośredniej do przekazywania
61 komunikatów. Gniazda ØMQ udostępniają abstrakcję asynchronicznych
62 kolejek komunikatów, wiele wzorców przekazywania komunikatów,
63 filtrowanie komunikatów (subskrypce), przezroczysty dostęp do wielu
64 protokołów transportowych i wiele innych możliwości.
65
66 %package devel
67 Summary:        0MQ library header files for development
68 Summary(en.UTF-8):      ØMQ library header files for development
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ØMQ
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 %{?with_gnutls:Requires:        gnutls >= 3.1.4}
73 Requires:       libbsd-devel
74 %{?with_pgm:Requires:   libpgm-devel >= 5.1}
75 Requires:       libsodium-devel
76 Requires:       libstdc++-devel
77 Requires:       libunwind-devel
78 Obsoletes:      zeromq-pthreads-devel < 2
79
80 %description devel
81 0MQ library header files for development.
82
83 %description devel -l en.UTF-8
84 ØMQ library header files for development.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki ØMQ.
88
89 %package static
90 Summary:        Static 0MQ library
91 Summary(en.UTF-8):      Static ØMQ library
92 Summary(pl.UTF-8):      Statyczna biblioteka ØMQ
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Obsoletes:      zeromq-pthreads-static < 2
96
97 %description static
98 Static 0MQ library.
99
100 %description static -l en.UTF-8
101 Static ØMQ library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka ØMQ.
105
106 %package -n cppzmq-devel
107 Summary:        Development files for cppzmq
108 Summary(pl.UTF-8):      Pliki programistyczne cppzmq
109 Group:          Development/Libraries
110 License:        MIT
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description -n cppzmq-devel
114 The cppzmq-devel package contains the header file for developing
115 applications that use the C++ interface for 0MQ.
116
117 %description -n cppzmq-devel -l pl.UTF-8
118 Ten pakiet zawiera plik nagłówkowy do tworzenia aplikacji
119 wykorzystujących interfejs C++ do ØMQ.
120
121 %prep
122 %setup -q
123
124 # uses some multicast networking, timeouts on some hosts
125 %{__sed} -i -e '/^\s*tests\/test_radio_dish /d' Makefile.am
126
127 %build
128 %{__libtoolize}
129 %{__aclocal}
130 %{__autoconf}
131 %{__automake}
132 %{__autoheader}
133 %configure \
134         --enable-drafts \
135         --disable-silent-rules \
136         %{?with_kerberos5:--with-libgssapi_krb5} \
137         --with-libsodium \
138         %{?with_norm:--with-norm} \
139         %{?with_pgm:--with-pgm} \
140         %{?with_gnutls:--with-tls} \
141         --disable-Werror
142 %{__make}
143
144 %if %{with tests}
145 %{__make} check -j1
146 %endif
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 # obsoleted by pkg-config
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog NEWS
166 %attr(755,root,root) %{_bindir}/curve_keygen
167 %attr(755,root,root) %{_libdir}/libzmq.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libzmq.so.5
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libzmq.so
173 %{_includedir}/zmq.h
174 %{_includedir}/zmq_utils.h
175 %{_pkgconfigdir}/libzmq.pc
176 %{_mandir}/man3/zmq*.3*
177 %{_mandir}/man7/zmq*.7*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libzmq.a
This page took 0.106105 seconds and 4 git commands to generate.