]> git.pld-linux.org Git - packages/zchunk.git/blob - zchunk.spec
- updated to 1.4.0
[packages/zchunk.git] / zchunk.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library for generating easy-to-delta files
6 Summary(pl.UTF-8):      Biblioteka do generowania plików pozwalających na łatwe generowanie różnic
7 Name:           zchunk
8 Version:        1.4.0
9 Release:        1
10 License:        BSD
11 Group:          Applications/File
12 #Source0Download: https://github.com/zchunk/zchunk/tags
13 Source0:        https://github.com/zchunk/zchunk/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e43fef37628e8a3df3daa8a46d6218a8
15 URL:            https://github.com/zchunk/zchunk
16 BuildRequires:  curl-devel
17 BuildRequires:  gcc >= 5:3.2
18 BuildRequires:  meson >= 0.53.0
19 BuildRequires:  ninja >= 1.5
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.736
23 BuildRequires:  zstd-devel >= 1.5.0
24 Requires:       %{name}-libs = %{version}-%{release}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 zchunk is a compressed file format that splits the file into
29 independent chunks. This allows you to only download changed chunks
30 when downloading a new version of the file, and also makes zchunk
31 files efficient over rsync.
32
33 zchunk files are protected with strong checksums to verify that the
34 file you downloaded is, in fact, the file you wanted.
35
36 %description -l pl.UTF-8
37 zchunk to format skompresowanych plików dzielący plik na niezależne
38 części. Pozwala to pobierać tylko zmienione części przy ściąganiu
39 nowej wersji pliku oraz czyni format wydajnym dla rsynca.
40
41 Plik zchunk są chronione silnymi sumami kontrolnymi w celu
42 weryfikacji, czy pobrany plik jest faktycznie tym, którym miał być.
43
44 %package libs
45 Summary:        Shared zck library
46 Summary(pl.UTF-8):      Biblioteka współdzielona zck
47 Group:          Libraries
48 Requires:       zstd >= 1.5.0
49
50 %description libs
51 zchunk is a compressed file format that splits the file into
52 independent chunks. This allows you to only download changed chunks
53 when downloading a new version of the file, and also makes zchunk
54 files efficient over rsync.
55
56 zchunk files are protected with strong checksums to verify that the
57 file you downloaded is, in fact, the file you wanted.
58
59 This package contains shared library.
60
61 %description libs -l pl.UTF-8
62 zchunk to format skompresowanych plików dzielący plik na niezależne
63 części. Pozwala to pobierać tylko zmienione części przy ściąganiu
64 nowej wersji pliku oraz czyni format wydajnym dla rsynca.
65
66 Plik zchunk są chronione silnymi sumami kontrolnymi w celu
67 weryfikacji, czy pobrany plik jest faktycznie tym, którym miał być.
68
69 Ten pakiet zawiera bibliotekę współdzieloną.
70
71 %package devel
72 Summary:        Header files for zck library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki zck
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       openssl-devel
77 Requires:       zstd-devel >= 1.5.0
78
79 %description devel
80 Header files for zck library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki zck.
84
85 %package static
86 Summary:        Static zck library
87 Summary(pl.UTF-8):      Statyczna biblioteka zck
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static zck library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka zck.
96
97 %prep
98 %setup -q
99
100 %build
101 %meson build \
102         %{!?with_static_libs:--default-library=shared}
103
104 %ninja_build -C build
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %ninja_install -C build
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   libs -p /sbin/ldconfig
115 %postun libs -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc LICENSE README.md
120 %attr(755,root,root) %{_bindir}/unzck
121 %attr(755,root,root) %{_bindir}/zck
122 %attr(755,root,root) %{_bindir}/zck_delta_size
123 %attr(755,root,root) %{_bindir}/zck_gen_zdict
124 %attr(755,root,root) %{_bindir}/zck_read_header
125 # R: curl
126 %attr(755,root,root) %{_bindir}/zckdl
127 %{_mandir}/man1/unzck.1*
128 %{_mandir}/man1/zck.1*
129 %{_mandir}/man1/zck_delta_size.1*
130 %{_mandir}/man1/zck_gen_zdict.1*
131 %{_mandir}/man1/zck_read_header.1*
132 %{_mandir}/man1/zckdl.1*
133
134 %files libs
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libzck.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libzck.so.1
138
139 %files devel
140 %defattr(644,root,root,755)
141 %doc zchunk_format.txt
142 %attr(755,root,root) %{_libdir}/libzck.so
143 %{_includedir}/zck.h
144 %{_pkgconfigdir}/zck.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libzck.a
150 %endif
This page took 0.228185 seconds and 4 git commands to generate.