]> git.pld-linux.org Git - packages/ykclient.git/blob - ykclient.spec
- cleanup, pl, added -static; release 2
[packages/ykclient.git] / ykclient.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Yubikey management library and client
6 Summary(pl.UTF-8):      Biblioteka i klient do zarządzania urządzeniami Yubikey
7 Name:           ykclient
8 Version:        2.15
9 Release:        2
10 License:        BSD
11 Group:          Applications/System
12 Source0:        https://developers.yubico.com/yubico-c-client/Releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  d7da4d4acc1461af06346e194aa4960b
14 URL:            https://developers.yubico.com/yubico-c-client/
15 BuildRequires:  curl-devel
16 BuildRequires:  help2man
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Yubikey management library and command line client.
22
23 %description -l pl.UTF-8
24 Biblioteka i działający z linii poleceń klient do zarządzania
25 urządzeniami Yubikey.
26
27 %package devel
28 Summary:        Development headers for ykclient library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ykclient
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Development files for ykclient library needed to build applications to
35 take advantage of Yubikey authentication.
36
37 %description devel -l pl.UTF-8
38 Pliki programistyczne biblioteki ykclient, potrzebne przy tworzeniu
39 aplikacji wykorzystujących uwierzytelnianie Yubikey.
40
41 %package static
42 Summary:        Static ykclient library
43 Summary(pl.UTF-8):      Statyczna biblioteka ykclient
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static ykclient library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka ykclient.
52
53 %prep
54 %setup -q
55
56 %build
57 %configure \
58         --disable-silent-rules \
59         %{!?with_static_libs:--disable-static}
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libykclient.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc AUTHORS COPYING ChangeLog NEWS README
79 %attr(755,root,root) %{_bindir}/ykclient
80 %attr(755,root,root) %{_libdir}/libykclient.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libykclient.so.3
82 %{_mandir}/man1/ykclient.1*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libykclient.so
87 %{_includedir}/ykclient*.h
88
89 %if %{with static_libs}
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libykclient.a
93 %endif
This page took 0.106515 seconds and 4 git commands to generate.