]> git.pld-linux.org Git - packages/yasm.git/blob - yasm.spec
- release 3 (by relup.sh)
[packages/yasm.git] / yasm.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # without Python bindings
4
5 Summary:        The YASM Modular Assembler
6 Summary(pl.UTF-8):      Modularny assembler YASM
7 Name:           yasm
8 Version:        1.3.0
9 Release:        3
10 License:        distributable (BSD, GPL, LGPL, Artistic; see COPYING)
11 Group:          Development/Tools
12 Source0:        http://www.tortall.net/projects/yasm/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  fc9e586751ff789b34b1f21d572d96af
14 Patch0:         %{name}-pythondir.patch
15 URL:            http://www.tortall.net/projects/yasm/
16 BuildRequires:  autoconf >= 2.53
17 BuildRequires:  automake >= 1:1.9.6
18 BuildRequires:  gettext-tools
19 BuildRequires:  libtool
20 %{?with_python:BuildRequires:   python-Cython >= 0.11.3}
21 BuildRequires:  xmlto
22 Obsoletes:      libyasm
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Yasm is a complete rewrite of the NASM assembler under the "new"
27 BSD License (some portions are under other licenses, see COPYING for
28 details). It is designed from the ground up to allow for multiple
29 assembler syntaxes to be supported (eg, NASM, TASM, GAS, etc.) in
30 addition to multiple output object formats and even multiple
31 instruction sets. Another primary module of the overall design is an
32 optimizer module.
33
34 %description -l pl.UTF-8
35 Yasm to całkowite przepisanie asemblera NASM na "nowej" licencji BSD
36 (niektóre fragmenty są na innych licencjach, szczegóły w pliku
37 COPYING). Jest zaprojektowany od podstaw, aby umożliwić obsługę
38 wielu składni asemblera (np. NASM, TASM, GAS itd.), a ponadto wiele
39 formatów obiektów wyjściowych, a nawet wiele zestawów instrukcji.
40 Kolejny główny moduł ogólnego projektu to moduł optymalizatora.
41
42 %package -n libyasm-devel
43 Summary:        Header files and static libyasm library
44 Summary(pl.UTF-8):      Pliki nagłówkowe i statyczna biblioteka libyasm
45 Group:          Development/Libraries
46 License:        BSD+Artistic or LGPL or GPL (see COPYING)
47 Obsoletes:      libyasm
48 Obsoletes:      libyasm-static
49
50 %description -n libyasm-devel
51 Header files and static libyasm library.
52
53 %description -n libyasm-devel -l pl.UTF-8
54 Pliki nagłówkowe i statyczna biblioteka libyasm.
55
56 %package -n python-yasm
57 Summary:        Python interface for yasm library
58 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki yasm
59 Group:          Libraries/Python
60 License:        BSD+Artistic or LGPL or GPL (see COPYING)
61
62 %description -n python-yasm
63 Python interface for yasm library.
64
65 %description -n python-yasm -l pl.UTF-8
66 Pythonowy interfejs do biblioteki yasm.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         %{?debug:--enable-debug} \
80         %{?with_python:--enable-python-bindings}
81
82 %{__make} -j1 all check
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS BSD.txt COPYING
96 %attr(755,root,root) %{_bindir}/vsyasm
97 %attr(755,root,root) %{_bindir}/yasm
98 %attr(755,root,root) %{_bindir}/ytasm
99 %{_mandir}/man1/yasm.1*
100 %{_mandir}/man7/yasm*.7*
101
102 %files -n libyasm-devel
103 %defattr(644,root,root,755)
104 %doc AUTHORS BSD.txt COPYING
105 %{_libdir}/libyasm.a
106 %{_includedir}/libyasm*.h
107 %{_includedir}/libyasm
108
109 %if %{with python}
110 %files -n python-yasm
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{py_sitedir}/yasm.so
113 %{py_sitedir}/yasm-0.0-py*.egg-info
114 %endif
This page took 0.130643 seconds and 4 git commands to generate.