]> git.pld-linux.org Git - packages/yarn.git/blob - yarn.spec
Up to 1.22.10
[packages/yarn.git] / yarn.spec
1 Summary:        Fast, reliable, and secure node dependency management
2 Name:           yarn
3 Version:        1.22.10
4 Release:        1
5 License:        BSD
6 Group:          Development/Tools
7 Source0:        https://github.com/yarnpkg/yarn/releases/download/v%{version}/%{name}-v%{version}.tar.gz
8 # Source0-md5:  52e8dbe9d0cb90683dd3ee2ebf2becb8
9 URL:            https://classic.yarnpkg.com/lang/en/
10 BuildRequires:  rpmbuild(macros) >= 1.634
11 BuildRequires:  sed >= 4.0
12 Requires:       nodejs >= 4.8.0
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Fast, reliable, and secure dependency management. Yarn: Fast,
18 reliable, and secure dependency management.
19
20 Fast: Yarn caches every package it downloads so it never needs to
21 again. It also parallelizes operations to maximize resource
22 utilization so install times are faster than ever.
23
24 Reliable: Using a detailed, but concise, lockfile format, and a
25 deterministic algorithm for installs, Yarn is able to guarantee that
26 an install that worked on one system will work exactly the same way on
27 any other system.
28
29 Secure: Yarn uses checksums to verify the integrity of every installed
30 package before its code is executed.
31
32 %prep
33 %setup -q -n %{name}-v%{version}
34
35 %{__rm} bin/*.cmd
36 %{__rm} bin/yarn
37 %{__rm} bin/yarnpkg
38 %{__sed} -i -e '1s,^#!.*node,#!/usr/bin/node,' bin/yarn.js lib/cli.js
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{nodejs_libdir}/%{name},%{_bindir}}
43
44 cp -a lib bin package.json $RPM_BUILD_ROOT%{nodejs_libdir}/%{name}
45 ln -s %{nodejs_libdir}/%{name}/bin/%{name}.js $RPM_BUILD_ROOT%{_bindir}/%{name}
46 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/yarnpkg
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc LICENSE
54 %attr(755,root,root) %{_bindir}/yarn
55 %attr(755,root,root) %{_bindir}/yarnpkg
56 %defattr(-,root,root,-)
57 %{nodejs_libdir}/%{name}
This page took 0.093434 seconds and 4 git commands to generate.