]> git.pld-linux.org Git - packages/xview.git/blob - xview.spec
- use http://ftp.debian.org/ url
[packages/xview.git] / xview.spec
1 %define         xview_ver       3.2p1.4
2 Summary:        XView libraries for X11
3 Summary(pl.UTF-8):      Biblioteki XView dla X11
4 Name:           xview
5 Version:        %{xview_ver}
6 Release:        9
7 License:        GPL
8 Group:          Development/Libraries
9 Source0:        ftp://step.polymtl.ca/pub/Xview/libs/xview/Xview-%{version}/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  b9ff26d6ad378af320bac45154ceaeba
11 Patch0:         http://ftp.debian.org/debian/pool/main/x/xview/%{name}_%{version}-25.diff.gz
12 # Patch0-md5:   215985b45696627d5808a3af3687c774
13 URL:            http://step.polymtl.ca/~coyote/xview_main.html
14 BuildRequires:  xorg-cf-files
15 BuildRequires:  xorg-lib-libX11-devel
16 BuildRequires:  xorg-lib-libXpm-devel
17 BuildRequires:  xorg-lib-libXt-devel
18 BuildRequires:  xorg-proto-xextproto-devel
19 BuildRequires:  xorg-proto-xproto-devel
20 BuildRequires:  xorg-util-gccmakedep
21 BuildRequires:  xorg-util-imake
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 XView provides a set of pre-built, user-interface objects such as
26 canvases, scrollbars, menus, and control panels. The appearance and
27 functionality of these objects follow the OPEN LOOK Graphical User
28 Interface (GUI) specification.
29
30 This is the Sun implementation of the OpenLook interface standard,
31 using the xview libraries. While somewhat outdated and superseded by
32 Motif, or gtk, it is still very useful, especially in providing
33 compatibility with older installations.
34
35 It is possible that the openwin desktop takes up much less disk space
36 to install and memory to run than modern desktops, which would make it
37 a good candidate for old hardware.
38
39 %description -l pl.UTF-8
40 XView dostarcza zestaw obiektów interfejsu użytkownika takich jak
41 scrollbary, menu, panele kontrolne. Zachowanie i funkcjonalność tych
42 obiektów jest zgodna ze specyfikacją OPEN LOOK GUI.
43
44 XView to implementacja Suna standardu OpenLook. Pomimo wieku i
45 wyparcia przez Motifa czy gtk, jest nadal użyteczna, zwłaszcza do
46 zapewnienia kompatybilności ze starymi programami.
47
48 %package devel
49 Summary:        Header files for XView development
50 Summary(pl.UTF-8):      Pliki nagłówkowe XView
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 All the files needed to develop applications that, using the XView
56 libraries, meet the OpenLook interface specifications.
57
58 %description devel -l pl.UTF-8
59 Wszystko co potrzebne do tworzenia aplikacji korzystających z
60 bibliotek XView, zgodnych ze specyfikacją interfejsu OpenLook.
61
62 %package static
63 Summary:        Static libraries for XView development
64 Summary(pl.UTF-8):      Biblioteki statyczne XView
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description static
69 Static libraries for XView development
70
71 %description static -l pl.UTF-8
72 Biblioteki statyczne XView
73
74 %package examples
75 Summary:        A number of example programs and tutorials for the XView libraries
76 Summary(pl.UTF-8):      Przykładowe programy i dokumentacja do bibliotek XView
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description examples
81 Sample programs - with source code - that cover the basics of XView
82 programming are included in this package.
83
84 Also includes documents on the XView API (Application Programming
85 Interface).
86
87 %description examples -l pl.UTF-8
88 Przykładowe programy - wraz z kodem źródłowym - pokazujące podstawy
89 programowania z użyciem XView. Pakiet zawiera też dokumentację API
90 XView.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 rm -f make
98 # now macro version shows 4.1 - olvm version, must use another macro - xview_ver
99 IMAKEINCLUDE="-I$RPM_BUILD_DIR/%{name}-%{xview_ver}/config -I%{_libdir}/X11/config"
100 export IMAKEINCLUDE
101 cd config
102 imake -DUseInstalled
103 cd ..
104 xmkmf -a
105 %{__make} \
106         CC="%{__cc}" \
107         CCOPTIONS="%{rpmcflags}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man7,%{_includedir},%{_examplesdir}/%{name}-%{version}}
112
113 for name in olgx xview; do
114         cp lib/lib$name/lib$name.a $RPM_BUILD_ROOT%{_libdir}
115         cp -d lib/lib$name/lib$name.so.* $RPM_BUILD_ROOT%{_libdir}
116 done
117
118 install xview.man $RPM_BUILD_ROOT%{_mandir}/man7/xview.7
119
120 for dir in olgx olgx_private xview xview_private pixrect; do
121         cp -aL build/include/$dir $RPM_BUILD_ROOT%{_includedir}
122 done
123
124 ln -sf libolgx.so.3.2.4 $RPM_BUILD_ROOT%{_libdir}/libolgx.so
125 ln -sf libxview.so.3.2.4 $RPM_BUILD_ROOT%{_libdir}/libxview.so
126
127 cp -a contrib/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libolgx.so.*.*
138 %attr(755,root,root) %{_libdir}/libxview.so.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libolgx.so.3
140 %attr(755,root,root) %ghost %{_libdir}/libxview.so.3
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libolgx.so
145 %attr(755,root,root) %{_libdir}/libxview.so
146 %{_mandir}/man7/xview.7*
147 %{_includedir}/olgx
148 %{_includedir}/olgx_private
149 %{_includedir}/pixrect
150 %{_includedir}/xview
151 %{_includedir}/xview_private
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libolgx.a
156 %{_libdir}/libxview.a
157
158 %files examples
159 %defattr(644,root,root,755)
160 %{_examplesdir}/%{name}-%{version}
This page took 0.111215 seconds and 4 git commands to generate.