]> git.pld-linux.org Git - packages/xorg-driver-video-qxl.git/blob - xorg-driver-video-qxl.spec
up to 0.1.6
[packages/xorg-driver-video-qxl.git] / xorg-driver-video-qxl.spec
1 #
2 # Conditional build:
3 %bcond_without  pcsc    # spiceccid PC/SC driver
4 %bcond_without  xspice  # xspice driver
5 #
6 %if %{without xspice}
7 %undefine       with_pcsc
8 %endif
9 Summary:        X.org video driver for QXL virtual GPU
10 Summary(pl.UTF-8):      Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL
11 Name:           xorg-driver-video-qxl
12 Version:        0.1.6
13 Release:        1
14 License:        MIT
15 Group:          X11/Applications
16 Source0:        https://xorg.freedesktop.org/releases/individual/driver/xf86-video-qxl-%{version}.tar.xz
17 # Source0-md5:  5d3a4ac0f6b21d62ff4e308717ff239f
18 URL:            https://xorg.freedesktop.org/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 %{?with_pcsc:BuildRequires:     libcacard-devel}
22 BuildRequires:  libdrm-devel >= 2.4.46
23 BuildRequires:  libtool
24 %{?with_pcsc:BuildRequires:     pcsc-lite-devel}
25 BuildRequires:  pkgconfig >= 1:0.19
26 BuildRequires:  rpmbuild(macros) >= 1.389
27 BuildRequires:  spice-protocol >= 0.12.0
28 %{?with_xspice:BuildRequires:   spice-server-devel >= 0.6.3}
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  udev-devel
31 BuildRequires:  xorg-lib-libXfont2-devel >= 2
32 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
33 BuildRequires:  xorg-proto-fontsproto-devel
34 BuildRequires:  xorg-proto-randrproto-devel
35 BuildRequires:  xorg-proto-renderproto-devel
36 BuildRequires:  xorg-proto-videoproto-devel
37 BuildRequires:  xorg-proto-xf86dgaproto-devel
38 BuildRequires:  xorg-proto-xproto-devel
39 BuildRequires:  xorg-util-util-macros >= 1.4
40 BuildRequires:  xorg-xserver-server-devel >= 1.0.99.901
41 BuildRequires:  xz
42 %{?requires_xorg_xserver_videodrv}
43 Requires:       libdrm >= 2.4.46
44 Requires:       xorg-lib-libpciaccess >= 0.10.0
45 Requires:       xorg-xserver-server >= 1.0.99.901
46 Provides:       xorg-driver-video
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 X.org video driver for QXL virtual GPU, which can be found in the
51 RedHat Enterprise Virtualisation system, and also in the spice
52 project.
53
54 %description -l pl.UTF-8
55 Sterownik obrazu X.org dla wirtualnych procesorów graficznych QXL,
56 które można znaleźć w systemie RedHat Enterprise Virtualisation oraz w
57 projekcie spice.
58
59 %package -n pcsc-driver-spiceccid
60 Summary:        Chip/Smart Card Interface Devices driver for Spice
61 Summary(pl.UTF-8):      Sterownik CCID dla Spice
62 Group:          Libraries
63 Requires:       pcsc-lite
64
65 %description -n pcsc-driver-spiceccid
66 Chip/Smart Card Interface Devices driver for Spice.
67
68 This driver is built to interface to pcsc-lite as a serial smartcard
69 device. It translates the IFD (Interface device) ABI into the Spice
70 protocol.
71
72 %description -n pcsc-driver-spiceccid -l pl.UTF-8
73 Sterownik CCID (Chip/Smart Card Interface Device) dla Spice.
74
75 Ten sterownik współpracuje z pcsc-lite jako szeregowy czytnik kart
76 procesorowych. Tłumaczy ABI IFD (Interface device) na protokół Spice.
77
78 %package -n spice-xserver
79 Summary:        Xspice - X server and Spice server in one
80 Summary(pl.UTF-8):      Xspice - serwer X oraz serwer Spice w jednym
81 Group:          X11/Applications
82 Requires:       spice-server-libs >= 0.6.3
83 Requires:       xorg-xserver-server >= 1.0.99.901
84
85 %description -n spice-xserver
86 Xspice is an X server and Spice server in one. It consists of a
87 wrapper script for executing Xorg with the right parameters and
88 environment variables, a module named spiceqxl_drv.so implementing
89 three drivers: a video mostly code identical to the guest qxl X
90 driver, and keyboard and mouse reading from the spice inputs channel.
91
92 Xspice allows regular X connections, while a spice client provides the
93 keyboard and mouse and video output.
94
95 %description -n spice-xserver -l pl.UTF-8
96 Xspice to serwer X i serwer Spice w jednym. Składa się ze skryptu
97 wywołującego Xorg z właściwymi parametrami i zmiennymi środowiskowymi,
98 oraz modułu o nazwie spiceqxl_drv.so implementującego trzy sterowniki:
99 graficzny oparty na kodzie prawie identycznym ze sterownikiem X gościa
100 qxl, oraz klawiatury i myszy szytające z kanału wejćiowego spice.
101
102 Xspice pozwala na normalne połączenia X, podczas gdy klient spice
103 udostępnia wejście klawiatury i myszy oraz wyjście obrazu.
104
105 %prep
106 %setup -q -n xf86-video-qxl-%{version}
107
108 %{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
109       scripts/Xspice
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         %{?with_pcsc:--enable-ccid --with-ccid-module-dir=%{_libdir}/pcsc/drivers} \
119         %{?with_xspice:--enable-xspice}
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la
130 %if %{with pcsc}
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers/*.la
132 %endif
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc COPYING ChangeLog NEWS README.md TODO
140 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/qxl_drv.so
141
142 %if %{with pcsc}
143 %files -n pcsc-driver-spiceccid
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/pcsc/drivers/libspiceccid.so*
146 %endif
147
148 %if %{with xspice}
149 %files -n spice-xserver
150 %defattr(644,root,root,755)
151 %doc README.xspice examples/spiceqxl.xorg.conf.example
152 %attr(755,root,root) %{_bindir}/Xspice
153 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/spiceqxl_drv.so
154 %endif
This page took 0.096449 seconds and 3 git commands to generate.