]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia.git/commitdiff
split kernel 4.7 compatibility patch into non-uvm and uvm parts auto/th/xorg-driver-video-nvidia-367.35-2
authorJan Palus <atler@pld-linux.org>
Tue, 2 Aug 2016 20:40:48 +0000 (22:40 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 2 Aug 2016 20:42:08 +0000 (22:42 +0200)
uvm is only present on 64bit

linux-4.7-uvm.patch [new file with mode: 0644]
linux-4.7.patch
xorg-driver-video-nvidia.spec

diff --git a/linux-4.7-uvm.patch b/linux-4.7-uvm.patch
new file mode 100644 (file)
index 0000000..786db7f
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/kernel/nvidia-uvm/uvm_linux.h
++++ b/kernel/nvidia-uvm/uvm_linux.h
+@@ -547,7 +547,11 @@
+     INIT_RADIX_TREE(tree, GFP_NOWAIT);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 7, 0)
++static bool radix_tree_is_empty(struct radix_tree_root *tree)
++#else
+ static bool radix_tree_empty(struct radix_tree_root *tree)
++#endif
+ {
+     void *dummy;
+     return radix_tree_gang_lookup(tree, &dummy, 0, 1) == 0;
+
index 0dc12c8a06a782b881b1ab55c183fb4e2de9a7fb..97a0b482ae56de621d453a003f5b955317b51c3b 100644 (file)
      if (gem == NULL)
      {
 
---- a/kernel/nvidia-uvm/uvm_linux.h
-+++ b/kernel/nvidia-uvm/uvm_linux.h
-@@ -547,7 +547,11 @@
-     INIT_RADIX_TREE(tree, GFP_NOWAIT);
- }
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 7, 0)
-+static bool radix_tree_is_empty(struct radix_tree_root *tree)
-+#else
- static bool radix_tree_empty(struct radix_tree_root *tree)
-+#endif
- {
-     void *dummy;
-     return radix_tree_gang_lookup(tree, &dummy, 0, 1) == 0;
-
index f6f6de2a16e0d2e792d7e89658ec6884c3a5bbb3..3a1e8e0a1b9a9dbd1b340771de8fd3cc921bc47e 100644 (file)
@@ -48,6 +48,7 @@ Source5:      10-nvidia-modules.conf
 Patch0:                X11-driver-nvidia-GL.patch
 Patch1:                X11-driver-nvidia-desktop.patch
 Patch2:                linux-4.7.patch
+Patch3:                linux-4.7-uvm.patch
 URL:           http://www.nvidia.com/object/unix.html
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -253,6 +254,9 @@ rm -rf NVIDIA-Linux-x86*-%{version}*
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%ifarch %{x8664}
+%patch3 -p1
+%endif
 echo 'EXTRA_CFLAGS += -Wno-pointer-arith -Wno-sign-compare -Wno-unused' >> kernel/Makefile.kbuild
 
 %build
This page took 0.041928 seconds and 4 git commands to generate.