]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia.git/blobdiff - xorg-driver-video-nvidia.spec
- updated to 7667, this removes support for many old cars,
[packages/xorg-driver-video-nvidia.git] / xorg-driver-video-nvidia.spec
index 8c6f994f868716ba51786a3fbe4b7dd79490d882..6567a173b2f9f19423801a525e165b030854d19e 100644 (file)
@@ -3,13 +3,29 @@
 %bcond_without dist_kernel     # without distribution kernel
 %bcond_without smp             # without smp packages
 %bcond_without kernel          # without kernel packages
+%bcond_without incall          # include all tarballs
 %bcond_with    verbose         # verbose build (V=1)
 #
 %define                _nv_ver         1.0
-%define                _nv_rel         6629
+%define                _nv_rel         7667
 %define                _min_x11        6.7.0
 %define                _rel            3
 #
+%define                need_x86        0
+%define                need_x8664      0
+%if %{with incall}
+%define                need_x86        1
+%define                need_x8664      1
+%else
+%ifarch %{ix86}
+%define                need_x86        1
+%endif
+%ifarch %{x8664}
+%define                need_x8664      1
+%endif
+%endif
+#
+
 Summary:       Linux Drivers for nVidia TNT/TNT2/GeForce/Quadro Chips
 Summary(pl):   Sterowniki do kart graficznych nVidia TNT/TNT2/GeForce/Quadro
 Name:          X11-driver-nvidia
@@ -19,21 +35,24 @@ License:    nVidia Binary
 Vendor:                nVidia Corp.
 Group:         X11/XFree86
 # why not pkg0!?
-Source0:       http://download.nvidia.com/XFree86/Linux-x86/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg1.run
-# Source0-md5: f7737c1e95371f37a4fd30da2f11e72c
-Source1:       http://download.nvidia.com/XFree86/Linux-x86_64/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg2.run
-# Source1-md5: 652e69f549c81a7a3f2806daa74b9c36
+%if %{need_x86}
+Source0:       http://download.nvidia.com/XFree86/Linux-x86/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg0.run
+# Source0-md5: 1d062204da2902ae86154a03e1a40204
+%endif
+%if %{need_x8664}
+Source1:       http://download.nvidia.com/XFree86/Linux-x86_64/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg0.run
+# Source1-md5: fa4e143a3193c0bd9cd697eb8637b354
+%endif
 Patch0:                %{name}-gcc34.patch
 Patch1:                %{name}-GL.patch
 Patch2:                %{name}-conftest.patch
-Patch3:                %{name}-1165235.patch
-Patch4:                %{name}-1171869.patch
+# http://www.minion.de/files/1.0-6629/
 URL:           http://www.nvidia.com/object/linux.html
 BuildConflicts:        XFree86-nvidia
 BuildRequires: grep
 %{?with_dist_kernel:BuildRequires:     kernel-module-build >= 2.6.7}
 BuildRequires: %{kgcc_package}
-BuildRequires: rpmbuild(macros) >= 1.153
+BuildRequires: rpmbuild(macros) >= 1.213
 BuildRequires: sed >= 4.0
 BuildRequires: textutils
 #BuildRequires:        X11-devel >= %{_min_x11}        # disabled for now
@@ -52,12 +71,12 @@ Obsoletes:  XFree86-OpenGL-libGL
 Obsoletes:     XFree86-driver-nvidia
 Obsoletes:     XFree86-nvidia
 Conflicts:     XFree86-OpenGL-devel <= 4.2.0-3
-ExclusiveArch: %{ix86} amd64
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLcore.so.1
 %define                _prefix         /usr/X11R6
-%ifarch amd64
+%ifarch %{x8664}
 %define                _libdir32       %{_prefix}/lib
 %endif
 
@@ -118,7 +137,6 @@ Summary(pl):        Modu
 Version:       %{_nv_ver}.%{_nv_rel}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-PreReq:                modutils >= 2.3.18-2
 Requires(post,postun): /sbin/depmod
 Requires:      dev >= 2.7.7-10
 %{?with_dist_kernel:%requires_releq_kernel_up}
@@ -141,7 +159,6 @@ Summary(de):        Das nVidia-Kern-Modul f
 Summary(pl):   Modu³ j±dra dla obs³ugi kart graficznych nVidia
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-PreReq:                modutils >= 2.3.18-2
 Requires(post,postun): /sbin/depmod
 Requires:      dev >= 2.7.7-10
 %{?with_dist_kernel:%requires_releq_kernel_smp}
@@ -163,16 +180,14 @@ cd %{_builddir}
 rm -rf NVIDIA-Linux-x86*-%{_nv_ver}-%{_nv_rel}-pkg*
 %ifarch %{ix86}
 /bin/sh %{SOURCE0} --extract-only
-%setup -qDT -n NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg1
+%setup -qDT -n NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg0
 %else
 /bin/sh %{SOURCE1} --extract-only
-%setup -qDT -n NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg2
+%setup -qDT -n NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg0
 %endif
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p0
-%patch4 -p0
 sed -i 's:-Wpointer-arith::' usr/src/nv/Makefile.kbuild
 
 %build
@@ -218,7 +233,7 @@ install usr/lib/tls/libnvidia-tls.so.%{version} $RPM_BUILD_ROOT/usr/%{_lib}/tls
 install usr/lib/libGL{,core}.so.%{version} $RPM_BUILD_ROOT%{_libdir}
 install usr/X11R6/lib/modules/extensions/libglx.so.%{version} \
        $RPM_BUILD_ROOT%{_libdir}/modules/extensions
-%ifarch amd64
+%ifarch %{x8664}
 # support for running 32-bit OpenGL applications on 64-bit AMD64 Linux installations
 #install -d $RPM_BUILD_ROOT%{_libdir32}
 #install usr/lib32%{?with_tls:/tls}/libnvidia-tls.so.%{version} $RPM_BUILD_ROOT%{_libdir32}
@@ -285,7 +300,7 @@ EOF
 %files
 %defattr(644,root,root,755)
 %doc LICENSE
-%doc usr/share/doc/{README,NVIDIA_Changelog,XF86Config.sample}
+%doc usr/share/doc/{README.txt,NVIDIA_Changelog,XF86Config.sample}
 #%%lang(de) %doc usr/share/doc/README.DE
 %attr(755,root,root) %{_libdir}/libGL.so.*.*
 %attr(755,root,root) %{_libdir}/libGL.so
@@ -294,7 +309,7 @@ EOF
 %dir /usr/%{_lib}/tls
 %attr(755,root,root) /usr/%{_lib}/libnvidia-tls.so.*.*.*
 %attr(755,root,root) /usr/%{_lib}/tls/libnvidia-tls.so.*.*.*
-%ifarch amd64
+%ifarch %{x8664}
 # support for running 32-bit OpenGL applications on 64-bit AMD64 Linux installations
 #dir %{_libdir32}
 #attr(755,root,root) %{_libdir32}/libGL.so.*.*
@@ -327,5 +342,6 @@ EOF
 %{_libdir}/libXvMCNVIDIA.a
 
 %files progs
-%defattr(755,root,root,755)
-%{_bindir}/nvidia-settings
+%defattr(644,root,root,755)
+%doc usr/share/doc/nvidia-settings-user-guide.txt
+%attr(755,root,root) %{_bindir}/nvidia-settings
This page took 0.035657 seconds and 4 git commands to generate.