- new patches
[packages/xorg-driver-video-nvidia.git] / NVIDIA_kernel-1.0-7167-1237815.diff
1 diff -ru usr/src/nv/nv.c usr/src/nv.1237815/nv.c
2 --- usr/src/nv/nv.c     2005-02-25 18:37:02.000000000 +0100
3 +++ usr/src/nv.1237815/nv.c     2005-03-11 17:29:49.034335416 +0100
4 @@ -3071,14 +3071,15 @@
5              nv_printf(NV_DBG_WARNINGS, "NVRM: not using NVAGP, AGPGART is loaded!\n");
6              return status;
7          }
8 -#elif defined(NV_MULTIPLE_BRIDGE_AGPGART_PRESENT)
9 +#elif defined(AGPGART)
10 +#if defined(NV_MULTIPLE_BRIDGE_AGPGART_PRESENT)
11          if (!list_empty(&agp_bridges))
12          {
13              nv_printf(NV_DBG_WARNINGS,
14                        "NVRM: not using NVAGP, an AGPGART backend is loaded!\n");
15              return status;
16          }
17 -#elif defined(AGPGART)
18 +#else /* NV_MULTIPLE_BRIDGE_AGPGART_PRESENT */
19          int error;
20          /*
21           * We can only safely use NvAGP when no backend has been
22 @@ -3096,6 +3097,7 @@
23              return status;
24          }
25  #endif
26 +#endif /* AGPGART  */
27  #if defined(CONFIG_X86_64) && defined(CONFIG_GART_IOMMU)
28          nv_printf(NV_DBG_WARNINGS,
29              "NVRM: not using NVAGP, kernel was compiled with GART_IOMMU support!!\n");
This page took 0.077239 seconds and 3 git commands to generate.