]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia.git/blame_incremental - xorg-driver-video-nvidia.spec
- ln %{_kernelsrcdir}/scripts for without dist_kernel
[packages/xorg-driver-video-nvidia.git] / xorg-driver-video-nvidia.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without dist_kernel # without distribution kernel
4%bcond_without smp # without smp packages
5%bcond_without kernel # without kernel packages
6%bcond_without incall # include all tarballs
7%bcond_without userspace # don't build userspace programs
8%bcond_with verbose # verbose build (V=1)
9#
10%define _nv_ver 1.0
11%define _nv_rel 8178
12%define _min_x11 6.7.0
13%define _rel 2
14#
15%define need_x86 0
16%define need_x8664 0
17%if %{with incall}
18%define need_x86 1
19%define need_x8664 1
20%else
21%ifarch %{ix86}
22%define need_x86 1
23%endif
24%ifarch %{x8664}
25%define need_x8664 1
26%endif
27%endif
28#
29
30Summary: Linux Drivers for nVidia TNT/TNT2/GeForce/Quadro Chips
31Summary(pl): Sterowniki do kart graficznych nVidia TNT/TNT2/GeForce/Quadro
32Name: X11-driver-nvidia
33Version: %{_nv_ver}.%{_nv_rel}
34Release: %{_rel}
35License: nVidia Binary
36Vendor: nVidia Corp.
37Group: X11
38# why not pkg0!?
39%if %{need_x86}
40Source0: http://download.nvidia.com/XFree86/Linux-x86/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg1.run
41# Source0-md5: bc9d459bfeee93735e3959de041635df
42%endif
43%if %{need_x8664}
44Source1: http://download.nvidia.com/XFree86/Linux-x86_64/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg1.run
45# Source1-md5: 0da016f8d5138c1ee51b7fa375821574
46%endif
47Patch0: %{name}-gcc34.patch
48Patch1: %{name}-GL.patch
49Patch2: %{name}-conftest.patch
50# http://www.minion.de/files/1.0-6629/
51URL: http://www.nvidia.com/object/linux.html
52BuildRequires: grep
53%if %{with kernel}
54%{?with_dist_kernel:BuildRequires: kernel-module-build >= 2.6.7}
55%endif
56BuildRequires: %{kgcc_package}
57BuildRequires: rpmbuild(macros) >= 1.213
58BuildRequires: sed >= 4.0
59BuildRequires: textutils
60#BuildRequires: X11-devel >= %{_min_x11} # disabled for now
61BuildConflicts: XFree86-nvidia
62Requires: X11-Xserver
63Requires: X11-libs >= %{_min_x11}
64Requires: X11-modules >= %{_min_x11}
65Provides: X11-OpenGL-core
66Provides: X11-OpenGL-libGL
67Provides: XFree86-OpenGL-core
68Provides: XFree86-OpenGL-libGL
69Obsoletes: Mesa
70Obsoletes: X11-OpenGL-core
71Obsoletes: X11-OpenGL-libGL
72Obsoletes: XFree86-OpenGL-core
73Obsoletes: XFree86-OpenGL-libGL
74Obsoletes: XFree86-driver-nvidia
75Obsoletes: XFree86-nvidia
76Conflicts: XFree86-OpenGL-devel <= 4.2.0-3
77ExclusiveArch: %{ix86} %{x8664}
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80%define _noautoreqdep libGL.so.1 libGLcore.so.1
81%define _prefix /usr/X11R6
82%ifarch %{x8664}
83%define _libdir32 %{_prefix}/lib
84%endif
85
86%description
87This driver set adds improved 2D functionality to the Xorg/XFree86 X
88server as well as high performance OpenGL acceleration, AGP support,
89support for most flat panels, and 2D multiple monitor support.
90
91Hardware: nVidia TNT, TNT2, GeForce, or Quadro based graphics
92accelerator. The nVidia NV1 and RIVA 128/128ZX chips are supported in
93the base Xorg/XFree86 install and are not supported by this driver
94set.
95
96%description -l pl
97Usprawnione sterowniki dla kart graficznych nVidia do serwera
98