]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- rel 15
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 %bcond_without  dri3    DRI3 support
6 #
7 %define libdrm_ver      2.4.41
8 %define pixman_ver      0.28.0
9 %if %{with sna}
10 %define xserver_ver     1.10
11 %else
12 %define xserver_ver     1.6.3
13 %endif
14 Summary:        X.org video driver for Intel integrated graphics chipsets
15 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
16 Name:           xorg-driver-video-intel
17 Version:        2.99.917
18 Release:        13
19 License:        MIT
20 Group:          X11/Applications
21 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
22 # Source0-md5:  fa196a66e52c0c624fe5d350af7a5e7b
23 URL:            http://xorg.freedesktop.org/
24 Patch0:         xorg-driver-video-intel-git.patch
25 # Patch0-md5:   0fd5075aeaa258ae81fb9707906394fb
26 Patch1:         driver-intel-sna-cursor-Make-sure-hw-cursors-are-disabled-before-disabling-secondary-planes.patch
27 Patch2:         link.patch
28 BuildRequires:  Mesa-libGL-devel
29 #BuildRequires: autoconf >= 2.63
30 #BuildRequires: automake >= 1:1.10.2-2
31 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
32 BuildRequires:  libdrm-devel >= %{libdrm_ver}
33 #BuildRequires: libtool >= 2:2.2
34 BuildRequires:  libxcb-devel >= 1.5
35 BuildRequires:  pixman-devel >= %{pixman_ver}
36 BuildRequires:  pkgconfig >= 1:0.19
37 BuildRequires:  rpmbuild(macros) >= 1.389
38 BuildRequires:  udev-devel
39 BuildRequires:  xcb-util-devel
40 BuildRequires:  xorg-lib-libX11-devel
41 BuildRequires:  xorg-lib-libXfixes-devel
42 BuildRequires:  xorg-lib-libXrender-devel
43 BuildRequires:  xorg-lib-libXtst-devel
44 BuildRequires:  xorg-lib-libXvMC-devel
45 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
46 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
47 %{?with_dri3:BuildRequires:     xorg-proto-dri3proto-devel}
48 BuildRequires:  xorg-proto-fontsproto-devel
49 BuildRequires:  xorg-proto-glproto-devel
50 BuildRequires:  xorg-proto-randrproto-devel
51 BuildRequires:  xorg-proto-renderproto-devel
52 BuildRequires:  xorg-proto-videoproto-devel
53 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
54 BuildRequires:  xorg-proto-xf86driproto-devel
55 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
56 BuildRequires:  xorg-util-util-macros >= 1.8
57 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
58 %{?requires_xorg_xserver_videodrv}
59 %{?with_glamor:Requires:        glamor >= 0.3.1}
60 Requires:       libdrm >= %{libdrm_ver}
61 Requires:       pixman >= %{pixman_ver}
62 Requires:       xorg-lib-libpciaccess >= 0.10
63 Requires:       xorg-xserver-libdri >= %{xserver_ver}
64 Requires:       xorg-xserver-libglx >= %{xserver_ver}
65 Requires:       xorg-xserver-server >= %{xserver_ver}
66 Provides:       xorg-driver-video
67 Provides:       xorg-driver-video-i810
68 Obsoletes:      X11-driver-i810 < 1:7.0.0
69 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
70 Obsoletes:      XFree86-i810
71 Obsoletes:      xorg-driver-video-i810 < 1.7.2
72 Conflicts:      vbetool
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 X.org video driver for Intel integrated graphics chipsets. It
77 supports:
78 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
79   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
80   Q35, GM45, G45, Q45, G43, G41 chipsets,
81 - Pineview-M in Atom N400 series,
82 - Pineview-D in Atom D400/D500 series.
83
84 Requires Kernel Mode Setting (KMS) to be active.
85
86 %description -l pl.UTF-8
87 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
88 Obsługuje:
89 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
90   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
91   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
92 - Pineview-M w procesorach Atom z serii N400,
93 - Pineview-D w procesorach Atom z serii D400/D500.
94
95 Wymaga aktywnego Kernel Mode Setting (KMS).
96
97 %prep
98 %setup -q -n xf86-video-intel-%{version}
99 %{__rm} src/render_program/exa_wm_yuv_rgb.g[67]a
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         %{?with_glamor:--enable-glamor} \
112         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
113         --enable-uxa \
114         --enable-sna%{!?with_sna:=no} \
115         %{__enable_disable dri3}
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
126         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING ChangeLog NEWS README
137 %attr(755,root,root) %{_bindir}/intel-virtual-output
138 %attr(755,root,root) %{_libexecdir}/xf86-video-intel-backlight-helper
139 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
141 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
143 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
144 %{_mandir}/man4/intel.4*
145 %{_mandir}/man4/intel-virtual-output.4*
146 %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
This page took 0.130265 seconds and 3 git commands to generate.