]> git.pld-linux.org Git - packages/wl.git/commitdiff
- fix for kernel 4.15 from arch https://bugs.archlinux.org/task/57261 auto/th/wl-6.30.223.271-8
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jan 2018 00:19:51 +0000 (01:19 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 30 Jan 2018 00:19:51 +0000 (01:19 +0100)
- rel 8

008-linux415.patch [new file with mode: 0644]
wl.spec

diff --git a/008-linux415.patch b/008-linux415.patch
new file mode 100644 (file)
index 0000000..1bced2f
--- /dev/null
@@ -0,0 +1,46 @@
+--- a/src/wl/sys/wl_linux.c    2017-07-17 00:11:24.000000000 +0100
++++ b/src/wl/sys/wl_linux.c    2018-01-27 09:49:47.057799596 +0000
+@@ -93,7 +93,11 @@
+ #include <wlc_wowl.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++static void wl_timer(struct timer_list *tl);
++#else
+ static void wl_timer(ulong data);
++#endif
+ static void _wl_timer(wl_timer_t *t);
+ static struct net_device *wl_alloc_linux_if(wl_if_t *wlif);
+@@ -2297,10 +2301,17 @@
+       atomic_dec(&t->wl->callbacks);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++static void
++wl_timer(struct timer_list *tl)
++{
++      wl_timer_t *t = (wl_timer_t *)tl;
++#else
+ static void
+ wl_timer(ulong data)
+ {
+       wl_timer_t *t = (wl_timer_t *)data;
++#endif
+       if (!WL_ALL_PASSIVE_ENAB(t->wl))
+               _wl_timer(t);
+@@ -2352,9 +2363,13 @@
+       bzero(t, sizeof(wl_timer_t));
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++      timer_setup(&t->timer, wl_timer, 0);
++#else
+       init_timer(&t->timer);
+       t->timer.data = (ulong) t;
+       t->timer.function = wl_timer;
++#endif
+       t->wl = wl;
+       t->fn = fn;
+       t->arg = arg;
diff --git a/wl.spec b/wl.spec
index 654ce3e80e6b265ded1d8aa33c8d20b98dddae09..dd2dc746f4559029ce8d01b40b79acd9fcd4404f 100644 (file)
--- a/wl.spec
+++ b/wl.spec
@@ -18,7 +18,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define                rel     7
+%define                rel     8
 %define                pname   wl
 %define                file_ver        %(echo %{version} | tr . _)
 Summary:       Broadcom 802.11 a/b/g/n hybrid Linux networking device driver
@@ -43,6 +43,7 @@ Patch4:               linux-4.8.patch
 Patch5:                17-fix-kernel-warnings.patch
 Patch6:                linux-4.11.patch
 Patch7:                linux-4.12.patch
+Patch8:                008-linux415.patch
 URL:           http://www.broadcom.com/support/802.11
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -131,6 +132,7 @@ EOF\
 %patch5 -p2
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 mkdir wl
 mv lib src Makefile wl/
This page took 0.053081 seconds and 4 git commands to generate.