1 Summary: Command-line copy/paste utilities for Wayland
7 Source0: https://github.com/bugaevc/wl-clipboard/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5: e39e266bca009d00a9ab99c29eb41ebc
9 URL: https://github.com/bugaevc/wl-clipboard
10 BuildRequires: meson >= 0.44.0
12 BuildRequires: rpm-build >= 4.6
13 BuildRequires: rpmbuild(macros) >= 1.752
14 BuildRequires: wayland-devel
15 BuildRequires: wayland-protocols >= 1.17
16 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 This project implements two command-line Wayland clipboard utilities,
20 wl-copy and wl-paste, that let you easily copy data between the
21 clipboard and Unix pipes, sockets, files and so on.
23 %package -n bash-completion-wl-clipboard
24 Summary: Bash completion for wl-clipboard
25 Group: Applications/Shells
26 Requires: %{name} = %{version}-%{release}
27 Requires: bash-completion >= 1:2.0
30 %description -n bash-completion-wl-clipboard
31 Bash completion for wl-clipboard.
33 %package -n fish-completion-wl-clipboard
34 Summary: fish-completion for wl-clipboard
35 Group: Applications/Shells
36 Requires: %{name} = %{version}-%{release}
40 %description -n fish-completion-wl-clipboard
41 fish-completion for wl-clipboard.
43 %package -n zsh-completion-wl-clipboard
44 Summary: ZSH completion for wl-clipboard
45 Group: Applications/Shells
46 Requires: %{name} = %{version}-%{release}
50 %description -n zsh-completion-wl-clipboard
51 ZSH completion for wl-clipboard.
58 -Dzshcompletiondir=%{zsh_compdir}
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
67 rm -rf $RPM_BUILD_ROOT
70 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/wl-copy
73 %attr(755,root,root) %{_bindir}/wl-paste
74 %{_mandir}/man1/wl-clipboard.1*
75 %{_mandir}/man1/wl-copy.1*
76 %{_mandir}/man1/wl-paste.1*
78 %files -n bash-completion-wl-clipboard
79 %defattr(644,root,root,755)
80 %{bash_compdir}/wl-copy
81 %{bash_compdir}/wl-paste
83 %files -n fish-completion-wl-clipboard
84 %defattr(644,root,root,755)
85 %{fish_compdir}/wl-copy.fish
86 %{fish_compdir}/wl-paste.fish
88 %files -n zsh-completion-wl-clipboard
89 %defattr(644,root,root,755)
90 %{zsh_compdir}/_wl-copy
91 %{zsh_compdir}/_wl-paste