]> git.pld-linux.org Git - packages/wl-clipboard.git/blob - wl-clipboard.spec
correct bash-completion epoch
[packages/wl-clipboard.git] / wl-clipboard.spec
1 Summary:        Command-line copy/paste utilities for Wayland
2 Name:           wl-clipboard
3 Version:        2.1.0
4 Release:        1
5 License:        GPL v3+
6 Group:          Applications
7 Source0:        https://github.com/bugaevc/wl-clipboard/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  e39e266bca009d00a9ab99c29eb41ebc
9 URL:            https://github.com/bugaevc/wl-clipboard
10 BuildRequires:  meson >= 0.44.0
11 BuildRequires:  ninja
12 BuildRequires:  rpm-build >= 4.6
13 BuildRequires:  rpmbuild(macros) >= 1.752
14 BuildRequires:  wayland-devel
15 BuildRequires:  wayland-protocols >= 1.17
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This project implements two command-line Wayland clipboard utilities,
20 wl-copy and wl-paste, that let you easily copy data between the
21 clipboard and Unix pipes, sockets, files and so on.
22
23 %package -n bash-completion-wl-clipboard
24 Summary:        Bash completion for wl-clipboard
25 Group:          Applications/Shells
26 Requires:       %{name} = %{version}-%{release}
27 Requires:       bash-completion >= 1:2.0
28 BuildArch:      noarch
29
30 %description -n bash-completion-wl-clipboard
31 Bash completion for wl-clipboard.
32
33 %package -n fish-completion-wl-clipboard
34 Summary:        fish-completion for wl-clipboard
35 Group:          Applications/Shells
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       fish
38 BuildArch:      noarch
39
40 %description -n fish-completion-wl-clipboard
41 fish-completion for wl-clipboard.
42
43 %package -n zsh-completion-wl-clipboard
44 Summary:        ZSH completion for wl-clipboard
45 Group:          Applications/Shells
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       zsh
48 BuildArch:      noarch
49
50 %description -n zsh-completion-wl-clipboard
51 ZSH completion for wl-clipboard.
52
53 %prep
54 %setup -q
55
56 %build
57 %meson build \
58         -Dzshcompletiondir=%{zsh_compdir}
59
60 %ninja_build -C build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README.md
72 %attr(755,root,root) %{_bindir}/wl-copy
73 %attr(755,root,root) %{_bindir}/wl-paste
74 %{_mandir}/man1/wl-clipboard.1*
75 %{_mandir}/man1/wl-copy.1*
76 %{_mandir}/man1/wl-paste.1*
77
78 %files -n bash-completion-wl-clipboard
79 %defattr(644,root,root,755)
80 %{bash_compdir}/wl-copy
81 %{bash_compdir}/wl-paste
82
83 %files -n fish-completion-wl-clipboard
84 %defattr(644,root,root,755)
85 %{fish_compdir}/wl-copy.fish
86 %{fish_compdir}/wl-paste.fish
87
88 %files -n zsh-completion-wl-clipboard
89 %defattr(644,root,root,755)
90 %{zsh_compdir}/_wl-copy
91 %{zsh_compdir}/_wl-paste
This page took 0.082441 seconds and 4 git commands to generate.