]> git.pld-linux.org Git - packages/wireless-tools.git/blob - wireless-tools.spec
- updated URLs
[packages/wireless-tools.git] / wireless-tools.spec
1 %define pre     pre9
2 Summary:        Wireless ethernet configuration tools
3 Summary(pl.UTF-8):      Narzędzia do konfiguracji sieci bezprzewodowej
4 Summary(pt_BR.UTF-8):   Ferramentas para redes sem fio
5 Name:           wireless-tools
6 Version:        30
7 Release:        0.%{pre}.1
8 Epoch:          1
9 License:        GPL v2
10 Group:          Networking/Admin
11 Source0:        https://hewlettpackard.github.io/wireless-tools/wireless_tools.%{version}.%{pre}.tar.gz
12 # Source0-md5:  ca91ba7c7eff9bfff6926b1a34a4697d
13 Patch0:         %{name}-optflags.patch
14 Patch1:         %{name}-debian.patch
15 URL:            https://hewlettpackard.github.io/wireless-tools/Tools.html
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sbindir        /sbin
19
20 %define         specflags       -fno-strict-aliasing
21
22 %description
23 This package contains the Wireless tools, used to manipulate the
24 Wireless Extensions. The Wireless Extension is an interface allowing
25 you to set Wireless LAN specific parameters and get the specific stats
26 for wireless networking equipment.
27
28 %description -l pl.UTF-8
29 Narzędzie używane do manipulacji Rozszerzeniami Bezprzewodowymi.
30 Rozszerzenia Bezprzewodowe to interfejs pozwalający na ustawianie
31 parametrów i uzyskiwanie statystyk na temat bezprzewodowych urządzeń.
32
33 %description -l pt_BR.UTF-8
34 Este pacote contém ferramentas para redes sem fio, utilizadas para
35 manipular as wireless extensions. Wireless extensions é uma interface
36 que permite que você modifique parâmetros específicos para redes sem
37 fio e verificar estatísticas sobre estas.
38
39 %package -n libiw
40 Summary:        Wireless Extension library
41 Summary(pl.UTF-8):      Biblioteka rozszerzeń bezprzewodowych
42 Group:          Libraries
43
44 %description -n libiw
45 Wireless Extension library.
46
47 %description -n libiw -l pl.UTF-8
48 Biblioteka rozszerzeń bezprzewodowych.
49
50 %package -n libiw-devel
51 Summary:        Wireless Extension library (development files)
52 Summary(pl.UTF-8):      Biblioteka rozszerzeń bezprzewodowych (pliki developerskie)
53 Group:          Development/Libraries
54 Requires:       libiw = %{epoch}:%{version}-%{release}
55
56 %description -n libiw-devel
57 Wireless Extension library (development files).
58
59 %description -n libiw-devel -l pl.UTF-8
60 Biblioteka rozszerzeń bezprzewodowych (pliki developerskie).
61
62 %package -n libiw-static
63 Summary:        Wireless Extension library (static library)
64 Summary(pl.UTF-8):      Biblioteka rozszerzeń bezprzewodowych (biblioteka statyczna)
65 Group:          Development/Libraries
66 Requires:       libiw-devel = %{epoch}:%{version}-%{release}
67
68 %description -n libiw-static
69 Wireless Extension library (static library).
70
71 %description -n libiw-static -l pl.UTF-8
72 Biblioteka rozszerzeń bezprzewodowych (biblioteka statyczna).
73
74 %prep
75 %setup -q -n wireless_tools.%{version}
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 %{__make} \
81         CC="%{__cc}" \
82         OPTFLAGS="%{rpmcflags} %{rpmcppflags}"
83
84 %{__make} libiw.a \
85         CC="%{__cc}" \
86         OPTFLAGS="%{rpmcflags} %{rpmcppflags}"
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_sbindir},/%{_lib},%{_libdir},%{_includedir},%{_mandir}/man8}
91
92 %{__make} install install-dynamic install-static \
93         INSTALL_DIR=$RPM_BUILD_ROOT%{_sbindir} \
94         INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir} \
95         INSTALL_INC=$RPM_BUILD_ROOT%{_includedir} \
96         INSTALL_MAN=$RPM_BUILD_ROOT%{_mandir}
97
98 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libiw.so.* $RPM_BUILD_ROOT/%{_lib}
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiw.so
100 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libiw.so.*) \
101         $RPM_BUILD_ROOT%{_libdir}/libiw.so
102
103 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/fr.ISO*
104 %{__mv} $RPM_BUILD_ROOT%{_mandir}/fr{.UTF-8,}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -n libiw -p /sbin/ldconfig
110 %postun -n libiw -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc CHANGELOG.h ESSID-BUG.txt HOTPLUG-UDEV.txt IFRENAME-VS-XXX.txt PCMCIA.txt README
115 %lang(fr) %doc README.fr
116 %attr(755,root,root) %{_sbindir}/ifrename
117 %attr(755,root,root) %{_sbindir}/iwconfig
118 %attr(755,root,root) %{_sbindir}/iwevent
119 %attr(755,root,root) %{_sbindir}/iwgetid
120 %attr(755,root,root) %{_sbindir}/iwlist
121 %attr(755,root,root) %{_sbindir}/iwpriv
122 %attr(755,root,root) %{_sbindir}/iwspy
123 %{_mandir}/man5/iftab.5*
124 %{_mandir}/man7/wireless.7*
125 %{_mandir}/man8/ifrename.8*
126 %{_mandir}/man8/iwconfig.8*
127 %{_mandir}/man8/iwevent.8*
128 %{_mandir}/man8/iwgetid.8*
129 %{_mandir}/man8/iwlist.8*
130 %{_mandir}/man8/iwpriv.8*
131 %{_mandir}/man8/iwspy.8*
132 %lang(cs) %{_mandir}/cs/man[578]/*
133 %lang(fr) %{_mandir}/fr/man[578]/*
134
135 %files -n libiw
136 %defattr(644,root,root,755)
137 %attr(755,root,root) /%{_lib}/libiw.so.*
138
139 %files -n libiw-devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libiw.so
142 %{_includedir}/iwlib.h
143 %{_includedir}/wireless.h
144
145 %files -n libiw-static
146 %defattr(644,root,root,755)
147 %{_libdir}/libiw.a
This page took 0.061101 seconds and 3 git commands to generate.