]> git.pld-linux.org Git - packages/winpdb.git/blob - winpdb.spec
- Version: 1.4.8 (fixed for Python 2.7)
[packages/winpdb.git] / winpdb.spec
1 Summary:        Python debugger in wxGTK
2 Summary(pl.UTF-8):      Debugger pythona w wxGTK
3 Name:           winpdb
4 Version:        1.4.8
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages/Python
8 Source0:        http://winpdb.googlecode.com/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  e28049cc93c1614b9db20960d76b7ea3
10 Patch0:         %{name}-rpdb2.patch
11 URL:            http://www.winpdb.org/
12 BuildRequires:  python-devel >= 1:2.6
13 BuildRequires:  rpm-pythonprov
14 Requires:       python-wxPython
15 Requires:       rpdb2 = %{version}-%{release}
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Winpdb is a platform independent GPL Python debugger with support for
21 multiple threads, namespace modification, embedded debugging,
22 encrypted communication and is up to 20 times faster than pdb.
23
24 Winpdb provides the GUI for Rpdb2.
25
26 %description -l pl.UTF-8
27 Winpdb jest niezależnym od platformy odpluskwiaczem języka Python na
28 licencji GPL ze wsparciem wielu wątków, modyfikacji przestrzeni nazw,
29 zagnieżdżonego odpluskwiania, szyfrowanej komunikacji i jest do
30 dwudziestu razy szybszy od pdb.
31
32 Winpdb zapewnia graficzny interfejs użytkownika dla Rpdb2.
33
34 %package -n rpdb2
35 Summary:        Python console based debugger
36 Summary(pl.UTF-8):      Debugger pythona na konsolę tesktową
37 Group:          Development/Languages/Python
38 %pyrequires_eq  python-modules
39
40 %description -n rpdb2
41 Rpdb2 is a platform independent GPL Python debugger with support for
42 multiple threads, namespace modification, embedded debugging,
43 encrypted communication and is up to 20 times faster than pdb.
44
45 Rpdb2 is Winpdb without the GUI.
46
47 %description -n rpdb2 -l pl.UTF-8
48 Rpdb2 jest niezależnym od platformy odpluskwiaczem języka Python na
49 licencji GPL ze wsparciem wielu wątków, modyfikacji przestrzeni nazw,
50 zagnieżdżonego odpluskwiania, szyfrowanej komunikacji i jest do
51 dwudziestu razy szybszy od pdb.
52
53 Rpdb2 to Winpdb bez swojego graficznego interfejsu użytkownika.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 python setup.py build
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 python setup.py install \
65         --optimize=2 \
66         --root=$RPM_BUILD_ROOT
67
68 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
69 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
70 %py_postclean
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README.txt
78 %attr(755,root,root) %{_bindir}/winpdb
79 %{py_sitescriptdir}/winpdb.py[co]
80
81 %files -n rpdb2
82 %defattr(644,root,root,755)
83 %doc README.txt
84 %attr(755,root,root) %{_bindir}/rpdb2
85 %{py_sitescriptdir}/rpdb2.py[co]
86 %{py_sitescriptdir}/%{name}-*.egg-info
This page took 0.092273 seconds and 3 git commands to generate.