]> git.pld-linux.org Git - packages/wimlib.git/blob - wimlib.spec
add static_libs bcond
[packages/wimlib.git] / wimlib.spec
1 # Conditional build:
2 %bcond_without  ntfs_3g         # build without ntfs-3g (avoid GPLv2 dependency)
3
4 Summary:        Open source Windows Imaging (WIM) library
5 Name:           wimlib
6 Version:        1.14.1
7 Release:        1
8 License:        GPL v3+ or LGPL v3+
9 Group:          Libraries
10 Source0:        https://wimlib.net/downloads/%{name}-%{version}.tar.gz
11 # Source0-md5:  af68bea3fb633bf60db4cba95bab2e6c
12 URL:            https://wimlib.net/
13 BuildRequires:  libfuse3-devel
14 %{?with_ntfs_3g:BuildRequires:  ntfs-3g-devel >= 1:2011.4.12}
15 BuildRequires:  pkgconfig
16 Requires:       libfuse3-tools
17 %{?with_ntfs_3g:Requires:       ntfs-3g-libs >= 1:2011.4.12}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 wimlib is an open source, cross-platform library for creating,
22 extracting, and modifying Windows Imaging (WIM) archives. WIM is a
23 file archiving format, somewhat comparable to ZIP (and many other file
24 archiving formats); but unlike ZIP, it allows storing various
25 Windows-specific metadata, allows storing multiple "images" in a
26 single archive, automatically deduplicates all file contents, and
27 supports optional solid compression to get a better compression ratio.
28 wimlib and its command-line frontend wimlib-imagex provide a free and
29 cross-platform alternative to Microsoft's WIMGAPI, ImageX, and DISM.
30
31 %package devel
32 Summary:        Development files for wimlib
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Development files for wimlib.
38
39 %package static
40 Summary:        Static wimlib library
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}-%{release}
43
44 %description static
45 Static wimlib library.
46
47 %package tools
48 Summary:        Tools for creating, modifying, extracting, and mounting WIM files
49 Group:          Applications/System
50 Requires:       %{name} = %{version}-%{release}
51 Suggests:       mkisofs
52
53 %description tools
54 Tools for creating, modifying, extracting, and mounting WIM files.
55
56 %prep
57 %setup -q
58
59 %{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' programs/mkwinpeimg.in
60
61 %build
62 %configure \
63         --disable-silent-rules \
64         %{!?with_ntfs_3g:--without-ntfs-3g}
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwim.la
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc COPYING NEWS.md README.md
84 %attr(755,root,root) %{_libdir}/libwim.so.*.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libwim.so.15
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/libwim.so
90 %{_includedir}/wimlib.h
91 %{_pkgconfigdir}/wimlib.pc
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/libwim.a
96
97 %files tools
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/mkwinpeimg
100 %attr(755,root,root) %{_bindir}/wimappend
101 %attr(755,root,root) %{_bindir}/wimapply
102 %attr(755,root,root) %{_bindir}/wimcapture
103 %attr(755,root,root) %{_bindir}/wimdelete
104 %attr(755,root,root) %{_bindir}/wimdir
105 %attr(755,root,root) %{_bindir}/wimexport
106 %attr(755,root,root) %{_bindir}/wimextract
107 %attr(755,root,root) %{_bindir}/wiminfo
108 %attr(755,root,root) %{_bindir}/wimjoin
109 %attr(755,root,root) %{_bindir}/wimlib-imagex
110 %attr(755,root,root) %{_bindir}/wimmount
111 %attr(755,root,root) %{_bindir}/wimmountrw
112 %attr(755,root,root) %{_bindir}/wimoptimize
113 %attr(755,root,root) %{_bindir}/wimsplit
114 %attr(755,root,root) %{_bindir}/wimunmount
115 %attr(755,root,root) %{_bindir}/wimupdate
116 %attr(755,root,root) %{_bindir}/wimverify
117 %{_mandir}/man1/mkwinpeimg.1*
118 %{_mandir}/man1/wimappend.1*
119 %{_mandir}/man1/wimapply.1*
120 %{_mandir}/man1/wimcapture.1*
121 %{_mandir}/man1/wimdelete.1*
122 %{_mandir}/man1/wimdir.1*
123 %{_mandir}/man1/wimexport.1*
124 %{_mandir}/man1/wimextract.1*
125 %{_mandir}/man1/wiminfo.1*
126 %{_mandir}/man1/wimjoin.1*
127 %{_mandir}/man1/wimlib-imagex-append.1*
128 %{_mandir}/man1/wimlib-imagex-apply.1*
129 %{_mandir}/man1/wimlib-imagex-capture.1*
130 %{_mandir}/man1/wimlib-imagex-delete.1*
131 %{_mandir}/man1/wimlib-imagex-dir.1*
132 %{_mandir}/man1/wimlib-imagex-export.1*
133 %{_mandir}/man1/wimlib-imagex-extract.1*
134 %{_mandir}/man1/wimlib-imagex-info.1*
135 %{_mandir}/man1/wimlib-imagex-join.1*
136 %{_mandir}/man1/wimlib-imagex-mount.1*
137 %{_mandir}/man1/wimlib-imagex-mountrw.1*
138 %{_mandir}/man1/wimlib-imagex-optimize.1*
139 %{_mandir}/man1/wimlib-imagex-split.1*
140 %{_mandir}/man1/wimlib-imagex-unmount.1*
141 %{_mandir}/man1/wimlib-imagex-update.1*
142 %{_mandir}/man1/wimlib-imagex-verify.1*
143 %{_mandir}/man1/wimlib-imagex.1*
144 %{_mandir}/man1/wimmount.1*
145 %{_mandir}/man1/wimmountrw.1*
146 %{_mandir}/man1/wimoptimize.1*
147 %{_mandir}/man1/wimsplit.1*
148 %{_mandir}/man1/wimunmount.1*
149 %{_mandir}/man1/wimupdate.1*
150 %{_mandir}/man1/wimverify.1*
This page took 0.141877 seconds and 3 git commands to generate.