]> git.pld-linux.org Git - packages/wildmidi.git/blob - wildmidi.spec
- updated to 0.4.6
[packages/wildmidi.git] / wildmidi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  alsa            # ALSA support (OpenAL/OSS otherwise)
5 %bcond_with     openal          # OpenAL support if not ALSA (OSS otherwise)
6 #
7 Summary:        MIDI player using pat sound sets
8 Summary(pl.UTF-8):      Odtwarzacz MIDI wykorzystujący zestawy dźwięków pat
9 Name:           wildmidi
10 Version:        0.4.6
11 Release:        1
12 License:        LGPL v3+ (library), GPL v3+ (player)
13 Group:          Libraries
14 Source0:        https://downloads.sourceforge.net/wildmidi/%{name}-%{version}.tar.gz
15 # Source0-md5:  769606325dc7a54a52555fddc3323dbc
16 URL:            https://wildmidi.sourceforge.net/
17 %{?with_openal:BuildRequires:   OpenAL-devel}
18 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.1}
19 BuildRequires:  cmake >= 3.4
20 # for wildmidi player
21 %{?with_alsa:Requires:  alsa-lib >= 1.0.1}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 WildMidi is a wave table player that uses GUS pat sound sets to play
26 MIDI file. The WildMidi player is the frontend, and is only designed
27 to pass information to the core library and output any audio data the
28 library returns.
29
30 The core of the project, libWildMidi, is the work horse behind the
31 player. It's capable of multithreading and multiprocessing of MIDI
32 files, allowing for the mixing of multiple MIDI file at any one time
33 if someone had a desire to do so. This library is what turns the MIDI
34 files into audio data using the GUS pat sets.
35
36 %description -l pl.UTF-8
37 WildMidi to odtwarzacz plików MIDI wykorzystujący zestawy dźwięków pat
38 z GUS-a. WildMidi to frontend służący tylko do przekazywania
39 informacji do głównej biblioteki i wyprowadzania danych dźwiękowych
40 zwracanych przez bibliotekę.
41
42 Serce projektu, libWildMidi, to silnik stojący za odtwarzaczem. Jest w
43 stanie przetwarzać pliki MIDI wielowątkowo, pozwalając na miksowanie
44 wielu plików MIDI. Biblioteka jest tym, co zamienia pliki MIDI na dane
45 dźwiękowe przy użyciu zestawów pat z GUS-a.
46
47 %package devel
48 Summary:        Header files for WildMidi library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WildMidi
50 License:        LGPL v3+
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for WildMidi library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki WildMidi.
59
60 %package static
61 Summary:        Static WildMidi library
62 Summary(pl.UTF-8):      Statyczna biblioteka WildMidi
63 License:        LGPL v3+
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static WildMidi library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka WildMidi.
72
73 %prep
74 %setup -q
75
76 %build
77 install -d build
78 cd build
79 %cmake .. \
80         -DCMAKE_INSTALL_INCLUDEDIR=include \
81         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
82         %{?with_alsa:-DWANT_ALSA=ON} \
83         %{!?with_openal:-DWANT_OPENAL=ON} \
84         %{!?with_alsa:%{!?with_openal:-DWANT_OSS=ON}} \
85         %{?with_static_libs:-DWANT_STATIC=ON} \
86         -DWANT_PLAYERSTATIC=OFF
87         
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} -C build install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README.md
105 %attr(755,root,root) %{_bindir}/wildmidi
106 %attr(755,root,root) %{_libdir}/libWildMidi.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libWildMidi.so.2
108 %{_mandir}/man1/wildmidi.1*
109 %{_mandir}/man5/wildmidi.cfg.5*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libWildMidi.so
114 %{_includedir}/wildmidi_lib.h
115 %{_pkgconfigdir}/wildmidi.pc
116 %{_libdir}/cmake/WildMidi
117 %{_mandir}/man3/WildMidi_*.3*
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libWildMidi.a
123 %endif
This page took 0.093555 seconds and 4 git commands to generate.