]> git.pld-linux.org Git - packages/webrtc-audio-processing.git/blob - webrtc-audio-processing.spec
- note on 1.x series
[packages/webrtc-audio-processing.git] / webrtc-audio-processing.spec
1 # NOTE:
2 # f.d.o source is meant to be a more Linux packaging friendly copy of the
3 # AudioProcessing module from the WebRTC[1] project. The ideal case is that we
4 # make no changes to the code to make tracking upstream code easy.
5 # [1] http://code.google.com/p/webrtc/
6 #
7 # Conditional build:
8 %bcond_without  neon            # without ARM NEON instructions
9
10 %ifnarch armv7l armv7hl armv7hnl armv8l armv8hl armv8hnl armv8hcnl aarch64
11 %undefine       with_neon
12 %endif
13
14 Summary:        WebRTC Audio Processing library
15 Summary(pl.UTF-8):      Biblioteka WebRTC Audio Processing
16 Name:           webrtc-audio-processing
17 # keep 0.x here; for versions >= 1 (parallel installable with 0.x) see webrtc-audio-processing1.spec
18 Version:        0.3.1
19 Release:        1
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://freedesktop.org/software/pulseaudio/webrtc-audio-processing/%{name}-%{version}.tar.xz
23 # Source0-md5:  6e10724ca34bcbc715a4c208273acb0c
24 URL:            https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake >= 1:1.11
27 BuildRequires:  libstdc++-devel >= 6:4.7
28 BuildRequires:  libtool
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 WebRTC is an open source project that enables web browsers with
35 Real-Time Communications (RTC) capabilities via simple Javascript
36 APIs. The WebRTC components have been optimized to best serve this
37 purpose. WebRTC implements the W3C's proposal for video conferencing
38 on the web.
39
40 %description -l pl.UTF-8
41 WebRTC to projekt o otwartych źródłach dodający obsługę komunikacji
42 w czasie rzeczywistym (RTC - Real-Time Communications) poprzez proste
43 API JavaScriptu. Komponenty WebRTC zostały zoptymalizowane, aby jak
44 najlepiej sprawdzały się w tym zastosowaniu. WebRTC implementuje
45 propozycje W3C do wideokonferencji w sieci.
46
47 %package devel
48 Summary:        Header files for WebRTC Audio Processing library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WebRTC Audio Processing
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53
54 %description devel
55 This package contains the header files needed to develop programs
56 which make use of WebRTC Audio Processing library.
57
58 %description devel -l pl.UTF-8
59 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
60 wykorzystujących bibliotekę WebRTC Audio Processing.
61
62 %package static
63 Summary:        Static WebRTC Audio Processing library
64 Summary(pl.UTF-8):      Biblioteka statyczna WebRTC Audio Processing
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static WebRTC Audio Processing library.
70
71 %description static -l pl.UTF-8
72 Biblioteka statyczna WebRTC Audio Processing.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         %{!?with_neon:--disable-neon} \
84         --disable-silent-rules
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS COPYING NEWS README.md webrtc/PATENTS
104 %attr(755,root,root) %{_libdir}/libwebrtc_audio_processing.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libwebrtc_audio_processing.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libwebrtc_audio_processing.so
110 %{_includedir}/webrtc_audio_processing
111 %{_pkgconfigdir}/webrtc-audio-processing.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libwebrtc_audio_processing.a
This page took 0.095025 seconds and 4 git commands to generate.