]> git.pld-linux.org Git - packages/vmmlib.git/blob - vmmlib.spec
- unconditional noarch subpackages
[packages/vmmlib.git] / vmmlib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Vector and Matrix Math Library for C++
6 Summary(pl.UTF-8):      Vector and Matrix Math Library - biblioteka matematyczna wektorów i macierzy w C++
7 Name:           vmmlib
8 Version:        1.14.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/Eyescale/vmmlib/releases
13 Source0:        https://github.com/Eyescale/vmmlib/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  f25e57bfc1e4699447963f5dbafd22f2
15 URL:            http://vmml.github.io/vmmlib/
16 BuildRequires:  Eyescale-CMake >= 2018.02
17 BuildRequires:  boost-devel
18 BuildRequires:  cmake >= 3.1
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libstdc++-devel
21 Requires:       boost-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A templatized C++ vector and matrix math library.
26
27 %description -l pl.UTF-8
28 Biblioteka matematyczna wektorów i macierzy oparta na szablonach C++.
29
30 %package apidocs
31 Summary:        vmmlib API documentation
32 Summary(pl.UTF-8):      Dokumentacja API biblioteki vmmlib
33 Group:          Documentation
34 BuildArch:      noarch
35
36 %description apidocs
37 API documentation for vmmlib library.
38
39 %description apidocs -l pl.UTF-8
40 Dokumentacja API biblioteki vmmlib.
41
42 %prep
43 %setup -q
44
45 rmdir CMake/common
46 ln -s %{_datadir}/Eyescale-CMake CMake/common
47
48 %build
49 install -d build
50 cd build
51 %cmake ..
52 %{__make}
53
54 %if %{with apidocs}
55 doxygen doc/Doxyfile
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C build install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %{__rm} $RPM_BUILD_ROOT%{_datadir}/vmmlib/{ACKNOWLEDGEMENTS,LICENSE.txt,README.md}
65 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vmmlib/tests
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc ACKNOWLEDGEMENTS LICENSE.txt README.md doc/Changelog.md
73 %{_includedir}/vmmlib
74 %dir %{_datadir}/vmmlib
75 %{_datadir}/vmmlib/CMake
76
77 %if %{with apidocs}
78 %files apidocs
79 %defattr(644,root,root,755)
80 %doc build/doc/html/*
81 %endif
This page took 0.111815 seconds and 4 git commands to generate.