]> git.pld-linux.org Git - packages/vice.git/blob - vice.spec
- updated to 3.7.1
[packages/vice.git] / vice.spec
1 #
2 # Conditional build:
3 %bcond_without  ieee1284        # IEEE 1284 (parallel port) support for ParSID
4 %bcond_without  openmp          # OpenMP support
5 %bcond_without  pulseaudio      # pulseaudio support
6 %bcond_with     catweasel       # CatWeasel MK3 (PCI) hardware SID support
7 %bcond_with     hardsid         # HardSID (ISA/PCI) hardware SID support
8 %bcond_with     parsid          # ParSID (IEEE1284) hardware SID support
9 %bcond_with     ssi2001         # SSI2001 (ISA) hardware SID support
10 #
11 %if %{without parsid}
12 %undefine       with_ieee1284
13 %endif
14 Summary:        Versatile Commodore Emulator
15 Summary(pl.UTF-8):      Uniwersalny emulator Commodore
16 Name:           vice
17 Version:        3.7.1
18 Release:        1
19 License:        GPL v2+
20 Group:          Applications/Emulators
21 Source0:        https://downloads.sourceforge.net/vice-emu/%{name}-%{version}.tar.gz
22 # Source0-md5:  ffcb48e9b688d14dc5f86de22c30ee32
23 Source1:        %{name}-c128.desktop
24 Source2:        %{name}-c64.desktop
25 Source3:        %{name}-cbm2.desktop
26 Source4:        %{name}-pet.desktop
27 Source5:        %{name}-plus4.desktop
28 Source6:        %{name}-vic20.desktop
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-bash.patch
31 Patch2:         %{name}-opt.patch
32 Patch3:         %{name}-link.patch
33 URL:            https://vice-emu.sourceforge.io/
34 BuildRequires:  OpenGL-GLU-devel
35 BuildRequires:  OpenGL-GLX-devel
36 BuildRequires:  SDL2-devel >= 2.0
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  autoconf >= 2.50
39 BuildRequires:  automake
40 BuildRequires:  bison
41 BuildRequires:  ffmpeg-devel < 5
42 BuildRequires:  flac-devel
43 BuildRequires:  flex
44 BuildRequires:  fontconfig-devel >= 2.0.0
45 BuildRequires:  giflib-devel
46 BuildRequires:  glew-devel
47 BuildRequires:  glib2-devel >= 2.0
48 BuildRequires:  gtk+3-devel >= 3.22
49 BuildRequires:  lame-libs-devel
50 %{?with_ieee1284:BuildRequires: libieee1284-devel}
51 %{?with_openmp:BuildRequires:   libgomp-devel}
52 BuildRequires:  libmpg123-devel
53 BuildRequires:  libogg-devel
54 BuildRequires:  libpcap-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libstdc++-devel >= 6:4.7
57 BuildRequires:  libvorbis-devel
58 BuildRequires:  linux-libc-headers
59 %if %{with catweasel} || %{with hardsid}
60 BuildRequires:  pciutils-devel
61 %endif
62 BuildRequires:  perl-base
63 BuildRequires:  pkgconfig
64 BuildRequires:  portaudio-devel
65 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
66 BuildRequires:  readline-devel
67 BuildRequires:  rpm-build >= 4.6
68 BuildRequires:  texinfo
69 BuildRequires:  xa
70 BuildRequires:  xorg-lib-libX11-devel
71 BuildRequires:  zlib-devel
72 Requires:       fontconfig >= 2.0.0
73 Requires:       gtk+3 >= 3.22
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 VICE is a Versatile Commodore Emulator, i.e. a program that runs on a
78 Unix, MS-DOS, Win95/NT, OS/2, RiscOS or BeOS machine and executes
79 programs intended for the old 8-bit Commodore computers. The current
80 version emulates the C64, the C128 (80 column screen is included now),
81 the VIC20, all the PET models (except the SuperPET 9000, which is out
82 of line anyway), CBM-II (aka C610) and the Plus4.
83
84 %description -l pl.UTF-8
85 VICE jest wszechstronnym emulatorem 8-bitowego komputera Commodore.
86 Aktualna wersja emuluje C64, C128 (wraz z trybem pracy 80 kolumnowym),
87 VIC20, wszystkie modele PET (poza SuperPET 9000, który zresztą nie
88 pasował do tej linii), CBM-II (C610) oraz Plus4.
89
90 %package doc
91 Summary:        VICE documentation in HTML format
92 Summary(pl.UTF-8):      Dokumentacja do VICE w formacie HTML
93 Group:          Documentation
94 BuildArch:      noarch
95
96 %description doc
97 VICE documentation in HTML format.
98
99 %description doc -l pl.UTF-8
100 Dokumentacja do VICE w formacie HTML.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108
109 %build
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 export CFLAGS="%{rpmcflags} -fcommon"
115 %configure \
116         DOS2UNIX=/usr/bin/dos2unix \
117         %{?with_catweasel:--enable-catweasel} \
118         --enable-ethernet \
119         --enable-ffmpeg \
120         --enable-gtk3ui \
121         %{!?with_hardsid:--disable-hardsid} \
122         --enable-lame \
123         %{?with_ieee1284:--enable-libieee1284} \
124         --enable-midi \
125         %{!?with_openmp:--disable-openmp} \
126         %{?with_parsid:--enable-parsid} \
127         --disable-pdf-docs \
128         %{?with_ssi2001:--enable-ssi2001} \
129         --enable-x64 \
130         --enable-x64-image \
131         --with-flac \
132         --with-libcurl \
133         --with-mpg123 \
134         --with-oss \
135         %{?with_pulseaudio:--with-pulse} \
136         --with-sdlsound \
137         --with-vorbis
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_desktopdir}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
149 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
150 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
151 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
152 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
153 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}
154
155 %{__rm} $RPM_BUILD_ROOT%{_docdir}/vice/{*.txt,*.md,vice.texi}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
162
163 %postun
164 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
165
166 %files
167 %defattr(644,root,root,755)
168 %doc NEWS README doc/{CIA-README.txt,iec-bus.txt,readmes/Readme-SDL2.txt} doc/html/fonts/OFL.txt
169 %attr(755,root,root) %{_bindir}/c1541
170 %attr(755,root,root) %{_bindir}/cartconv
171 %attr(755,root,root) %{_bindir}/petcat
172 %attr(755,root,root) %{_bindir}/vsid
173 %attr(755,root,root) %{_bindir}/x128
174 %attr(755,root,root) %{_bindir}/x64
175 %attr(755,root,root) %{_bindir}/x64dtv
176 %attr(755,root,root) %{_bindir}/x64sc
177 %attr(755,root,root) %{_bindir}/xcbm2
178 %attr(755,root,root) %{_bindir}/xcbm5x0
179 %attr(755,root,root) %{_bindir}/xpet
180 %attr(755,root,root) %{_bindir}/xplus4
181 %attr(755,root,root) %{_bindir}/xscpu64
182 %attr(755,root,root) %{_bindir}/xvic
183 %{_datadir}/vice
184 %{_infodir}/vice.info*
185 %{_desktopdir}/vice-*.desktop
186
187 %files doc
188 %defattr(644,root,root,755)
189 %doc doc/html/{fonts,images,*.css,*.html,NEWS,COPYING,favicon.ico,robots.txt}
This page took 0.121774 seconds and 4 git commands to generate.