]> git.pld-linux.org Git - packages/unbound.git/blob - unbound.spec
- 1.0.1
[packages/unbound.git] / unbound.spec
1 #
2 Summary:        Recursive, validating DNS server
3 Name:           unbound
4 Version:        1.0.1
5 Release:        1
6 License:        BSD
7 Group:          Applications
8 Source0:        http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  e60c8221768cc79eca8783f01e8cf969
10 Source1:        %{name}.init
11 URL:            http://unbound.net/
12 BuildRequires:  rpmbuild(macros) >= 1.228
13 Requires(post,preun):   /sbin/chkconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Unbound is a validating, recursive, and caching DNS resolver.
18
19 The C implementation of Unbound is developed and maintained by NLnet
20 Labs. It is based on ideas and algorithms taken from a java prototype
21 developed by Verisign labs, Nominet, Kirei and ep.net.
22
23 Unbound is designed as a set of modular components, so that also
24 DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
25 a server, but are linked into an application) are easily possible.
26
27 %package devel
28 Summary:        Header files for unbound library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki unbound
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for unbound library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki unbound.
38
39 %package static
40 Summary:        Static unbound library
41 Summary(pl.UTF-8):      Statyczna biblioteka unbound
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static unbound library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka unbound.
50
51 %prep
52 %setup -q
53
54 %build
55 %configure
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
61 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 /sbin/ldconfig
71
72 %postun
73 /sbin/ldconfig
74 /sbin/chkconfig --add %{name}
75 %service %{name} restart
76
77 %preun
78 if [ "$1" = "0" ]; then
79         %service -q %{name} stop
80         /sbin/chkconfig --del %{name}
81 fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc doc/Changelog doc/CREDITS doc/plan doc/example.conf doc/README
86 %doc doc/FEATURES doc/ietf67-design-02.odp doc/ietf67-design-02.pdf
87 %doc doc/requirements.txt doc/TODO
88 %attr(754,root,root) /etc/rc.d/init.d/unbound
89 %dir %{_sysconfdir}/%{name}
90 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
91 %attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
92 %attr(755,root,root) %{_sbindir}/unbound
93 %attr(755,root,root) %{_sbindir}/unbound-checkconf
94 %attr(755,root,root) %{_sbindir}/unbound-host
95 %{_mandir}/man1/unbound-host.1*
96 %{_mandir}/man5/unbound.conf.5*
97 %{_mandir}/man8/unbound-checkconf.8*
98 %{_mandir}/man8/unbound.8*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_includedir}/unbound.h
103 %{_libdir}/libunbound.la
104 %{_libdir}/libunbound.so
105 %{_mandir}/man3/libunbound.3*
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libunbound.a
This page took 0.062974 seconds and 4 git commands to generate.