]> git.pld-linux.org Git - packages/unbound.git/blob - unbound.spec
- updated to 1.4.18
[packages/unbound.git] / unbound.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4 #
5 Summary:        Recursive, validating DNS resolver
6 Summary(pl.UTF-8):      Rekurencyjny, weryfikujący resolver DNS
7 Name:           unbound
8 Version:        1.4.18
9 Release:        1
10 License:        BSD
11 Group:          Applications/Network
12 Source0:        http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  2cad65b6a2d08bb6e0210ea92156ca4b
14 Source1:        %{name}.init
15 URL:            http://unbound.net/
16 BuildRequires:  expat-devel
17 BuildRequires:  ldns-devel >= 1.6.9
18 BuildRequires:  libevent-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpmbuild(macros) >= 1.228
21 %if %{with python}
22 BuildRequires:  python-devel >= 1:2.4.0
23 BuildRequires:  swig-python
24 %endif
25 Requires(post,preun):   /sbin/chkconfig
26 Requires:       %{name}-libs = %{version}-%{release}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Unbound is a validating, recursive, and caching DNS resolver.
31
32 The C implementation of Unbound is developed and maintained by NLnet
33 Labs. It is based on ideas and algorithms taken from a Java prototype
34 developed by Verisign labs, Nominet, Kirei and ep.net.
35
36 Unbound is designed as a set of modular components, so that also
37 DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
38 a server, but are linked into an application) are easily possible.
39
40 %description -l pl.UTF-8
41 Unbound to weryfikujący, rekurencyjny i cache'ujący resolver (kod
42 rozwiązujący nazwy) DNS.
43
44 Implementacja Unbound w C jest tworzona i utrzymywana przez NLnet
45 Labs. Jest oparta na pomysłach i algorytmach zaczerpniętych z
46 prototypu w Javie stworzonego przez Verisign Labs, Nominet, Kirei oraz
47 ep.net.
48
49 Unbound został zaprojektowany jako zbiór modularnych komponentów, więc
50 możliwe są także weryfikacja DNSSEC (bezpieczny DNS) oraz
51 resolvery-zaślepki (nie działające jako serwer, ale wbudowane w
52 aplikację).
53
54 %package libs
55 Summary:        Unbound shared library
56 Summary(pl.UTF-8):      Biblioteka współdzielona Unbound
57 Group:          Libraries
58 Conflicts:      unbound < 1.4.18-1
59
60 %description libs
61 Unbound shared library.
62
63 %description libs -l pl.UTF-8
64 Biblioteka współdzielona Unbound.
65
66 %package devel
67 Summary:        Header files for unbound library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki unbound
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       ldns-devel
72 Requires:       openssl-devel
73
74 %description devel
75 Header files for unbound library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki unbound.
79
80 %package static
81 Summary:        Static unbound library
82 Summary(pl.UTF-8):      Statyczna biblioteka unbound
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static unbound library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka unbound.
91
92 %package -n python-unbound
93 Summary:        Python interface to unbound library
94 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki unbound
95 Group:          Python/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97
98 %description -n python-unbound
99 Python interface to unbound library.
100
101 %description -n python-unbound -l pl.UTF-8
102 Pythonowy interfejs do biblioteki unbound.
103
104 %prep
105 %setup -q
106
107 %build
108 %configure \
109         %{?with_python:--with-pyunbound}
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
115 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %if %{with python}
121 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
122 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
123 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
124 %py_postclean
125 %endif
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 /sbin/chkconfig --add %{name}
132 %service %{name} restart
133
134 %preun
135 if [ "$1" = "0" ]; then
136         %service -q %{name} stop
137         /sbin/chkconfig --del %{name}
138 fi
139
140 %post   libs -p /sbin/ldconfig
141 %postun libs -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc doc/{CREDITS,Changelog,FEATURES,LICENSE,README,TODO,control_proto_spec.txt,example.conf,ietf67-design-02.pdf,requirements.txt}
146 %attr(754,root,root) /etc/rc.d/init.d/unbound
147 %dir %{_sysconfdir}/%{name}
148 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
149 %attr(755,root,root) %{_sbindir}/unbound
150 %attr(755,root,root) %{_sbindir}/unbound-anchor
151 %attr(755,root,root) %{_sbindir}/unbound-checkconf
152 %attr(755,root,root) %{_sbindir}/unbound-control*
153 %attr(755,root,root) %{_sbindir}/unbound-host
154 %{_mandir}/man1/unbound-host.1*
155 %{_mandir}/man5/unbound.conf.5*
156 %{_mandir}/man8/unbound-checkconf.8*
157 %{_mandir}/man8/unbound.8*
158 %{_mandir}/man8/unbound-anchor.8*
159 %{_mandir}/man8/unbound-control.8*
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libunbound.so
169 %{_libdir}/libunbound.la
170 %{_includedir}/unbound.h
171 %{_mandir}/man3/libunbound.3*
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libunbound.a
176
177 %if %{with python}
178 %files -n python-unbound
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{py_sitedir}/_unbound.so*
181 %{py_sitedir}/unbound.py[co]
182 %endif
This page took 0.071235 seconds and 4 git commands to generate.