]> git.pld-linux.org Git - packages/unbound.git/blob - unbound.spec
- up to 1.4.3
[packages/unbound.git] / unbound.spec
1 #
2 Summary:        Recursive, validating DNS server
3 Name:           unbound
4 Version:        1.4.3
5 Release:        1
6 License:        BSD
7 Group:          Applications
8 Source0:        http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  2dffdd42f94b8238447a41835439d129
10 Source1:        %{name}.init
11 URL:            http://unbound.net/
12 BuildRequires:  ldns-devel
13 BuildRequires:  libevent-devel
14 BuildRequires:  rpmbuild(macros) >= 1.228
15 Requires(post,preun):   /sbin/chkconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Unbound is a validating, recursive, and caching DNS resolver.
20
21 The C implementation of Unbound is developed and maintained by NLnet
22 Labs. It is based on ideas and algorithms taken from a java prototype
23 developed by Verisign labs, Nominet, Kirei and ep.net.
24
25 Unbound is designed as a set of modular components, so that also
26 DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
27 a server, but are linked into an application) are easily possible.
28
29 %package devel
30 Summary:        Header files for unbound library
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki unbound
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for unbound library.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki unbound.
40
41 %package static
42 Summary:        Static unbound library
43 Summary(pl.UTF-8):      Statyczna biblioteka unbound
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static unbound library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka unbound.
52
53 %prep
54 %setup -q
55
56 %build
57 %configure
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
63 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/ldconfig
73
74 %postun
75 /sbin/ldconfig
76 /sbin/chkconfig --add %{name}
77 %service %{name} restart
78
79 %preun
80 if [ "$1" = "0" ]; then
81         %service -q %{name} stop
82         /sbin/chkconfig --del %{name}
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc doc/Changelog doc/CREDITS doc/control_proto_spec.txt
88 %doc doc/example.conf doc/README doc/FEATURES doc/ietf67-design-02.odp
89 %doc doc/ietf67-design-02.pdf doc/requirements.txt doc/TODO 
90 %attr(754,root,root) /etc/rc.d/init.d/unbound
91 %dir %{_sysconfdir}/%{name}
92 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
93 %attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
95 %attr(755,root,root) %{_sbindir}/unbound
96 %attr(755,root,root) %{_sbindir}/unbound-checkconf
97 %attr(755,root,root) %{_sbindir}/unbound-control*
98 %attr(755,root,root) %{_sbindir}/unbound-host
99 %{_mandir}/man1/unbound-host.1*
100 %{_mandir}/man5/unbound.conf.5*
101 %{_mandir}/man8/unbound-checkconf.8*
102 %{_mandir}/man8/unbound.8*
103 %{_mandir}/man8/unbound-control.8*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %{_includedir}/unbound.h
108 %{_libdir}/libunbound.la
109 %{_libdir}/libunbound.so
110 %{_mandir}/man3/libunbound.3*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libunbound.a
This page took 0.051144 seconds and 4 git commands to generate.