]> git.pld-linux.org Git - packages/unbound.git/blob - unbound.spec
- add useradd/userremove deps
[packages/unbound.git] / unbound.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4 #
5 Summary:        Recursive, validating DNS resolver
6 Summary(pl.UTF-8):      Rekurencyjny, weryfikujący resolver DNS
7 Name:           unbound
8 Version:        1.4.21
9 Release:        2
10 License:        BSD
11 Group:          Applications/Network
12 Source0:        http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  0aa8db06ea784bf7879060bd1f6551c8
14 Source1:        %{name}.init
15 URL:            http://unbound.net/
16 BuildRequires:  expat-devel
17 BuildRequires:  ldns-devel >= 1.6.9
18 BuildRequires:  libevent-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpmbuild(macros) >= 1.228
21 %if %{with python}
22 BuildRequires:  python-devel >= 1:2.4.0
23 BuildRequires:  swig-python
24 %endif
25 Requires(post,preun):   /sbin/chkconfig
26 BuildRequires:  rpmbuild(macros) >= 1.202
27 Provides:       user(unbound)
28 Requires(postun):       /usr/sbin/userdel
29 Requires(pre):  /bin/id
30 Requires(pre):  /usr/sbin/useradd
31 Requires:       %{name}-libs = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Unbound is a validating, recursive, and caching DNS resolver.
36
37 The C implementation of Unbound is developed and maintained by NLnet
38 Labs. It is based on ideas and algorithms taken from a Java prototype
39 developed by Verisign labs, Nominet, Kirei and ep.net.
40
41 Unbound is designed as a set of modular components, so that also
42 DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
43 a server, but are linked into an application) are easily possible.
44
45 %description -l pl.UTF-8
46 Unbound to weryfikujący, rekurencyjny i cache'ujący resolver (kod
47 rozwiązujący nazwy) DNS.
48
49 Implementacja Unbound w C jest tworzona i utrzymywana przez NLnet
50 Labs. Jest oparta na pomysłach i algorytmach zaczerpniętych z
51 prototypu w Javie stworzonego przez Verisign Labs, Nominet, Kirei oraz
52 ep.net.
53
54 Unbound został zaprojektowany jako zbiór modularnych komponentów, więc
55 możliwe są także weryfikacja DNSSEC (bezpieczny DNS) oraz
56 resolvery-zaślepki (nie działające jako serwer, ale wbudowane w
57 aplikację).
58
59 %package libs
60 Summary:        Unbound shared library
61 Summary(pl.UTF-8):      Biblioteka współdzielona Unbound
62 Group:          Libraries
63 Conflicts:      unbound < 1.4.18-1
64
65 %description libs
66 Unbound shared library.
67
68 %description libs -l pl.UTF-8
69 Biblioteka współdzielona Unbound.
70
71 %package devel
72 Summary:        Header files for unbound library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki unbound
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       ldns-devel
77 Requires:       openssl-devel
78
79 %description devel
80 Header files for unbound library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki unbound.
84
85 %package static
86 Summary:        Static unbound library
87 Summary(pl.UTF-8):      Statyczna biblioteka unbound
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static unbound library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka unbound.
96
97 %package -n python-unbound
98 Summary:        Python interface to unbound library
99 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki unbound
100 Group:          Python/Libraries
101 Requires:       %{name}-libs = %{version}-%{release}
102
103 %description -n python-unbound
104 Python interface to unbound library.
105
106 %description -n python-unbound -l pl.UTF-8
107 Pythonowy interfejs do biblioteki unbound.
108
109 %prep
110 %setup -q
111
112 %build
113 %configure \
114         %{?with_python:--with-pyunbound}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
120 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %if %{with python}
126 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
127 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
128 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
129 %py_postclean
130 %endif
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 /sbin/chkconfig --add %{name}
137 %service %{name} restart
138
139 %pre
140 %useradd -u 196 -g 99 -d /tmp -s /bin/false -c "unbound user" unbound
141
142 %preun
143 if [ "$1" = "0" ]; then
144         %service -q %{name} stop
145         /sbin/chkconfig --del %{name}
146 fi
147
148 %postun
149 if [ "$1" = "0" ]; then
150         %userremove unbound
151 fi
152
153 %post   libs -p /sbin/ldconfig
154 %postun libs -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc doc/{CREDITS,Changelog,FEATURES,LICENSE,README,TODO,control_proto_spec.txt,example.conf,ietf67-design-02.pdf,requirements.txt}
159 %attr(754,root,root) /etc/rc.d/init.d/unbound
160 %dir %{_sysconfdir}/%{name}
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
162 %attr(755,root,root) %{_sbindir}/unbound
163 %attr(755,root,root) %{_sbindir}/unbound-anchor
164 %attr(755,root,root) %{_sbindir}/unbound-checkconf
165 %attr(755,root,root) %{_sbindir}/unbound-control*
166 %attr(755,root,root) %{_sbindir}/unbound-host
167 %{_mandir}/man1/unbound-host.1*
168 %{_mandir}/man5/unbound.conf.5*
169 %{_mandir}/man8/unbound-checkconf.8*
170 %{_mandir}/man8/unbound.8*
171 %{_mandir}/man8/unbound-anchor.8*
172 %{_mandir}/man8/unbound-control*.8*
173
174 %files libs
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libunbound.so
182 %{_libdir}/libunbound.la
183 %{_includedir}/unbound.h
184 %{_mandir}/man3/libunbound.3*
185 %{_mandir}/man3/ub_*.3*
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libunbound.a
190
191 %if %{with python}
192 %files -n python-unbound
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{py_sitedir}/_unbound.so*
195 %{py_sitedir}/unbound.py[co]
196 %endif
This page took 0.0458730000000001 seconds and 4 git commands to generate.