]> git.pld-linux.org Git - packages/unbound.git/blame - unbound.spec
- updated to 1.4.20
[packages/unbound.git] / unbound.spec
CommitLineData
ca75cd40 1#
89d05c6c
JB
2# Conditional build:
3%bcond_without python # Python binding
4#
5Summary: Recursive, validating DNS resolver
6Summary(pl.UTF-8): Rekurencyjny, weryfikujący resolver DNS
ca75cd40 7Name: unbound
8ad6c75c 8Version: 1.4.20
44b158d7 9Release: 1
ca75cd40 10License: BSD
89d05c6c 11Group: Applications/Network
ca75cd40 12Source0: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
8ad6c75c 13# Source0-md5: 1f2d0b490fd7928a708a326beda21948
cda91157 14Source1: %{name}.init
ca75cd40 15URL: http://unbound.net/
89d05c6c 16BuildRequires: expat-devel
511c7cae 17BuildRequires: ldns-devel >= 1.6.9
5ec53429 18BuildRequires: libevent-devel
89d05c6c 19BuildRequires: openssl-devel
ca75cd40 20BuildRequires: rpmbuild(macros) >= 1.228
89d05c6c
JB
21%if %{with python}
22BuildRequires: python-devel >= 1:2.4.0
23BuildRequires: swig-python
24%endif
ca75cd40 25Requires(post,preun): /sbin/chkconfig
89d05c6c 26Requires: %{name}-libs = %{version}-%{release}
ca75cd40 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Unbound is a validating, recursive, and caching DNS resolver.
31
32The C implementation of Unbound is developed and maintained by NLnet
89d05c6c 33Labs. It is based on ideas and algorithms taken from a Java prototype
ca75cd40 34developed by Verisign labs, Nominet, Kirei and ep.net.
35
36Unbound is designed as a set of modular components, so that also
37DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
38a server, but are linked into an application) are easily possible.
39
89d05c6c
JB
40%description -l pl.UTF-8
41Unbound to weryfikujący, rekurencyjny i cache'ujący resolver (kod
42rozwiązujący nazwy) DNS.
43
44Implementacja Unbound w C jest tworzona i utrzymywana przez NLnet
45Labs. Jest oparta na pomysłach i algorytmach zaczerpniętych z
46prototypu w Javie stworzonego przez Verisign Labs, Nominet, Kirei oraz
47ep.net.
48
49Unbound został zaprojektowany jako zbiór modularnych komponentów, więc
50możliwe są także weryfikacja DNSSEC (bezpieczny DNS) oraz
51resolvery-zaślepki (nie działające jako serwer, ale wbudowane w
52aplikację).
53
54%package libs
55Summary: Unbound shared library
56Summary(pl.UTF-8): Biblioteka współdzielona Unbound
57Group: Libraries
58Conflicts: unbound < 1.4.18-1
59
60%description libs
61Unbound shared library.
62
63%description libs -l pl.UTF-8
64Biblioteka współdzielona Unbound.
65
ca75cd40 66%package devel
67Summary: Header files for unbound library
68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki unbound
69Group: Development/Libraries
89d05c6c
JB
70Requires: %{name}-libs = %{version}-%{release}
71Requires: ldns-devel
72Requires: openssl-devel
ca75cd40 73
74%description devel
75Header files for unbound library.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe biblioteki unbound.
79
80%package static
81Summary: Static unbound library
82Summary(pl.UTF-8): Statyczna biblioteka unbound
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
87Static unbound library.
88
89%description static -l pl.UTF-8
90Statyczna biblioteka unbound.
91
89d05c6c
JB
92%package -n python-unbound
93Summary: Python interface to unbound library
94Summary(pl.UTF-8): Pythonowy interfejs do biblioteki unbound
95Group: Python/Libraries
96Requires: %{name}-libs = %{version}-%{release}
97
98%description -n python-unbound
99Python interface to unbound library.
100
101%description -n python-unbound -l pl.UTF-8
102Pythonowy interfejs do biblioteki unbound.
103
ca75cd40 104%prep
105%setup -q
106
107%build
89d05c6c
JB
108%configure \
109 %{?with_python:--with-pyunbound}
ca75cd40 110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
cda91157 114install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
115install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
ca75cd40 116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
119
89d05c6c
JB
120%if %{with python}
121%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
122%py_comp $RPM_BUILD_ROOT%{py_sitedir}
123%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
124%py_postclean
125%endif
126
ca75cd40 127%clean
128rm -rf $RPM_BUILD_ROOT
129
ca75cd40 130%post
131/sbin/chkconfig --add %{name}
132%service %{name} restart
133
134%preun
135if [ "$1" = "0" ]; then
136 %service -q %{name} stop
137 /sbin/chkconfig --del %{name}
138fi
ca75cd40 139
89d05c6c
JB
140%post libs -p /sbin/ldconfig
141%postun libs -p /sbin/ldconfig
142
ca75cd40 143%files
144%defattr(644,root,root,755)
89d05c6c 145%doc doc/{CREDITS,Changelog,FEATURES,LICENSE,README,TODO,control_proto_spec.txt,example.conf,ietf67-design-02.pdf,requirements.txt}
cda91157 146%attr(754,root,root) /etc/rc.d/init.d/unbound
783ab43a 147%dir %{_sysconfdir}/%{name}
148%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
ca75cd40 149%attr(755,root,root) %{_sbindir}/unbound
511c7cae 150%attr(755,root,root) %{_sbindir}/unbound-anchor
ca75cd40 151%attr(755,root,root) %{_sbindir}/unbound-checkconf
5ec53429 152%attr(755,root,root) %{_sbindir}/unbound-control*
ca75cd40 153%attr(755,root,root) %{_sbindir}/unbound-host
154%{_mandir}/man1/unbound-host.1*
155%{_mandir}/man5/unbound.conf.5*
156%{_mandir}/man8/unbound-checkconf.8*
157%{_mandir}/man8/unbound.8*
511c7cae 158%{_mandir}/man8/unbound-anchor.8*
5ec53429 159%{_mandir}/man8/unbound-control.8*
ca75cd40 160
89d05c6c
JB
161%files libs
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
164%attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
165
ca75cd40 166%files devel
cda91157 167%defattr(644,root,root,755)
89d05c6c 168%attr(755,root,root) %{_libdir}/libunbound.so
ca75cd40 169%{_libdir}/libunbound.la
89d05c6c 170%{_includedir}/unbound.h
ca75cd40 171%{_mandir}/man3/libunbound.3*
44b158d7 172%{_mandir}/man3/ub_*.3*
ca75cd40 173
174%files static
cda91157 175%defattr(644,root,root,755)
ca75cd40 176%{_libdir}/libunbound.a
89d05c6c
JB
177
178%if %{with python}
179%files -n python-unbound
180%defattr(644,root,root,755)
181%attr(755,root,root) %{py_sitedir}/_unbound.so*
182%{py_sitedir}/unbound.py[co]
183%endif
This page took 0.143485 seconds and 4 git commands to generate.