]> git.pld-linux.org Git - packages/unbound.git/blame - unbound.spec
- rel 2; create unbound user since it uses it by default
[packages/unbound.git] / unbound.spec
CommitLineData
ca75cd40 1#
89d05c6c
JB
2# Conditional build:
3%bcond_without python # Python binding
4#
5Summary: Recursive, validating DNS resolver
6Summary(pl.UTF-8): Rekurencyjny, weryfikujący resolver DNS
ca75cd40 7Name: unbound
379d3e5e 8Version: 1.4.21
5c77fe31 9Release: 2
ca75cd40 10License: BSD
89d05c6c 11Group: Applications/Network
ca75cd40 12Source0: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
379d3e5e 13# Source0-md5: 0aa8db06ea784bf7879060bd1f6551c8
cda91157 14Source1: %{name}.init
ca75cd40 15URL: http://unbound.net/
89d05c6c 16BuildRequires: expat-devel
511c7cae 17BuildRequires: ldns-devel >= 1.6.9
5ec53429 18BuildRequires: libevent-devel
89d05c6c 19BuildRequires: openssl-devel
ca75cd40 20BuildRequires: rpmbuild(macros) >= 1.228
89d05c6c
JB
21%if %{with python}
22BuildRequires: python-devel >= 1:2.4.0
23BuildRequires: swig-python
24%endif
ca75cd40 25Requires(post,preun): /sbin/chkconfig
89d05c6c 26Requires: %{name}-libs = %{version}-%{release}
ca75cd40 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Unbound is a validating, recursive, and caching DNS resolver.
31
32The C implementation of Unbound is developed and maintained by NLnet
89d05c6c 33Labs. It is based on ideas and algorithms taken from a Java prototype
ca75cd40 34developed by Verisign labs, Nominet, Kirei and ep.net.
35
36Unbound is designed as a set of modular components, so that also
37DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
38a server, but are linked into an application) are easily possible.
39
89d05c6c
JB
40%description -l pl.UTF-8
41Unbound to weryfikujący, rekurencyjny i cache'ujący resolver (kod
42rozwiązujący nazwy) DNS.
43
44Implementacja Unbound w C jest tworzona i utrzymywana przez NLnet
45Labs. Jest oparta na pomysłach i algorytmach zaczerpniętych z
46prototypu w Javie stworzonego przez Verisign Labs, Nominet, Kirei oraz
47ep.net.
48
49Unbound został zaprojektowany jako zbiór modularnych komponentów, więc
50możliwe są także weryfikacja DNSSEC (bezpieczny DNS) oraz
51resolvery-zaślepki (nie działające jako serwer, ale wbudowane w
52aplikację).
53
54%package libs
55Summary: Unbound shared library
56Summary(pl.UTF-8): Biblioteka współdzielona Unbound
57Group: Libraries
58Conflicts: unbound < 1.4.18-1
59
60%description libs
61Unbound shared library.
62
63%description libs -l pl.UTF-8
64Biblioteka współdzielona Unbound.
65
ca75cd40 66%package devel
67Summary: Header files for unbound library
68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki unbound
69Group: Development/Libraries
89d05c6c
JB
70Requires: %{name}-libs = %{version}-%{release}
71Requires: ldns-devel
72Requires: openssl-devel
ca75cd40 73
74%description devel
75Header files for unbound library.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe biblioteki unbound.
79
80%package static
81Summary: Static unbound library
82Summary(pl.UTF-8): Statyczna biblioteka unbound
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
87Static unbound library.
88
89%description static -l pl.UTF-8
90Statyczna biblioteka unbound.
91
89d05c6c
JB
92%package -n python-unbound
93Summary: Python interface to unbound library
94Summary(pl.UTF-8): Pythonowy interfejs do biblioteki unbound
95Group: Python/Libraries
96Requires: %{name}-libs = %{version}-%{release}
97
98%description -n python-unbound
99Python interface to unbound library.
100
101%description -n python-unbound -l pl.UTF-8
102Pythonowy interfejs do biblioteki unbound.
103
ca75cd40 104%prep
105%setup -q
106
107%build
89d05c6c
JB
108%configure \
109 %{?with_python:--with-pyunbound}
ca75cd40 110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
cda91157 114install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
115install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
ca75cd40 116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
119
89d05c6c
JB
120%if %{with python}
121%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
122%py_comp $RPM_BUILD_ROOT%{py_sitedir}
123%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
124%py_postclean
125%endif
126
ca75cd40 127%clean
128rm -rf $RPM_BUILD_ROOT
129
ca75cd40 130%post
131/sbin/chkconfig --add %{name}
132%service %{name} restart
133
5c77fe31
AM
134%pre
135%useradd -u 196 -g 99 -d /tmp -s /bin/false -c "unbound user" unbound
136
ca75cd40 137%preun
138if [ "$1" = "0" ]; then
139 %service -q %{name} stop
140 /sbin/chkconfig --del %{name}
141fi
ca75cd40 142
5c77fe31
AM
143%postun
144if [ "$1" = "0" ]; then
145 %userremove unbound
146fi
147
89d05c6c
JB
148%post libs -p /sbin/ldconfig
149%postun libs -p /sbin/ldconfig
150
ca75cd40 151%files
152%defattr(644,root,root,755)
89d05c6c 153%doc doc/{CREDITS,Changelog,FEATURES,LICENSE,README,TODO,control_proto_spec.txt,example.conf,ietf67-design-02.pdf,requirements.txt}
cda91157 154%attr(754,root,root) /etc/rc.d/init.d/unbound
783ab43a 155%dir %{_sysconfdir}/%{name}
156%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
ca75cd40 157%attr(755,root,root) %{_sbindir}/unbound
511c7cae 158%attr(755,root,root) %{_sbindir}/unbound-anchor
ca75cd40 159%attr(755,root,root) %{_sbindir}/unbound-checkconf
5ec53429 160%attr(755,root,root) %{_sbindir}/unbound-control*
ca75cd40 161%attr(755,root,root) %{_sbindir}/unbound-host
162%{_mandir}/man1/unbound-host.1*
163%{_mandir}/man5/unbound.conf.5*
164%{_mandir}/man8/unbound-checkconf.8*
165%{_mandir}/man8/unbound.8*
511c7cae 166%{_mandir}/man8/unbound-anchor.8*
379d3e5e 167%{_mandir}/man8/unbound-control*.8*
ca75cd40 168
89d05c6c
JB
169%files libs
170%defattr(644,root,root,755)
171%attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
172%attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
173
ca75cd40 174%files devel
cda91157 175%defattr(644,root,root,755)
89d05c6c 176%attr(755,root,root) %{_libdir}/libunbound.so
ca75cd40 177%{_libdir}/libunbound.la
89d05c6c 178%{_includedir}/unbound.h
ca75cd40 179%{_mandir}/man3/libunbound.3*
44b158d7 180%{_mandir}/man3/ub_*.3*
ca75cd40 181
182%files static
cda91157 183%defattr(644,root,root,755)
ca75cd40 184%{_libdir}/libunbound.a
89d05c6c
JB
185
186%if %{with python}
187%files -n python-unbound
188%defattr(644,root,root,755)
189%attr(755,root,root) %{py_sitedir}/_unbound.so*
190%{py_sitedir}/unbound.py[co]
191%endif
This page took 0.088884 seconds and 4 git commands to generate.