]> git.pld-linux.org Git - packages/unbound.git/blame - unbound.spec
- add useradd/userremove deps
[packages/unbound.git] / unbound.spec
CommitLineData
ca75cd40 1#
89d05c6c
JB
2# Conditional build:
3%bcond_without python # Python binding
4#
5Summary: Recursive, validating DNS resolver
6Summary(pl.UTF-8): Rekurencyjny, weryfikujący resolver DNS
ca75cd40 7Name: unbound
379d3e5e 8Version: 1.4.21
5c77fe31 9Release: 2
ca75cd40 10License: BSD
89d05c6c 11Group: Applications/Network
ca75cd40 12Source0: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
379d3e5e 13# Source0-md5: 0aa8db06ea784bf7879060bd1f6551c8
cda91157 14Source1: %{name}.init
ca75cd40 15URL: http://unbound.net/
89d05c6c 16BuildRequires: expat-devel
511c7cae 17BuildRequires: ldns-devel >= 1.6.9
5ec53429 18BuildRequires: libevent-devel
89d05c6c 19BuildRequires: openssl-devel
ca75cd40 20BuildRequires: rpmbuild(macros) >= 1.228
89d05c6c
JB
21%if %{with python}
22BuildRequires: python-devel >= 1:2.4.0
23BuildRequires: swig-python
24%endif
ca75cd40 25Requires(post,preun): /sbin/chkconfig
5946fd51
AM
26BuildRequires: rpmbuild(macros) >= 1.202
27Provides: user(unbound)
28Requires(postun): /usr/sbin/userdel
29Requires(pre): /bin/id
30Requires(pre): /usr/sbin/useradd
89d05c6c 31Requires: %{name}-libs = %{version}-%{release}
ca75cd40 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Unbound is a validating, recursive, and caching DNS resolver.
36
37The C implementation of Unbound is developed and maintained by NLnet
89d05c6c 38Labs. It is based on ideas and algorithms taken from a Java prototype
ca75cd40 39developed by Verisign labs, Nominet, Kirei and ep.net.
40
41Unbound is designed as a set of modular components, so that also
42DNSSEC (secure DNS) validation and stub-resolvers (that do not run as
43a server, but are linked into an application) are easily possible.
44
89d05c6c
JB
45%description -l pl.UTF-8
46Unbound to weryfikujący, rekurencyjny i cache'ujący resolver (kod
47rozwiązujący nazwy) DNS.
48
49Implementacja Unbound w C jest tworzona i utrzymywana przez NLnet
50Labs. Jest oparta na pomysłach i algorytmach zaczerpniętych z
51prototypu w Javie stworzonego przez Verisign Labs, Nominet, Kirei oraz
52ep.net.
53
54Unbound został zaprojektowany jako zbiór modularnych komponentów, więc
55możliwe są także weryfikacja DNSSEC (bezpieczny DNS) oraz
56resolvery-zaślepki (nie działające jako serwer, ale wbudowane w
57aplikację).
58
59%package libs
60Summary: Unbound shared library
61Summary(pl.UTF-8): Biblioteka współdzielona Unbound
62Group: Libraries
63Conflicts: unbound < 1.4.18-1
64
65%description libs
66Unbound shared library.
67
68%description libs -l pl.UTF-8
69Biblioteka współdzielona Unbound.
70
ca75cd40 71%package devel
72Summary: Header files for unbound library
73Summary(pl.UTF-8): Pliki nagłówkowe biblioteki unbound
74Group: Development/Libraries
89d05c6c
JB
75Requires: %{name}-libs = %{version}-%{release}
76Requires: ldns-devel
77Requires: openssl-devel
ca75cd40 78
79%description devel
80Header files for unbound library.
81
82%description devel -l pl.UTF-8
83Pliki nagłówkowe biblioteki unbound.
84
85%package static
86Summary: Static unbound library
87Summary(pl.UTF-8): Statyczna biblioteka unbound
88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90
91%description static
92Static unbound library.
93
94%description static -l pl.UTF-8
95Statyczna biblioteka unbound.
96
89d05c6c
JB
97%package -n python-unbound
98Summary: Python interface to unbound library
99Summary(pl.UTF-8): Pythonowy interfejs do biblioteki unbound
100Group: Python/Libraries
101Requires: %{name}-libs = %{version}-%{release}
102
103%description -n python-unbound
104Python interface to unbound library.
105
106%description -n python-unbound -l pl.UTF-8
107Pythonowy interfejs do biblioteki unbound.
108
ca75cd40 109%prep
110%setup -q
111
112%build
89d05c6c
JB
113%configure \
114 %{?with_python:--with-pyunbound}
ca75cd40 115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
cda91157 119install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
120install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
ca75cd40 121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
89d05c6c
JB
125%if %{with python}
126%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
127%py_comp $RPM_BUILD_ROOT%{py_sitedir}
128%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
129%py_postclean
130%endif
131
ca75cd40 132%clean
133rm -rf $RPM_BUILD_ROOT
134
ca75cd40 135%post
136/sbin/chkconfig --add %{name}
137%service %{name} restart
138
5c77fe31
AM
139%pre
140%useradd -u 196 -g 99 -d /tmp -s /bin/false -c "unbound user" unbound
141
ca75cd40 142%preun
143if [ "$1" = "0" ]; then
144 %service -q %{name} stop
145 /sbin/chkconfig --del %{name}
146fi
ca75cd40 147
5c77fe31
AM
148%postun
149if [ "$1" = "0" ]; then
150 %userremove unbound
151fi
152
89d05c6c
JB
153%post libs -p /sbin/ldconfig
154%postun libs -p /sbin/ldconfig
155
ca75cd40 156%files
157%defattr(644,root,root,755)
89d05c6c 158%doc doc/{CREDITS,Changelog,FEATURES,LICENSE,README,TODO,control_proto_spec.txt,example.conf,ietf67-design-02.pdf,requirements.txt}
cda91157 159%attr(754,root,root) /etc/rc.d/init.d/unbound
783ab43a 160%dir %{_sysconfdir}/%{name}
161%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/unbound.conf
ca75cd40 162%attr(755,root,root) %{_sbindir}/unbound
511c7cae 163%attr(755,root,root) %{_sbindir}/unbound-anchor
ca75cd40 164%attr(755,root,root) %{_sbindir}/unbound-checkconf
5ec53429 165%attr(755,root,root) %{_sbindir}/unbound-control*
ca75cd40 166%attr(755,root,root) %{_sbindir}/unbound-host
167%{_mandir}/man1/unbound-host.1*
168%{_mandir}/man5/unbound.conf.5*
169%{_mandir}/man8/unbound-checkconf.8*
170%{_mandir}/man8/unbound.8*
511c7cae 171%{_mandir}/man8/unbound-anchor.8*
379d3e5e 172%{_mandir}/man8/unbound-control*.8*
ca75cd40 173
89d05c6c
JB
174%files libs
175%defattr(644,root,root,755)
176%attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
177%attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
178
ca75cd40 179%files devel
cda91157 180%defattr(644,root,root,755)
89d05c6c 181%attr(755,root,root) %{_libdir}/libunbound.so
ca75cd40 182%{_libdir}/libunbound.la
89d05c6c 183%{_includedir}/unbound.h
ca75cd40 184%{_mandir}/man3/libunbound.3*
44b158d7 185%{_mandir}/man3/ub_*.3*
ca75cd40 186
187%files static
cda91157 188%defattr(644,root,root,755)
ca75cd40 189%{_libdir}/libunbound.a
89d05c6c
JB
190
191%if %{with python}
192%files -n python-unbound
193%defattr(644,root,root,755)
194%attr(755,root,root) %{py_sitedir}/_unbound.so*
195%{py_sitedir}/unbound.py[co]
196%endif
This page took 0.074663 seconds and 4 git commands to generate.