]> git.pld-linux.org Git - packages/tin.git/blob - tin.spec
icu rebuild
[packages/tin.git] / tin.spec
1 #
2 #   You can build tin with:
3 # --define 'domain_name your.domain'
4 # --define 'default_server default.nntp.server'
5 #
6 Summary:        tin News Reader
7 Summary(de.UTF-8):      tin News-Reader
8 Summary(fr.UTF-8):      Lecteur de news tin
9 Summary(pl.UTF-8):      tin - czytnik newsów
10 Summary(ru.UTF-8):      tin - программа для чтения телеконференций Usenet
11 Summary(tr.UTF-8):      Haber okuyucu
12 Summary(uk.UTF-8):      tin - програма для читання телеконференцій Usenet
13 Name:           tin
14 Version:        2.4.5
15 Release:        1
16 Epoch:          5
17 License:        distributable
18 Group:          Applications/News
19 Source0:        ftp://ftp.tin.org/pub/news/clients/tin/stable/%{name}-%{version}.tar.gz
20 # Source0-md5:  303016b1aa8d845cc79d6bd6754a81a8
21 Source1:        %{name}.desktop
22 Source2:        %{name}.attributes
23 Patch0:         %{name}-enable_coloring.patch
24 Patch1:         %{name}-charset.patch
25 URL:            http://www.tin.org/
26 BuildRequires:  bison
27 BuildRequires:  gettext-tools
28 BuildRequires:  gsasl-devel
29 BuildRequires:  libicu-devel
30 BuildRequires:  libidn-devel
31 BuildRequires:  ncurses-devel >= 5.0
32 BuildRequires:  pcre-devel
33 BuildRequires:  uudeview-devel
34 Requires:       urlview
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Tin is a full-screen easy to use Netnews reader. It can read news
39 locally (i.e., /var/spool/news) or remotely (rtin or tin -r option)
40 via a NNTP (Network News Transport Protocol) server. It will
41 automatically utilize NOV (News OVerview) style index files if
42 available locally or via the NNTP XOVER command.
43
44 Tin has four separate levels of operation: Group selection level,
45 Group level, Thread level and Article level. Use the 'h' (help)
46 command to view a list of the commands available at a particular
47 level.
48
49 %description -l de.UTF-8
50 Tin ist ein Vollbild-Newsreader. Das Programm kann entweder lokal
51 (z.B. usr/spool/news) oder entfernt (Option 'rtin' bzw. 'tin -r') über
52 einen NNTP-Server (Network News Transport Protocol) eingesetzt werden.
53
54 %description -l fr.UTF-8
55 Tin est un lecteur de news plein écran facile à utiliser. Il peut lire
56 des articles localement (i.e. /usr/spool/news) ou à distance ('rtin'
57 ou 'tin -r') via un serveur NNTP (Network News Transport Protocol).
58
59 %description -l pl.UTF-8
60 Tin jest pełnoekranowym czytnikiem newsów. Umożliwia czytanie zarówno
61 z lokalnych zasobów (np. z katalogu /var/spool/news jak i ze zdalnych
62 (uruchamiając 'rtin' lub 'tin -r') serwerów NNTP (Network News
63 Transport Protocol).
64
65 %description -l ru.UTF-8
66 Tin - это простая в использовании полноэкранная программа для чтения
67 телеконференций Usenet. Она может читать телеконференции с локальной
68 (т.е. /var/spool/news) или удаленной (rtin или опция tin -r) по NNTP
69 (Network News Transport Protocol).
70
71 %description -l tr.UTF-8
72 Tin, metin ekranda çalışan kolay kullanılır bir USENET haber
73 okuyucusudur. Haberleri yerel olarak (/usr/spool/news), ya da bir NNTP
74 sunucusu aracılığıyla uzaktan ('rtin' ya da 'tin -r' seçeneği ile)
75 okuyabilir.
76
77 %description -l uk.UTF-8
78 Tin - це проста у використанні повноекранна програма для читання
79 телеконференцій Usenet. Вона дозволяє читати телеконференції як з
80 локальної машини (тобто /var/spool/news) так і з віддаленої (rtin або
81 опція tin -r) по NNTP (Network News Transport Protocol).
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %build
89 LDFLAGS="%{rpmldflags}"
90 %configure2_13 \
91         --disable-debug \
92         --enable-color \
93         --enable-curses \
94         --enable-ipv6 \
95         --enable-nls \
96         --with-gpg=%{_bindir}/gpg \
97         --with-ispell=%{_bindir}/ispell \
98         --with-mailer=/usr/lib/sendmail \
99         --with-metamail=%{_bindir}/metamail \
100         --with-ncurses \
101         --with-nov-dir=%{_var}/spool/news \
102         --with-pcre \
103         --with-screen=ncurses \
104         --with-spooldir=%{_var}/spool/news \
105         %{?domain_name:--with-domain-name=%{domain_name}} \
106         %{?default_server:--with-nntp-default-server=%{default_server}}
107
108 %{__make} -C src
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT/{etc,etc/tin,%{_bindir},%{_mandir}/man1,%{_mandir}/man5,%{_desktopdir}}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 cp -p doc/tin.defaults $RPM_BUILD_ROOT%{_sysconfdir}/tin/tinrc
118 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tin/attributes
119 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rtin.1
120 echo ".so tin.1" > $RPM_BUILD_ROOT%{_mandir}/man1/rtin.1
121
122 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
123
124 # file conflict mmdf between mutt and tin
125 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mmdf.5*
126 # file conflict mbox between manpages and tin
127 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mbox.5*
128
129 %find_lang %{name}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc README MANIFEST doc/{CHANGES,TODO,DEBUG_REFS,WHATSNEW,*.txt}
137 %dir %{_sysconfdir}/%{name}
138 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/tinrc
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/attributes
140 %attr(755,root,root) %{_bindir}/metamutt
141 %attr(755,root,root) %{_bindir}/opt-case.pl
142 %attr(755,root,root) %{_bindir}/rtin
143 %attr(755,root,root) %{_bindir}/tin
144 %attr(755,root,root) %{_bindir}/tinews.pl
145 %attr(755,root,root) %{_bindir}/url_handler.pl
146 %attr(755,root,root) %{_bindir}/w2r.pl
147 %{_mandir}/man1/opt-case.pl.1*
148 %{_mandir}/man1/rtin.1*
149 %{_mandir}/man1/tin.1*
150 %{_mandir}/man1/tinews.pl.1*
151 %{_mandir}/man1/url_handler.pl.1*
152 %{_mandir}/man1/w2r.pl.1*
153 %{_mandir}/man5/tin.5*
154 %{_mandir}/man5/rtin.5*
155 %{_desktopdir}/tin.desktop
This page took 0.065561 seconds and 3 git commands to generate.