]> git.pld-linux.org Git - packages/swish-e.git/commitdiff
- avoid namespace pollution, patch from debian
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 15 Sep 2014 22:01:11 +0000 (00:01 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 15 Sep 2014 22:01:11 +0000 (00:01 +0200)
namespace.patch [new file with mode: 0644]
swish-e.spec

diff --git a/namespace.patch b/namespace.patch
new file mode 100644 (file)
index 0000000..3e49d6b
--- /dev/null
@@ -0,0 +1,30 @@
+--- swish-e-2.4.7.orig/perl/API.pm
++++ swish-e-2.4.7/perl/API.pm
+@@ -2,7 +2,7 @@
+ # $Id: API.pm 2499 2009-10-04 03:34:07Z karpet $
+-use vars qw/ @ISA $VERSION /;
++use vars qw/ @ISA $VERSION/;
+ $VERSION = '0.04_01';
+@@ -31,7 +31,17 @@
+     return $m;
+ }
+-CL: for my $class ( grep { m/::$/ } keys %SWISH::API:: )
++# Fix for Debian Bug #422609
++@moduleslist = ( 
++  "MetaName::",
++  "Search::",
++  "PropertyName::",
++  "Results::",
++  "FuzzyWord::",
++  "Result::",
++);
++
++CL: for my $class ( @moduleslist )
+ {
+     local *c = $SWISH::API::{$class};
+     METH: foreach my $meth ( keys %c ) {
index 75375f9473f1bf916aa14ff36a8e124e6d7ae966..f94c19fb58d2566cc9988e577236a08322f96ce9 100644 (file)
@@ -12,6 +12,7 @@ Group:                Applications/Text
 Source0:       http://swish-e.org/swish-daily/%{name}-%{version}-%{snap}.tar.gz
 # Source0-md5: c6b918413382ff61eb5e224c8b4c6f7d
 Patch0:                format-security.patch
+Patch1:                namespace.patch
 URL:           http://swish-e.org/
 #Icon:         swish-e.xpm
 BuildRequires: libxml2-devel
@@ -144,6 +145,7 @@ Biblioteka statyczna dla swish-e.
 %prep
 %setup -q -n %{name}-%{version}-%{snap}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %configure \
This page took 0.150368 seconds and 4 git commands to generate.