]> git.pld-linux.org Git - packages/sslsplit.git/commitdiff
- rebuild with openssl 3.0.0, rel 2 master auto/th/sslsplit-0.5.5-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Oct 2021 19:53:39 +0000 (21:53 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Oct 2021 19:53:39 +0000 (21:53 +0200)
openssl3.patch [new file with mode: 0644]
sslsplit.spec

diff --git a/openssl3.patch b/openssl3.patch
new file mode 100644 (file)
index 0000000..09ebb0d
--- /dev/null
@@ -0,0 +1,58 @@
+--- sslsplit-0.5.5/pxyconn.c~  2019-08-30 13:09:00.000000000 +0200
++++ sslsplit-0.5.5/pxyconn.c   2021-10-03 21:51:40.305960755 +0200
+@@ -2188,7 +2188,7 @@
+                       /* these can happen due to client cert auth,
+                        * only log error if debugging is activated */
+                       log_dbg_printf("Error from %s bufferevent: "
+-                                     "%i:%s %lu:%i:%s:%i:%s:%i:%s\n",
++                                     "%i:%s %lu:%i:%s:%i:%s:%s\n",
+                                      (bev == ctx->src.bev) ? "src" : "dst",
+                                      errno,
+                                      errno ? strerror(errno) : "-",
+@@ -2199,24 +2199,22 @@
+                                      ERR_GET_LIB(sslerr),
+                                      sslerr ?
+                                      ERR_lib_error_string(sslerr) : "-",
+-                                     ERR_GET_FUNC(sslerr),
+                                      sslerr ?
+                                      ERR_func_error_string(sslerr) : "-");
+                       while ((sslerr = bufferevent_get_openssl_error(bev))) {
+                               log_dbg_printf("Additional SSL error: "
+-                                             "%lu:%i:%s:%i:%s:%i:%s\n",
++                                             "%lu:%i:%s:%i:%s:%s\n",
+                                              sslerr,
+                                              ERR_GET_REASON(sslerr),
+                                              ERR_reason_error_string(sslerr),
+                                              ERR_GET_LIB(sslerr),
+                                              ERR_lib_error_string(sslerr),
+-                                             ERR_GET_FUNC(sslerr),
+                                              ERR_func_error_string(sslerr));
+                       }
+               } else {
+                       /* real errors */
+                       log_err_printf("Error from %s bufferevent: "
+-                                     "%i:%s %lu:%i:%s:%i:%s:%i:%s\n",
++                                     "%i:%s %lu:%i:%s:%i:%s:%s\n",
+                                      (bev == ctx->src.bev) ? "src" : "dst",
+                                      errno,
+                                      errno ? strerror(errno) : "-",
+@@ -2227,18 +2225,16 @@
+                                      ERR_GET_LIB(sslerr),
+                                      sslerr ?
+                                      ERR_lib_error_string(sslerr) : "-",
+-                                     ERR_GET_FUNC(sslerr),
+                                      sslerr ?
+                                      ERR_func_error_string(sslerr) : "-");
+                       while ((sslerr = bufferevent_get_openssl_error(bev))) {
+                               log_err_printf("Additional SSL error: "
+-                                             "%lu:%i:%s:%i:%s:%i:%s\n",
++                                             "%lu:%i:%s:%i:%s:%s\n",
+                                              sslerr,
+                                              ERR_GET_REASON(sslerr),
+                                              ERR_reason_error_string(sslerr),
+                                              ERR_GET_LIB(sslerr),
+                                              ERR_lib_error_string(sslerr),
+-                                             ERR_GET_FUNC(sslerr),
+                                              ERR_func_error_string(sslerr));
+                       }
+               }
index a84115c15e35cb81f25324eb8ed0cc3b557c1678..91b746e011dd4f4dfef60fde72d658d9ee36434b 100644 (file)
@@ -2,13 +2,14 @@ Summary:      Transparent and scalable SSL/TLS interception
 Summary(pl.UTF-8):     Przezroczyste i skalowalne przechwytywanie SSL/TLS
 Name:          sslsplit
 Version:       0.5.5
-Release:       1
+Release:       2
 License:       BSD
 Group:         Applications/System
 # see also https://github.com/droe/sslsplit/releases
 #Source0:      https://github.com/droe/sslsplit/archive/%{version}/%{name}-%{version}.tar.gz
 Source0:       https://mirror.roe.ch/rel/sslsplit/%{name}-%{version}.tar.bz2
 # Source0-md5: c9628996a930bd18ce8e635dbedf0362
+Patch0:                openssl3.patch
 URL:           https://www.roe.ch/SSLsplit
 BuildRequires: check-devel
 BuildRequires: libevent-devel >= 2
@@ -46,10 +47,12 @@ netfiltra.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__make} \
        CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        DEBUG_CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        PKG_LDFLAGS="%{rpmldflags}"
 
This page took 0.086683 seconds and 4 git commands to generate.