]> git.pld-linux.org Git - packages/sord.git/blob - sord.spec
- updated to 0.16.16
[packages/sord.git] / sord.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # API documentation
4
5 Summary:        Lightweight C library for storing RDF data in memory
6 Summary(pl.UTF-8):      Lekka biblioteka C do przechowywania danych RDF w pamięci
7 Name:           sord
8 Version:        0.16.16
9 Release:        1
10 License:        ISC
11 Group:          Libraries
12 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.xz
13 # Source0-md5:  003384f397d832180b0cc1bdf339368d
14 URL:            http://drobilla.net/software/sord/
15 BuildRequires:  meson >= 0.56.0
16 BuildRequires:  ninja >= 1.5
17 BuildRequires:  pcre2-8-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  serd-devel >= 0.30.10
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRequires:  zix-devel >= 0.4.0
23 %if %{with apidocs}
24 BuildRequires:  doxygen
25 %endif
26 Requires:       serd >= 0.30.10
27 Requires:       zix >= 0.4.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Sord is a lightweight C library for storing RDF data in memory.
32
33 %description -l pl.UTF-8
34 Sort to lekka biblioteka C do przechowywania danych RDF w pamięci.
35
36 %package devel
37 Summary:        Header files for sord library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sord
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       serd-devel >= 0.30.10
42 Requires:       zix-devel >= 0.4.0
43
44 %description devel
45 Header files for sord library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki sord.
49
50 %prep
51 %setup -q
52
53 %build
54 %meson build \
55         --default-library=shared \
56         %{!?with_apidocs:-Ddocs=disabled}
57
58 %ninja_build -C build
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %ninja_install -C build
64
65 %if %{without apidocs}
66 # -Ddocs=disabled disables man page installation
67 install -d $RPM_BUILD_ROOT%{_mandir}/man1
68 cp -p doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
69 %endif
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS COPYING NEWS README.md
80 %attr(755,root,root) %{_bindir}/sord_validate
81 %attr(755,root,root) %{_bindir}/sordi
82 %attr(755,root,root) %{_libdir}/libsord-0.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libsord-0.so.0
84 %{_mandir}/man1/sord_validate.1*
85 %{_mandir}/man1/sordi.1*
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/libsord-0.so
90 %{_includedir}/sord-0
91 %{_pkgconfigdir}/sord-0.pc
This page took 0.100225 seconds and 4 git commands to generate.