]> git.pld-linux.org Git - packages/simdjson.git/blob - simdjson.spec
macros for %cmake
[packages/simdjson.git] / simdjson.spec
1 Summary:        Parsing gigabytes of JSON per second
2 Name:           simdjson
3 Version:        0.8.2
4 Release:        1
5 License:        Apache v2.0
6 Group:          Libraries
7 #Source0Download: https://github.com/simdjson/simdjson/releases
8 Source0:        https://github.com/simdjson/simdjson/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  b88e14c5724145561cbe840eb589da98
10 URL:            https://simdjson.org
11 BuildRequires:  cmake >= 3.9
12 BuildRequires:  libstdc++-devel >= 6:5
13 BuildRequires:  rpmbuild(macros) >= 1.605
14 ExclusiveArch:  %{x8664} aarch64
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 JSON documents are everywhere on the Internet. Servers spend a lot of
19 time parsing these documents. simdjson aims to accelerate the parsing
20 of JSON per se using commonly available SIMD instructions as much as
21 possible while doing full validation (including character encoding).
22
23 %package devel
24 Summary:        Header files for simdjson library
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27
28 %description devel
29 Header files for simdjson library.
30
31 %prep
32 %setup -q
33
34 %build
35 %cmake \
36         -DSIMDJSON_JUST_LIBRARY=ON
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post   -p /sbin/ldconfig
48 %postun -p /sbin/ldconfig
49
50 %files
51 %defattr(644,root,root,755)
52 %doc AUTHORS CONTRIBUTING.md CONTRIBUTORS HACKING.md README.md RELEASES.md
53 %attr(755,root,root) %{_libdir}/libsimdjson.so.*.*.*
54 %attr(755,root,root) %ghost %{_libdir}/libsimdjson.so.7
55
56 %files devel
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_libdir}/libsimdjson.so
59 %{_libdir}/cmake/simdjson
60 %{_includedir}/simdjson.h
This page took 0.069092 seconds and 3 git commands to generate.