]> git.pld-linux.org Git - packages/scribus.git/commitdiff
- up to 1.5.5
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 1 Aug 2020 11:52:02 +0000 (13:52 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 1 Aug 2020 11:52:02 +0000 (13:52 +0200)
- upstream switched to qt5
- use upstream desktop file

gcc10.patch [new file with mode: 0644]
poppler-0.84.0.patch [new file with mode: 0644]
poppler-0.86.0.patch [new file with mode: 0644]
qt-5.15.patch [new file with mode: 0644]
scribus.desktop [deleted file]
scribus.spec

diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..ba7747c
--- /dev/null
@@ -0,0 +1,22 @@
+--- scribus-1.5.5/scribus/plugins/import/pdf/slaoutput.h~      2020-08-01 12:12:08.000000000 +0200
++++ scribus-1.5.5/scribus/plugins/import/pdf/slaoutput.h       2020-08-01 12:15:46.683302925 +0200
+@@ -229,7 +229,7 @@
\r
+       //----- image drawing\r
+       void drawImageMask(GfxState *state, Object *ref, Stream *str, int width, int height, GBool invert, GBool interpolate, GBool inlineImg) override;\r
+-      void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg) override;\r
++      void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg);\r
+       void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,\r
+                                  int width, int height,\r
+                                  GfxImageColorMap *colorMap,\r
+@@ -261,8 +261,8 @@
+       //----- text drawing\r
+       void  beginTextObject(GfxState *state) override;\r
+       void  endTextObject(GfxState *state) override;\r
+-      void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/) override;\r
+-      GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/) override;\r
++      void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/);\r
++      GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/);\r
+       void  endType3Char(GfxState * /*state*/) override;\r
+       void  type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/) override;\r
+       void  type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/) override;\r
diff --git a/poppler-0.84.0.patch b/poppler-0.84.0.patch
new file mode 100644 (file)
index 0000000..3c44024
--- /dev/null
@@ -0,0 +1,157 @@
+--- a/scribus/plugins/import/pdf/importpdf.cpp
++++ b/scribus/plugins/import/pdf/importpdf.cpp
+@@ -74,7 +74,11 @@ PdfPlug::PdfPlug(ScribusDoc* doc, int flags)
+ QImage PdfPlug::readThumbnail(const QString& fName)\r
+ {\r
+       QString pdfFile = QDir::toNativeSeparators(fName);\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
++      globalParams.reset(new GlobalParams());\r
++#else\r
+       globalParams = new GlobalParams();\r
++#endif\r
+       if (globalParams)\r
+       {\r
+ #if defined(Q_OS_WIN32) && POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 62, 0)\r
+@@ -89,7 +93,9 @@ QImage PdfPlug::readThumbnail(const QString& fName)
+                       if (pdfDoc->getErrorCode() == errEncrypted)\r
+                       {\r
+                               delete pdfDoc;\r
++#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
+                               delete globalParams;\r
++#endif\r
+                               return QImage();\r
+                       }\r
+                       if (pdfDoc->isOk())\r
+@@ -133,11 +139,15 @@ QImage PdfPlug::readThumbnail(const QString& fName)
+                               image.setText("YSize", QString("%1").arg(h));\r
+                               delete dev;\r
+                               delete pdfDoc;\r
++#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
+                               delete globalParams;\r
++#endif\r
+                               return image;\r
+                       }\r
+                       delete pdfDoc;\r
++#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
+                       delete globalParams;\r
++#endif\r
+               }\r
+       }\r
+       return QImage();\r
+@@ -343,7 +353,11 @@ bool PdfPlug::convert(const QString& fn)
+               qApp->processEvents();\r
+       }\r
\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
++      globalParams.reset(new GlobalParams());\r
++#else\r
+       globalParams = new GlobalParams();\r
++#endif\r
+       GooString *userPW = nullptr;\r
+       if (globalParams)\r
+       {\r
+@@ -385,7 +399,9 @@ bool PdfPlug::convert(const QString& fn)
+                                       if (progressDialog)\r
+                                               progressDialog->close();\r
+                                       delete pdfDoc;\r
++#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
+                                       delete globalParams;\r
++#endif\r
+                                       return false;\r
+                               }\r
+                               if (progressDialog)\r
+@@ -430,7 +446,9 @@ bool PdfPlug::convert(const QString& fn)
+                                                       progressDialog->close();\r
+                                               delete optImp;\r
+                                               delete pdfDoc;\r
++#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
+                                               delete globalParams;\r
++#endif\r
+                                               return false;\r
+                                       }\r
+                                       pageString = optImp->getPagesString();\r
+@@ -843,8 +861,12 @@ bool PdfPlug::convert(const QString& fn)
+               }\r
+               delete pdfDoc;\r
+       }\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
++      globalParams.release();\r
++#else\r
+       delete globalParams;\r
+       globalParams = nullptr;\r
++#endif\r
\r
+ //    qDebug() << "converting finished";\r
+ //    qDebug() << "Imported" << Elements.count() << "Elements";\r
+diff --git a/scribus/plugins/import/pdf/importpdfconfig.h b/scribus/plugins/import/pdf/importpdfconfig.h
+index 9913ee382..5a7e0d216 100644
+--- a/scribus/plugins/import/pdf/importpdfconfig.h
++++ b/scribus/plugins/import/pdf/importpdfconfig.h
+@@ -58,4 +58,10 @@ for which a new license (GPL+exception) is in place.
+ #define POPPLER_CONST_082\r
+ #endif\r
\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
++#define POPPLER_CONST_083 const\r
++#else\r
++#define POPPLER_CONST_083\r
++#endif\r
++\r
+ #endif\r
+diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
+index 5e4d32a55..ffcfa8450 100644
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -3678,7 +3678,7 @@ QString SlaOutputDev::getAnnotationColor(const AnnotColor *color)
+       return fNam;\r
+ }\r
\r
+-QString SlaOutputDev::convertPath(GfxPath *path)\r
++QString SlaOutputDev::convertPath(POPPLER_CONST_083 GfxPath *path)\r
+ {\r
+       if (! path)\r
+               return QString();\r
+@@ -3688,7 +3688,7 @@ QString SlaOutputDev::convertPath(GfxPath *path)
\r
+       for (int i = 0; i < path->getNumSubpaths(); ++i)\r
+       {\r
+-              GfxSubpath * subpath = path->getSubpath(i);\r
++              POPPLER_CONST_083 GfxSubpath * subpath = path->getSubpath(i);\r
+               if (subpath->getNumPoints() > 0)\r
+               {\r
+                       output += QString("M %1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));\r
+diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
+index 60fb90061..d928fada8 100644
+--- a/scribus/plugins/import/pdf/slaoutput.h
++++ b/scribus/plugins/import/pdf/slaoutput.h
+@@ -282,7 +282,7 @@ private:
+       void getPenState(GfxState *state);\r
+       QString getColor(GfxColorSpace *color_space, POPPLER_CONST_070 GfxColor *color, int *shade);\r
+       QString getAnnotationColor(const AnnotColor *color);\r
+-      QString convertPath(GfxPath *path);\r
++      QString convertPath(POPPLER_CONST_083 GfxPath *path);\r
+       int getBlendMode(GfxState *state);\r
+       void applyMask(PageItem *ite);\r
+       void pushGroup(const QString& maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);\r
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -1189,6 +1189,11 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
+       catalog = catA;\r
+       pdfDoc = doc;\r
+       updateGUICounter = 0;\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 84, 0)\r
++      m_fontEngine = new SplashFontEngine(true, true, true, true);\r
++#elif POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 61, 0)\r
++      m_fontEngine = new SplashFontEngine(globalParams->getEnableFreeType(), true, true, true);\r
++#else\r
+       m_fontEngine = new SplashFontEngine(\r
+ #if HAVE_T1LIB_H\r
+       globalParams->getEnableT1lib(),\r
+@@ -1199,6 +1204,7 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
+       true,\r
+ #endif\r
+       true);\r
++#endif\r
+ }\r
\r
+ void SlaOutputDev::startPage(int pageNum, GfxState *, XRef *)\r
diff --git a/poppler-0.86.0.patch b/poppler-0.86.0.patch
new file mode 100644 (file)
index 0000000..8200f64
--- /dev/null
@@ -0,0 +1,201 @@
+--- scribus-1.5.6/scribus/plugins/import/pdf/importpdf.cpp
++++ scribus-1.5.6/scribus/plugins/import/pdf/importpdf.cpp
+@@ -792,14 +792,15 @@ bool PdfPlug::convert(const QString& fn)
+                                                               names = catDict.dictLookup("OpenAction");\r
+                                                               if (names.isDict())\r
+                                                               {\r
+-                                                                      LinkAction *linkAction = nullptr;\r
++                                                                      std::unique_ptr<::LinkAction> linkAction;\r
+                                                                       linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());\r
+                                                                       if (linkAction)\r
+                                                                       {\r
+-                                                                              LinkJavaScript *jsa = (LinkJavaScript*)linkAction;\r
++                                                                              LinkJavaScript *jsa = static_cast<LinkJavaScript *>(linkAction.get());
+                                                                               if (jsa->isOk())\r
+                                                                               {\r
+-                                                                                      QString script = UnicodeParsedString(jsa->getScript());\r
++                                                                                      const GooString scriptGooString(jsa->getScript());
++                                                                                      QString script = UnicodeParsedString(&scriptGooString);\r
+                                                                                       if (script.startsWith("this."))\r
+                                                                                       {\r
+                                                                                               script.remove(0, 5);\r
+--- scribus-1.5.6/scribus/plugins/import/pdf/slaoutput.cpp
++++ scribus-1.5.6/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -324,7 +324,7 @@ LinkAction* SlaOutputDev::SC_getAddition
+               {\r
+                       Object actionObject = additionalActionsObject.dictLookup(key);\r
+                       if (actionObject.isDict())\r
+-                              linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI());\r
++                              linkAction = (LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI())).release();\r
+               }\r
+       }\r
+       return linkAction;\r
+@@ -455,7 +455,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot
+                       POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
+                       if (ndst)\r
+                       {\r
+-                              LinkDest *dstn = pdfDoc->findDest(ndst);\r
++                              std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
+                               if (dstn)\r
+                               {\r
+                                       if (dstn->getKind() == destXYZ)\r
+@@ -499,7 +499,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot
+                       POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
+                       if (ndst)\r
+                       {\r
+-                              LinkDest *dstn = pdfDoc->findDest(ndst);\r
++                              std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
+                               if (dstn)\r
+                               {\r
+                                       if (dstn->getKind() == destXYZ)\r
+@@ -516,8 +516,9 @@ bool SlaOutputDev::handleLinkAnnot(Annot
+       else if (act->getKind() == actionURI)\r
+       {\r
+               LinkURI *gto = (LinkURI*)act;\r
++              const GooString uriGooString(gto->getURI());
+               validLink = true;\r
+-              fileName = UnicodeParsedString(gto->getURI());\r
++              fileName = UnicodeParsedString(&uriGooString);\r
+       }\r
+       if (validLink)\r
+       {\r
+@@ -929,8 +930,9 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Lact;\r
+                       if (jsa->isOk())\r
+                       {\r
++                              const GooString scriptGooString(jsa->getScript());
+                               ite->annotation().setActionType(1);\r
+-                              ite->annotation().setAction(UnicodeParsedString(jsa->getScript()));\r
++                              ite->annotation().setAction(UnicodeParsedString(&scriptGooString));\r
+                       }\r
+               }\r
+               else if (Lact->getKind() == actionGoTo)\r
+@@ -967,7 +969,7 @@ void SlaOutputDev::handleActions(PageIte
+                               POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
+                               if (ndst)\r
+                               {\r
+-                                      LinkDest *dstn = pdfDoc->findDest(ndst);\r
++                                      std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
+                                       if (dstn)\r
+                                       {\r
+                                               if (dstn->getKind() == destXYZ)\r
+@@ -1019,7 +1021,7 @@ void SlaOutputDev::handleActions(PageIte
+                               POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
+                               if (ndst)\r
+                               {\r
+-                                      LinkDest *dstn = pdfDoc->findDest(ndst);\r
++                                      std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
+                                       if (dstn)\r
+                                       {\r
+                                               if (dstn->getKind() == destXYZ)\r
+@@ -1039,7 +1041,8 @@ void SlaOutputDev::handleActions(PageIte
+               else if (Lact->getKind() == actionUnknown)\r
+               {\r
+                       LinkUnknown *uno = (LinkUnknown*)Lact;\r
+-                      QString actString = UnicodeParsedString(uno->getAction());\r
++                      const GooString actionGooString(uno->getAction());
++                      QString actString = UnicodeParsedString(&actionGooString);\r
+                       if (actString == "ResetForm")\r
+                       {\r
+                               ite->annotation().setActionType(4);\r
+@@ -1082,8 +1085,9 @@ void SlaOutputDev::handleActions(PageIte
+               else if (Lact->getKind() == actionNamed)\r
+               {\r
+                       LinkNamed *uno = (LinkNamed*)Lact;\r
++                      const GooString nameGooString(uno->getName());
+                       ite->annotation().setActionType(10);\r
+-                      ite->annotation().setAction(UnicodeParsedString(uno->getName()));\r
++                      ite->annotation().setAction(UnicodeParsedString(&nameGooString));\r
+               }\r
+               else\r
+                       qDebug() << "Found unsupported Action of type" << Lact->getKind();\r
+@@ -1096,7 +1100,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setD_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1110,7 +1115,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setE_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1124,7 +1130,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setX_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1138,7 +1145,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setFo_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1152,7 +1160,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setBl_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1166,7 +1175,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setC_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
+@@ -1180,7 +1190,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setF_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                               ite->annotation().setFormat(5);\r
+                       }\r
+@@ -1195,7 +1206,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setK_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                               ite->annotation().setFormat(5);\r
+                       }\r
+@@ -1210,7 +1222,8 @@ void SlaOutputDev::handleActions(PageIte
+                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
+                       if (jsa->isOk())\r
+                       {\r
+-                              ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));\r
++                              const GooString scriptGooString(jsa->getScript());
++                              ite->annotation().setV_act(UnicodeParsedString(&scriptGooString));\r
+                               ite->annotation().setAAact(true);\r
+                       }\r
+               }\r
diff --git a/qt-5.15.patch b/qt-5.15.patch
new file mode 100644 (file)
index 0000000..5b9bc00
--- /dev/null
@@ -0,0 +1,10 @@
+--- scribus-1.5.5/scribus/ui/scresizecursor.cpp~       2019-07-31 00:34:50.000000000 +0200
++++ scribus-1.5.5/scribus/ui/scresizecursor.cpp        2020-08-01 12:08:46.353067959 +0200
+@@ -12,6 +12,7 @@
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPixmap>
+ #include <QPen>
+ #include <QBrush>
diff --git a/scribus.desktop b/scribus.desktop
deleted file mode 100644 (file)
index 1d87d84..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Scribus
-Name[fa]=اسکریباس
-Name[lo]=ສະຄຣີບັດສ໌
-GenericName=Desktop Publishing
-GenericName[af]=Werkskerm Publisering
-GenericName[bg]=Издателска програма
-GenericName[bs]=Stono izdavaštvo (DTP)
-GenericName[ca]=Publicació d'escriptori
-GenericName[cs]=Publikování na desktopu
-GenericName[cy]=Cyhoeddi Penbwrdd
-GenericName[da]=Dtp
-GenericName[eo]=DTP-programo
-GenericName[es]=Publicación de escritorio
-GenericName[et]=Küljendusrakendus
-GenericName[fa]=نشر میزکار
-GenericName[fi]=Julkaisuohjelma
-GenericName[fr]=Publication de bureau
-GenericName[he]=הוצאה לאור שולחנית
-GenericName[hr]=Stolno izdavaštvo
-GenericName[hu]=Kiadványszerkesztés
-GenericName[it]=Pubblicazioni
-GenericName[ja]=デスクトップパブリッシング
-GenericName[lo]=ເດດທອບພັລບບີດຊິງ
-GenericName[lt]=Darbastalio leidykla
-GenericName[nb]=Datatrykkeprogram
-GenericName[nn]=Datatrykk
-GenericName[nso]=Kwalakwatso ya Desktop
-GenericName[pl]=Program do składu tekstu
-GenericName[pt]=Publicação no Ecrã
-GenericName[pt_BR]=Publicação do Ambiente de Trabalho
-GenericName[ru]=Настольное издательство
-GenericName[sl]=Namizno založništvo
-GenericName[sr]=Стоно издаваштво
-GenericName[ss]=Kushicelela ku desktop
-GenericName[sv]=Dáhtaprentenprográmma
-GenericName[th]=เดสก์ทอปพับลิชชิง
-GenericName[tr]=Desktop Yayıncılık
-GenericName[uk]=Видавнича система
-GenericName[uz]=Кичик нашриёт
-GenericName[ve]=U andadza Desikithopo
-GenericName[xh]=Upapasho lwe Desktop
-GenericName[zh_CN]=桌面出版
-GenericName[zh_TW]=桌面出版
-GenericName[zu]=Ukushicilelwa kwe-Desktop
-TryExec=scribus
-Exec=scribus %f
-MimeType=application/x-scribus;
-Terminal=false
-Icon=scribusicon
-Type=Application
-X-StandardInstall=false
-Categories=Qt;Office;X-Misc;
-StartupWMClass=scribus
-X-KDE-SubstituteUID=false
-X-KDE-Username=
-# vi: encoding=utf-8
index 967ee0bfce3df60a041e0dcb9e71caaa8f86bcca..593da80c303d5f2ac91a91fbf652f6d016a72d97 100644 (file)
@@ -8,21 +8,28 @@
 Summary:       Scribus - Open Source Desktop Publishing
 Summary(pl.UTF-8):     Scribus - DTP dla Wolnego Oprogramowania
 Name:          scribus
-Version:       1.4.4
-Release:       2
+Version:       1.5.5
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Publishing
 Source0:       http://downloads.sourceforge.net/scribus/%{name}-%{version}.tar.xz
-# Source0-md5: a5714ee53074d4b8b77b59612f5e27a8
-Source1:       %{name}.desktop
+# Source0-md5: 6a9ddc8c45356d3c6c741e4c7bb0565a
 Patch1:                %{name}-standard-font-paths.patch
 Patch2:                %{name}-docs.patch
 Patch3:                %{name}-sparc.patch
+Patch4:                qt-5.15.patch
+Patch5:                poppler-0.84.0.patch
+Patch6:                poppler-0.86.0.patch
+Patch7:                gcc10.patch
 URL:           http://www.scribus.net/
-BuildRequires: QtCore-devel
-BuildRequires: QtGui-devel
-BuildRequires: QtNetwork-devel
-BuildRequires: QtXml-devel
+BuildRequires: GraphicsMagick-devel
+BuildRequires: Qt5Core-devel
+BuildRequires: Qt5Gui-devel
+BuildRequires: Qt5Network-devel
+BuildRequires: Qt5OpenGL-devel
+BuildRequires: Qt5PrintSupport-devel
+BuildRequires: Qt5Widgets-devel
+BuildRequires: Qt5Xml-devel
 %{?with_cairo:BuildRequires:   cairo-devel >= 1.2.0}
 BuildRequires: cmake >= 2.4.5
 %if %{with cups}
@@ -30,21 +37,36 @@ BuildRequires:      cups-devel
 %else
 BuildConflicts:        cups-devel
 %endif
+BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel >= 2.1.0
+BuildRequires: harfbuzz-devel
+BuildRequires: harfbuzz-icu-devel
+BuildRequires: hunspell-devel
 BuildRequires: lcms-devel >= 1.09
 %{!?with_cairo:BuildRequires:  libart_lgpl-devel >= 2.3.14}
+BuildRequires: libcdr-devel
+BuildRequires: libfreehand-devel
+BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel
+BuildRequires: libmspub-devel
+BuildRequires: libpagemaker-devel
 BuildRequires: libpng-devel
+BuildRequires: libqxp-devel
+BuildRequires: librevenge-devel
 BuildRequires: libtiff-devel
+BuildRequires: libvisio-devel
 BuildRequires: libxml2-devel
+BuildRequires: libzmf-devel
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: podofo-devel
+BuildRequires: poppler-cpp-devel
+BuildRequires: poppler-devel
 BuildRequires: python-devel
 BuildRequires: python-modules
-BuildRequires: qt4-build
-BuildRequires: qt4-linguist
-BuildRequires: qt4-qmake
+BuildRequires: qt5-build
+BuildRequires: qt5-linguist
+BuildRequires: qt5-qmake
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.577
 BuildRequires: sed >= 4.0
@@ -74,8 +96,6 @@ przeznaczony głównie, lecz nie tylko, dla systemu Linux(R).
 Summary:       Header files for Scribus plugins development
 Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia wtyczek Scribusa
 Group:         Development/Libraries
-# currently it doesn't require base
-Requires:      qt-devel
 
 %description devel
 Header files for Scribus plugins development.
@@ -129,37 +149,36 @@ Domyślne szablony dokumentów dostarczane wraz ze Scribusem.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
-export QTDIR=%{_prefix}
-export KDEDIR=%{_prefix}
+mkdir -p build
+cd build
 
-%cmake . \
+%cmake .. \
        -DASPELL_EXECUTABLE=%{_bindir}/aspell \
+       -DWANT_GRAPHICSMAGICK:BOOL=ON \
 %if %{with cairo}
        -DWANT_CAIRO=1
 %else
        -DWANT_LIBART=1
 %endif
 
-%{__make} -j1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install $RPM_BUILD_ROOT%{_datadir}/%{name}/icons/scribus.png $RPM_BUILD_ROOT%{_pixmapsdir}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.lt_LT.qm $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.lt.qm
 
-mv $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.lt_LT.qm $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.lt.qm
-
-%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/doc/{AUTHORS,BUILDING,COPYING,ChangeLog,ChangeLogSVN,NEWS,PACKAGING,README,TODO}
-
-# currently not used, -devel subpackage?
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/doc/{AUTHORS,COPYING,ChangeLog,README,LINKS,TRANSLATION}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -174,25 +193,23 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog ChangeLogSVN NEWS README
+%doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/scribus
 %dir %{_libdir}/%{name}
-%{_libdir}/%{name}/import.prolog
-%{_datadir}/%{name}/unicodenameslist.txt
-# don't mark dictionaries with lang() --misiek
-%{_datadir}/%{name}/dicts
-%{_datadir}/%{name}/editorconfig
-%{_datadir}/%{name}/keysets
+%{_libdir}/%{name}/scribus.css
 %dir %{_libdir}/%{name}/plugins
 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so*
 %dir %{_libdir}/%{name}/plugins/gettext
 %attr(755,root,root) %{_libdir}/%{name}/plugins/gettext/*.so*
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}/dicts
+%{_datadir}/%{name}/editorconfig
+%{_datadir}/%{name}/keysets
 %dir %{_datadir}/%{name}/profiles
 %dir %{_datadir}/%{name}/translations
 %{_datadir}/%%{name}/translations/scribus*.qm
 %dir %{_datadir}/%{name}/swatches
 %{_datadir}/%{name}/swatches/*
-%dir %{_datadir}/%{name}
 %{_datadir}/%{name}/dtd
 %{_datadir}/%{name}/icons
 %{_datadir}/%{name}/loremipsum
@@ -203,40 +220,20 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/samples/*.py
 %dir %{_datadir}/%{name}/scripts
 %{_datadir}/%{name}/scripts/*
+%{_datadir}/%{name}/unicodenameslist.txt
 %{_desktopdir}/%{name}.desktop
+%{_iconsdir}/hicolor/*x*/apps/scribus.png
+%{_datadir}/metainfo/scribus.appdata.xml
 %{_mandir}/man1/%{name}.1*
 %lang(de) %{_mandir}/de/man1/%{name}.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}.1*
-%{_pixmapsdir}/%{name}.png
-%{_datadir}/mimelnk/application/vnd.scribus.desktop
-
-#%files devel
-#%defattr(644,root,root,755)
-#%{_includedir}/scribus
 
 %files docs
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}/doc
-%{_datadir}/%{name}/doc/*
-##%dir %{_datadir}/%{name}/doc/en
-##%{_datadir}/%{name}/doc/en/*
-##%dir %{_datadir}/%{name}/doc/it
-##%{_datadir}/%{name}/doc/it/*
-#%%lang(cs) %dir %{_datadir}/%{name}/doc/cs
-#%%lang(cs) %dir %{_datadir}/%{name}/doc/cs/tutorials
-#%%lang(cs) %dir %{_datadir}/%{name}/doc/cs/tutorials/scribus-short-words
-#%%lang(cs) %{_datadir}/%{name}/doc/cs/tutorials/scribus-short-words/*
-#%%lang(de) %dir %{_datadir}/%{name}/doc/de
-#%%lang(de) %{_datadir}/%{name}/doc/de/*
-#%%lang(fr) %dir %{_datadir}/%{name}/doc/fr
-#%%lang(fr) %{_datadir}/%{name}/doc/fr/*.*ml
-#%%lang(fr) %dir %{_datadir}/%{name}/doc/fr/tutorials
-#%%lang(fr) %dir %{_datadir}/%{name}/doc/fr/tutorials/scribus-short-words
-#%%lang(fr) %{_datadir}/%{name}/doc/fr/tutorials/scribus-short-words/*
-#%%lang(pl) %dir %{_datadir}/%{name}/doc/pl
-#%%lang(pl) %dir %{_datadir}/%{name}/doc/pl/tutorials
-#%%lang(pl) %dir %{_datadir}/%{name}/doc/pl/tutorials/scribus-short-words
-#%%lang(pl) %{_datadir}/%{name}/doc/pl/tutorials/scribus-short-words/*
+%{_datadir}/%{name}/doc/en
+%lang(de) %{_datadir}/%{name}/doc/de
+%lang(it) %{_datadir}/%{name}/doc/it
 
 %files icc
 %defattr(644,root,root,755)
@@ -244,34 +241,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files templates-base
 %defattr(644,root,root,755)
-%dir %{_datadir}/%{name}/templates
-%{_datadir}/%{name}/templates/*.xml
-%dir %{_datadir}/%{name}/templates/br1
-%{_datadir}/%{name}/templates/br1/*
-%dir %{_datadir}/%{name}/templates/nl1
-%{_datadir}/%{name}/templates/nl1/*
-#%%dir %{_datadir}/%{name}/templates/sc_presentation
-#%%{_datadir}/%{name}/templates/sc_presentation/*
-%dir %{_datadir}/%{name}/templates/textbased
-%{_datadir}/%{name}/templates/textbased/*
-%dir %{_datadir}/%{name}/templates/buscard*
-%{_datadir}/%{name}/templates/buscard*/*
-%dir %{_datadir}/%{name}/templates/cover*
-%{_datadir}/%{name}/templates/cover*/*
-%dir %{_datadir}/%{name}/templates/grid_*
-%{_datadir}/%{name}/templates/grid_*/*
-%dir %{_datadir}/%{name}/templates/cc
-%{_datadir}/%{name}/templates/cc/*
-%dir %{_datadir}/%{name}/templates/mc
-%{_datadir}/%{name}/templates/mc/*
-%dir %{_datadir}/%{name}/templates/pres_backgr*
-%{_datadir}/%{name}/templates/pres_backgr*/*
-
-%if 0
-  /usr/lib/scribus/import_la.prolog
-   /usr/share/scribus/scripts/ChangeLog
-   /usr/share/scribus/scripts/NEWS
-   /usr/share/scribus/scripts/ReadMe
-   /usr/share/scribus/scripts/TODO
-   /usr/share/scribus/unicodenameslist.txt
-%endif
+%{_datadir}/%{name}/templates
This page took 0.246266 seconds and 4 git commands to generate.